CTM is deactivating avast! Antivirus

I love the idea about CTM but … :frowning: ???

I tried different possibilities but at the end CTM is always automatically blocking/deactivating my avast! Free Antivirus which is not acceptable.
After the CTM install my antivirus is immediately deactivated. I also tried to first install CTM and afterwards avast! and it was working fine for more or less 3 days before it got deactivated again. In the meantime avast! did a few virus updates. As soon as a uninstall CTM, avast! is working 100% properly again!
I’m quite sure that this is a CTM issue.

I’m using a desktop computer with WinXP SP3 and avast! Free Antivirus and of course COMODO Firewall. :wink:

hi, firefoxx
thanks for your feedback
could you please tell us which version of avast! Free Antivirus?


Same problem. CTM is not compatible with avast! free antivirus (version 5). Seemed to be working quite fine (after turning Intel Turbo Memory off which is causing huge problems as well). However when I tried to resed the baseline, computer rebooted, created new installation snapshot and this turned avast! antivirus into an useless ■■■■.
A have also detected problems with Google Desktop after reseting baseline. All passwords (gmail gadget, gmail calendar gadget) were deleted.

Lets face it - CTM is not stable at all. So many problems. Should be released as a beta version and not offered as a stable product! So many times it has ruined my computer (XP and Vista - uninstall issues, incompatibility with Intel Turbo Memory, Avast antivirus, Google desktop probably as well…)
Thanks God for Paragon and their image software.

I have the same computer environment (winxp sp3 + avast!free anitivirus5.0.465 (English) + comodo time machine v2.6.138262.166 + CIS) , but the avast works well,at least now, and it can update, scan all computer.

i encounter some problems before(after i install CTM ,the computer appears some text options just as booting menu before entering the windows ), and then i reinstall the computer several times. Finally i found the it should be the “MY installing self-making CD.”

It’s a well known problem (I mean, avast installation corruption) if you restore with the avast self-defense module ON. Maybe you can try to disable it before start to restoring with CTM.
This happens specially if between the restore point (or baseline) and the moment you’ve started the restoration there were a program update of avast. Some roll backs will work (for some users) depending on the status of avast update program.

I’m not using CTM as I cannot manage to even install it in a multi-partition disk and some TrueCrypt partitions among them. But I could test with competitors roll back tools.

Perhaps i can shed some light on these corruption issues reported.

I believe that the logic of people getting corrupted data when restoring their snapshots is actually the other way round. The corruption is probably ( Im actually fairly certain of it) occurring when TAKING the snapshot.

A few years ago Rollback was also suffering from these inexplicable and intermitent corruptions when Rolling back. I recall the problem was eventually traced to the harddrive not being completely flushed prior to taking a snapshot (more specifically…something about a virtual disk) and also a problem with the virtual disk not flushing completely (occasionally) when the computer was shutting down. This resulted in a corrupted snapshot which only became evident when you went and rolled back to it. The symptoms were exactly what has been reported in these forums for some time now.

So perhaps Comodo might make use of this information in an effort to greatly improve CTM’s battered reputation.

Rollback uses device drivers to virtualize the Windows pagefiles for faster system bootup and system performance.

The pagefile virtualization has three modules:
The filter and redirect disk IOs to the pagefile
Be able to hook the pagfile on system bootup.
Be able to close the pagefile virtualization when system shuts down.

The bug is with the third module C… When shutting down a PC, supposedly Windows should wait for all processes and threads to exit and complete before shutting down the PC.

But we found out on some cases, the Windows system just shuts down regardless if there are still running processes or threads. In this case it’s Rollback’s module to close the pagefile virtualization.

In the case when the system shuts down before Rollback Rx closes the pagefile virtulization, there could be data in the pagefile that’s not committed to the hard disk.

Therefore the data on the hard disk could become inconsistent – missing the pieces from the pagefile.

And because the data on the hard disk are inconsistent, the Windows chkdsk will appear on reboots….

So the chkdisk is really not the problem, it’s just a symptom of the problem.

This bug is quite nasty, it’s certainly a level one bug. Because it could make files become corrupted over time – without obvious reasons.

I found a communication on the Rollback forums regarding the issue i discussed. Horizon actually say that this bug was introduced in V9 but i had corruption issues with Rollback since v8. 88) Of particular interest is the last sentence. I’m happy to report that Rollback is now rock solid. ;D

The point is that this is a real starting point to get this corruption issue resolved.

Installed CTM and it does NOT deactivate avast Internet Security (AIS).
Take care on restoring a snapshot (better will be excluding avast folders - install and programdata ones - from CTM.