CTM can't fix a /Boot/bcd error

Hi there comodo guru’s,

My netbook with Windows 7 starter suddenly gives the next error message during system boot (directly after the CTM console screen).

File: \Boot\Bcd

Status: 0xc000000f

Info: An error occured while attempting to read the boot configuration data.

So i thought “hey easy to solve… I just use CTM to go back to a snapshop prior to this error message.” Man did i get disapointed. I tried several snapshots. I even tried the baseline, but the error is still there. Now i wonder what good CTM does to me if it can’t restore a system error like this? Is’t CTM supposed to be able to recover from an error like this?

One more question, to solve this issue i probably need to use the windows recovery feature. Does anyone know if this will go well with CTM still installed or should i first uninstall CTM (at boot console) and then use the windows recovery feature?

Happy easter!!!

Best regards,

I managed to bix the error with the command BOOTREC /REBUILDBCD. I did not use the other bootrec commands, because i think that BOOTREC /FIXMBR will cause CTM not to work propaly anymore. Am i right with this assumption?

Though i still wonder why CTM can’t solve the /Boot/Bcd error if i rollback to a snapshot prior to the error. As far as i know is the boot configuration data nothing more than a hidden system file.
Is there a moderator available to look into this?

Best regards,

It happened again. On monday i solved the \Boot\Bcd error, then today the error is back again. What i did notice today is that CTM did defrag the HD earlier. Then in the afternoon we wanted to use the netbook again and the \Boot\Bcd problem is back. We have two netbooks. They both have the same configuration and the installed software is almost the same.

Brand: Packard Bell
OS: Windows 7 starters
Firewall: CIS (latest)
AV: Avast 5
Windows defrag: disabled
Windows restore: disabled

The only difference is that 1 netbook uses CTM 2.5 and the other one CTM 2.6. The one that has the problem is CTM 2.5. Does anybody know if this BCD error is related to CTM?

I did check the release notes of 2.6 to see if a bug concerning the BCD has been solved in 2.6, but i must say that your release note is worthless. A text as FIXED! A couple of critical bugs and FIXED! More than 20 GUI bugs doesn’t tell anything at all. Please give us a clear list with a bug by bug description of what you did exactly solve. Or else don’t even bother to make a release note at all.

Next it would be nice if some moderator would reply to my posts!

Hey marlonvdb,

Please note that the moderators on these forums are not Comodo employees. Nor are they necessarily any more experienced than you.

The primary function of a moderator is to moderate the forums, not to be an expert on every piece of software.

I’ll see if I can get one of the devs to have a look at your issue.

Ewen :slight_smile:

Hi Ewen,

Sorry!!! I thought the moderators were part of the comodo development team.
But are there active forum members who also are part of the development team?

Thanks! I appreciate it.

Best regards,

No problems. :wink:

But are there active forum members who also are part of the development team?

The devs are regular readers of the forums and quite a few of the devs regularly contribute on the various boards.

Ewen :slight_smile:

Hi Ewen,

For you info, i repaired the damaged BCD of my second netbook and updated CTM from 2.5 to 2.6. No problems did occur during the update. It went very smooth :). Last time the corrupted BCD store did occur 3 days after the system was recovered/repaired (the damaged BCD did happen two times). Now let’s see if it will happen again. If not, then it could indicate that the damaged BCD store had something to do with CTM 2.5. Anyway, i will keep you updated.

Thanks Marlon

:frowning: It happened again. Again the /Boot/Bcd file got damaged. The CTM version is 2.6…166. I’m not really sure why it keeps on damaging the bcd store or if it is really CTM that causes this, though it happened the first time 4 days after CTM 2.5 got installed. Then we repaired the bsd store and 3 days after that it did happen again. Again we repaired the the bsd store and this time upgraded CTM to 2.6. Today (4 days later) again the bsd store is damaged. Till now no comodo dev guy did tell me if there is an issue with CTM that can cause this problem, though i did see some threads on this forum about damaged bsd. Either they don’t read this post or they just don’t want to answer. This way this forum is becoming useless.
Anyway, if it is CTM that causes this, then please change the name from CTM to CTB (Comodo Time Bomb)

Nobody ever did answer that question. Does anybody have any idea?

Hi, marlonvdb, it’s a known issue and we are working on it.


Is there an update on this issue? I am using 2.8, and am having the same.

If this issue has been taken care of in another topic/discussion, could someone link it please? Thanks!

[at] Marlon & Exo:

I hope you guys have full backups of your Windows disks/partitions and not just rely on CTM! In the past I have also experienced the same issue. Fortunately I had my trusty Acronis 2012 startup media and I was able to boot from it and restore the boot sector from a previously saved sector-by-sector Acronis backup (which contained CTM after it was installed for the first time, with only the baseline snapshot taken at that point). Restoring the boot sector this way takes no time at all and then you are good to go.

Obviously my Acronis backup contains only the baseline on the day the backup was taken. Restoring the full backup would obviously destroy my current snapshots. Restoring only the boot sector means that CTM will be functional again and any current snapshots will not be affected.

Of course you don’t have to use Acronis for such a purpose. You can use any decent backup app or boot sector backup/restore utility, for as long as it gives you the option to create a start-up media so you can use it outside Windows for cases where the computer won’t boot.

Hey KoPRo - Thanks for the work around, I really appreciate it. I only use my computer for surfing, and minimal work, (that’s mostly web based) so the need for docs and other pc info is not pertinent. I was just curious to know if the known issue was ever resolved, because it was posted of May of 2010 that they were working on it.

Edit - I came across a solution for myself. Maybe this can help others, or anyone who might come across this forum page.

I believe the reason for the BCD error is because if there is a snapshot saved at each restore, it overloads the amount of space available on the machine. I was snapshotting every morning at 0300 and after ~2 weeks I came across this error.

Solution? Delete all unlocked snapshots after a new one is made, and then there were no issues thereafter. I hope this helps.

Here is another issue I could use some help with.

I made the mistake to enable the Startup Recovery Manager.
Realized it didn’t work well with my multi-Raid system and uninstalled it again.

the Recovery Manager makes changes to the VISTA BCD and now I get a brief flicker saying: MBR Error 3

It just flashes by and the system boots and works fine thereafter.

However, this bothers me. Tried the bootrec.exe /fixmbr …tells me it completes but it doesn’t fix the issue.
If I try /fixboot or /rebuildbcd…it tells me something missing.

Does anyone have an idea how I can do this step by step?