CSE & Outlook 2003 - two more problems

Using CSE with CAS & Outlook 2003

  1. CSE seems to load in the context of programs other than Explorer or Outlook. For example it frequently loads in the context of Filezilla FTP server & Comodo Cmdagent (part of CIS). Filezilla is not mail enabled. Maybe this causes problem 2.

  2. Since new version of CSE (and new version of CAS) email receipt in Outlook 2003 seems to get locked on occasion. (Fails to receive, but no server timeout message). Restarting outlook usually resolves. This could be a CAS or CSE problem, or an interaction - have raised in CAS forum.

*Your Operating System and Whether if it is 64 bit or 32 bit. XP SP3 32bit

*Security Software installed (Anti-Virus, Anti-Spyware, etc). CIS, CV, CMF, CSE, CAS; Avira (mail filtering disabled)

*How you produced the problem (How you got to the issue in the first place). Receiving emails in Outlook

*If possible, how you tried or resolved the problem (Did you change any settings in CSE or uninstall it, etc). Tried exiting CSE - no change. Restart Outlook resolves for a while. Disabling CAS seems to reduce frequency but not eliminate.

*Any other details that might help.

Hi Mouse1,

We’ve looking into these issues now and will respond to you soon.

Thanks for so professional and clear description of problems. :slight_smile:

Regards, Eugene.

Hello there,

I have the same problem as mouse1. Once or twice every day, Outlook 2007 SP2 would fail to retrieve emails. Closing and reopening Outlook would solve the problem. This problem appeared after I first installed Comodo Secure Email Updating to did not change anything.

My OS: XP SP3 32 bits
My antivirus: GDATA 2008
My firewall: Comodo Firewall Pro

Hope someone can find a solution besides uninstalling CSE.

Thank you all, have a good day.


Windows XP Professional SP3 32-bit
Comodo AV, Firewall, Defender 3.10.10…
Outlook 2003

When Outlook is application is closed it does not get closed out of Active Applications list. Consequence is that re-opening Outlook later on during the same win login session creates a second instance in Active Applications and send / receive process does not execute.

When and user shuts down Active Applications gets cleared and all is well again.

It is possible to clear Outlook from Active Applications list manually prior to re-opening and then it will open and send/recieve normally unless closed and reopened (recreating the problem above).

Perhaps there may be an issue with the interaction of Outlook and Active Applications list maintenance. In any event the problem is annoying but non-destructive

I think that Outlook normally recognises when there is another instance running (at least it does on my machine), but some plug-ins interfere with this behavoir, by making Outlook stay open with no window when the user requests closure.

CAS has this effect on occasions I think - or at least this rarely happens on my machine unless CAS is operating. CSE may cause the problem too. The source is quite likely one of the deeper CAS or CSE bugs assopciated with a plugin used by both maybe? See bug reports in CAS forum on leaking resources, and hung CASproc.exe instances.

I agree it can normally be resolved as you described. However on occasions, when a hanging CASproc seems to be causing the problem, the hanging CASproc may persist between logon sessions. Then the email account linked to the CAS proc cannot be downloaded from without some deeper surgery. (Switching spam protection on and off in CAS and deleting Quarantine DB and email cache files may resolve, at some risk of loss of emails or download of duplicates).

Hopfefully they’ll get the deep CAS and CSE bugs fixed soon! Sigh!


Glad this is on the radar - thanks for the update Mouse… compatability with Outlook has to be a high level issue given the millions of potential users adversely affected. Will be nice when fixed.


I am having similar issues. It’s funny, I have xp, vista32 and 64 machines and i am hoping that i dont have the same issues with my other machines because I am really begining to like comodo products a lot and had started recommending it to my clients as well. I do hope this issue gets resolved soon.

I started installation on the following configuration:

Lenovo T61
Vista32 Business
Comodo Internet Security
Outlook 2007

I got my certificate with no problems. When I start outlook both it and comodo secureemail begin to receive email - but when outlook seems to “see” securemail - it freezes and does nothing anymore!



Hi Draco

I’ve unistalled CSE now, as I am concentrating on getting bugs out of CAS. However I may install again in a few weeks. Also, now I am a moderator, I can refer this issue to other moderators.

To help with this process, perhaps you could post the information in the following, quite comprehensive, bug report format. It asks for a bit more than the standard bug report, but think this is worthwhile when trying to resolve a resistant problem like yours.

  1. What the problems is
  2. Whether you can reliably reproduce the problem and if so exactly how.
  3. Your Operating System & version (eg XP SP3):
  4. Other Security and Utility Software Installed (eg Norton Internet Security 2009):
  5. Email client & version (eg Outlook 2003):
  6. Email client add-ins (eg Mailbuddy):
  7. Email provider & account type (eg Hotmail.com, POP3/SMTP(SSL)):
  8. How you have tried to solve it, and what the result was:
  9. Please append memory dumps or screen shots if possible. If zipped, most can be uploaded.
  10. Any other information you think may help

Another thing you could do to track down the problem is to install sysinternals (now microsoft) process explorer, and watch what is happening a) when you boot b) when you try to retrieve email. I did this with CAS, and found that the CAS beta was somtimes launching in the context of EasyVPN and the wrong user account, thus explaining much… (If you install process explorer make sure you unzip from and directly into its final destination file. Also note that the usual cautions when using OS tools apply - don’t use the tool to make changes - viewing stuff is pretty safe - unless you understand what you are doing. Also save data and back up data and system first).

Hopefully we will be able to help, given this info…

Best wishes


[size=10pt]Almost ready to celebrate this problem’s one year anniversary without resolution ! ! ! ?

Great product in general but this fiddly problem is a tremendous nuisance. I am still recommending Comodo to folks in the hopes that this will be diagnosed and corrected sometime within the next … ?


Unfortunately we were unable to reproduce this issue.

New version of Comodo SecureEmail (2.5) with Outlook mode is on the Release Candidate stage.
In this version we have new mode - specially for Microsoft Outlook - plug-in mode.
(you can read more here:

Outlook plug-in mode has the following features:

  • Improved integration in Outlook (with MS Exchange Server support).
  • CSE configuration available from Outlook Tools->Options->Comodo SecureEmail.
  • Native support for all Outlook transport protocols and secure connections because transport is now complete by Outlook.
  • CSE support overrides Outlook’s encrypt/sign buttons, i.e. encryption and signing are handed over to CSE (e.g. Outlook button choice will take effect only if you choose to use Override mode else CSE rules do).
  • Outlook plug-in mode does not have conflicts with AV scanners that the LSP experienced.

Thanks for interesting in Comodo SecureEmail product.

Regards, Eugene