CSE 2300 outlook plugin warning message

I have installed the CSE Outlook Plugin. Everytime i want to send an email i get a warning message as shown in the attach. I’m sorry that its only in german but i will try to translate.
Its something like:
“While encrypting the message for the listed recipients an error occured. Maybe the digital ID doesnt exist or is invalid or the encryption is not compatible or not supported.”
-then the list of recipients-
“If you continue, the message will be encrypted and sent. Maybe the listed recipients cant read the message.”

Then i can only click on the left button (send unencrypted) or the right button (cancel) but not the middle button (continue).
So, when i click on the left button, the message will be sent and the recipient gets an email where he/she can choose to install CSE or use the webreader service.
So the Encryption seems to work fine but why is Outlook telling me its not working fine??

My System: Vista x64, Outlook 07, CSE (Outlook only install)

btw: good work! best stuff comes for free from comodo! :-TU

[attachment deleted by admin]

Hi EIC and welcome to the forum!

On some occasions CSEmail isn’t copying in the certificates into Outlook itself.

If you know where your certificate is stored on your harddrive then skip to [step 2].

Step 1: Open Comodo SecureEmail Configuration from Start>>Programs>>>Comodo>>>SecureEmail. Clickon “Certificates” on the left and then “Certificat Manager” on the right. Click Export and copy your certificate to the desktop.

Step 2: Open Outlook and click on Tools>>Options and then click on the “Security” Tab. Click on Import/Export and Import your certificate. Close Outlook and re-open it and send your message.

You’ll only have to do this once.


i imported the cert manually, started outlook again, but the warning message still pops up…

maybe it has something to do with the safety settings shown in the next attach?

[attachment deleted by admin]

You need to Untick the first two on the main window (not the little one on your screenshot)

Untick - Encrypt Contents And Attachments For Outgoing Messages

Untick - Add Digital Signature for outgoing.

Comodo SecureEmail does this for you and having these ticked can cause a conflict.


the strange thing is that i untick these two and when i restart outlook the boxes are ticked again…

and is this really necessary? in the changelog for 2300alpha: "* CSE support overrides Outlook’s encrypt/sign buttons, i.e. encryption and signing are handed over to CSE (e.g. Outlook button choice don’t take effect, CSE rules do).

I’ll have another look when i get home from work (5 hours). Can you do a screen shot of your settings in Comodo SecureEmail Configuration?

[b]EDIT: Just realized your running the Alpha version. Have you tried running the Stable version? (available to download from here: http://secure-email.comodo.com/download.html)

I’ve created an Alpha BUG Reports Topic and put a link to this thread.[/b]

I think i maybe know why this warning pops up.
I have sent this CSE-encrypted emails to recipients, from which i dont have a certificate installed. (The reason why i’m trying CSE is that i can send emails to people who dont use certificates, but can view it with the webreader service.)
So it would be logical that outlook warns me about that the recipient may not be able to read the message. But i do know that the recipient will get tha abilitiy to use the webreader so the warning will not be necessary for me personally.
If i’m right with this above, maybe we will see a tickbox to turn this warning off in next releases of CSE?

my CSE-settings are in the attach

EDIT: Yes, i tried but it didnt work with windows mail, windows live mail, thunderbird, outlook 2007 (tried all combinations of 32 and 64 bit CSE with these clients)
CSE scanned the folders but no popup poped up when i tried to send a mail → no encryption
I also tried on my 32bit xp → there the popup appeared but the client(s) showed an error, that they cannot send the message…
So i tried the and it seems to work → i just cant turn of the signing and encryption options in Outlook, which seems to cause my problem…

[attachment deleted by admin]

HI, Elc

Very strange, supports all these mail clients. We can send to you Diagnostic build that can help us found your issue and resolve it. What do you think about it?

CSE Alpha is turning on these settings automatically and don’t let user to turn off.

This warning is Outlook internal warning and this is NOT normal behaviour of CSE.

  1. Outlook requires that encrypted e-mails should be also signed - so please check your sender’s contact for certificate
  2. Check your recipient contact’s details - and remove the cert if it is exists for this contact (or just delete -create this contact)

Note: On your screenshot we can see incorrect e-mail address we don’t generate certs for this e-mail address - so warning is OK.

P.S. This is Alpha version - so it has some known issues and we are working on fixing them.

Thanks in advance.

Regards, Eugene.

Note: On your screenshot we can see incorrect e-mail address we don't generate certs for this e-mail address - so warning is OK.

I just made my email-adress not recognizable in photoshop…

Very strange, supports all these mail clients. We can send to you Diagnostic build that can help us found your issue and resolve it. What do you think about it?

For me, its ok. I would give it a try… just tell me how to get the Diagnostic build!

EDIT: I uninstalled 2300 and installed 2003 again → now i cant send emails anymore (not like before that i can send them but just unencrypted). I get an error with the code “0x80042109”


New Alpha II version is available for download:


Regards, Eugene

New version. ( Alpha II)

New try.

Now it works just fine!

Thanks and good work! :-TU