CSC Last Windows Update

I am a long time user almost since the beginning. I have had no trouble since starting to use Comodo CIS.

People are resistant to my hammering, it’s the best. Even after showing them Matousec’s site, pointing out that is has been number one for a long time and the version tested is usually two upgrades behind. They will still stick with the “Do Not Use” model.

I had CSC’s build 37 and sucessfully updated to 53 without any problems. Then last month’s Mircrosoft Windows update messed with 53 badly.

I can only use CSC build 53 once per boot. At this point, I can close the window properly. The next time I try to use it, it freezes the whole screen. I have to use task manager to shut CSC down.

Another oddity; During this period of time, instead of responding to left click commands, I have to use the enter button.

I have uninstalled several time and re-installed with the same results.

After I shut CSC down with task manager. Everything is nealy normal. I have tried with active clean on and off.

I looked in the Comodo folder and nothing has been uninstalled. Today I tried again to unistall and downloaded a fresh version. I received the abort, retry message. Can not install because updaterDLL.dll is missing from the system.

Thank you for all the wonderful products you have.