Crash of firefox and comodo using manual sandbox

I got this pop up (screenshot) but i could not upload so this is the reason i am posting here.

The bug/issue

  1. What you did:
    I was trying to run the on demand sandbox from comodo with firefox (untrusted). I did this using the right click of the mouse “Run in Comodo sandbox”.

  2. What actually happened or you actually saw:
    Firefox opened and immediately crashed. Then i tried a different approach (to try to run in partially limited), going to “D+” - “Run a program in the sandbox”, and when i was trying to choose again the firefox application comodo crashed ( i never had time to select the partially limited).

  3. What you expected to happen or see:
    For firefox and comodo not crushing (for firefox to work in untrusted).

  4. How you tried to fix it & what happened:
    i just restarted comodo, and it worked fine. But firefox once again did not work in untrusted.

  5. If its an application compatibility problem have you tried the application fixes?:

  6. Details (exact version) of any application involved with download link: Firefox 3.6.13. http://www.mozilla-europe.org/pt/firefox/

  7. Whether you can make the problem happen again, and if so exact steps to make it happen:
    Comodo never crashed again, but firefox does not work as untrusted, not even once, even in different computers but with the same programs and configurations.

  8. Any other information (eg your guess regarding the cause, with reasons):

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: yes
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
  3. A CIS config report or file.
  4. Crash or freeze dump file:Can´t find it

Your set-up

  1. CIS version, AV database version & configuration used:
    Version: 5.162636.1135, DT:7040, Configuration: proactive.

  2. a) Have you updated (without uninstall) from CIS 3 or 4:
    No clean install of version 5
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:

  3. a) Have you imported a config from a previous version of CIS:No
    b) if so, have U tried a standard config (without losing settings - if not please do)?:

  4. Other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here. ).
    Firewall: Ticked “Protect the ARP cache”, “Block Gratutuios ARP frames” “do protocol analisys”

  5. Defense+, Sandbox, Firewall & AV security levels:
    D+=Safe Mode , Sandbox=enabled , Firewall =Safe mode , AV = Stateful

  6. OS version, service pack, number of bits, UAC setting, & account type:
    OS: windows 7 Home Premium. 32 bits, UAC: default configuration, Account type: administrator account.

  7. Other security and utility software installed: sandboxie. On demand: malwarebytes. SAS, hitman pro.

  8. Virtual machine used (Please do NOT use Virtual box):No

[attachment deleted by admin]

Using safari browser, when i choose “Run in Comodo sandbox”, using the right click of the mouse, i get this Pop up,and of course i loose internet if i do not allow it. But if i choose “untrusted”, from “D+” - “Run a program in the sandbox”, there is no problem.
Internet explorer only works with partially limited.
Basically only opera works well with the on demand sandbox.

Safari 5.0.3. (7533.19.4)
internet explorer 8.0.7600.16385
PS- I do not know if this is a bug (if it is, i am sure someone already made a report),but if necessary i will use the correct format. But i think all the information needed is on my firs post.

[attachment deleted by admin]

Similar issue? https://forums.comodo.com/orphanedresolvedoutdated-issues-cis/bsod-badpoolerror-xp-sp3-t65128.0.html

We’ll need a crash dump for this unfortunately, or I will not be able to forward it.

You’ll find this in the following directory:

%AllUsersProfile%\Comodo\CISDumps

Don’t be confused by the % signs. Just type this path exactly as above into Windows Exlorer, or any windows file selection dialog box and you will go to the right place.

Best wishes

Mouse

Done

Thanks Mouse1