CPM Messing Up Windows System Assessment Tool ??

I am running CPM 1.1 build 44. It would appear that CPM is somehow involved in Win Experience Index assessment failure. In my case this occurs at the disk performance stage. While failure of winsat.exe to complete the WEI assessment does not (based on web searches) indicate that one’s system performance is, in any way, impaired, I like my Win 7 OS tools to work as they should.

After installing some driver updates, I ran winsat.exe to see if there were any performance improvements: winsat wouldn’t complete. Having had a few problems with CPM before, I targeted CPM as the possible culprit and I’ve tried a multitude of things like un-installing CPM and rerunning winsat, restoring early system-build images and re-installing various programs in normal and safe mode etc etc.

History: To see what was happening, I restored an early image of Win 7 install which included a few key app’s including CBM build 30 and ran winsat.exe (= OK). I up-dated Goodsync and then CPM build 44 and then ran winsat again (=OK). I then installed CIS and got BSODs with CPM’s cumon.sys as the culprit! I then re-installed CPM in Windows Safe Mode: no more BSODs. After a few more re-installs of other app’s (iTunes, Lacie Network Agent, Belkin USB Hub), I re-ran winsat.exe: winsat would not complete at disk assess’ stage again.

I then went back to my system restore point where I knew winsat was working with CPM build 44 and then I un-installed CPM. I then re-installed the additional app’s I’d installed before (i.e. when CPM was previously resident). Now winsat runs to completion.

Not conclusively a CPM bug, but indicative I believe.