CPM 1.2 - Always requesting reboot.


I have installed CPM (CPM_SETUP_1.2.188360.106_xp_vista_server2003_win7.exe) and post installation CPM requested me to reboot my system. I have restarted my machine and tried to launch CPM - surprisingly - it always requests me to reboot my machine again 88).

I then completely shut-down my machine and post restart tried to launch CPM - but same result. I then performed uninstall operation and reinstalled CMP and restarted my machine - but again it asked me to reboot my machine. :-\

Screen shot (CPM 1.2 - Requesting reboot.png) of the pop-up message has been attached with this post.

Awaiting a speedy reply - am tired of rebooting my machine :THNK

My machine details:

OS: Windows Vista Home Premium - SP2
Sys Type: 32 bit OS

Also attaching list of currently running processes and services fetched out by KillSwitch :-\

[attachment deleted by admin]

Do the solutions suggested in after uninstall performing forced delete is starting on every windows startup help? To be on the safe side rename the two mentioned files instead of deleting them.

To stop the reboot requests please delete the following registry key: HKEY_LOCAL_MACHINE\SOFTWARE\ComodoGroup\COMODOProgramsManager\Installer\CPMRestartCheck
Thank you.

Nopes, there is no - ‘forced delete message’. My intention was not to delete any file but to launch CPM after successful installation (followed by rebooting my machine) ;D

Under HKEY_LOCAL_MACHINE\SOFTWARE\ComodoGroup\ I don’t see “COMODOProgramsManager\Installer\CPMRestartCheck” :embarassed:

Does the user account you are currently using have administrator rights?
Also please check if the following key is present in the system registry: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce\CPM2

The user account am logged in as has Administrator rights and yes the above mentioned key is present in system registry with a value :

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce\CPM2 → “C:\Program Files\COMODO\COMODO Programs Manager\CPM.exe” /drivers_start 88)

Now … :-\ ???

  1. :frowning:

Please delete that key mentioned above from the system registry then uninstall CPM and reinstall it.
Also check any sandbox settings you have activated on your security software. The reason CPM keeps asking you to restart your system is the fact that something is preventing the driver from being activated (something is blocking the access to that registry key).

Edit: You can also check for the following key and delete it before you uninstall CPM: HKEY_LOCAL_MACHINE\SOFTWARE\ComodoProgramsManagerUpdate

Thanks but No Luck :cry:

I have deleted HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce\CPM2 → “C:\Program Files\COMODO\COMODO Programs Manager\CPM.exe” /drivers_start

Uninstalled - restarted - reinstalled - restarted - Launched CPM. It still asks me to reboot my system before I can use it >:(

Also, don’t see CPM being sandboxed by CIS or being blocked by Microsoft Security Essentials.