cpfres.dll in version NEW

Hi everyone

Guess what!!! I received the infamous cpfres.dll error with the new version… at start up, so I tried to recreate the issue and here is my research so I will share with all of you.

1.- As all we know (at this moment of the game) with version there is an issue with the GUI , it takes n-times to load
2.- While the GUI takes all the time to load if you click the desktop icon a second or more times, then it will open the GUI after the n-times to load (Step 1), at this moment it seems to be one instance loaded as the release note says
3.- Finally it opens the GUI
4.- Reboot your machine, and the two 0x0 cpfres.dll dialog windows will appear
5.- Reboot again with version .276 seems to happen one time (Steps 1-4)

Conclusion :

Avoid opening the GUI from the desktop icon, ALWAYS open the GUI from the tray and just in case you need to open from the desktop just wait until it opens , no matters how long it takes

(V) (R) (B)

I too have just recieved this error, for the second time this month!

Last time this happened I just assumed that it was taken out by a malicious application, I uninstalled it, disconnected from the internet, ran my virus scanner, which actually picked up a virus and cleaned it. Rebooted, then reinstalled Comodo, all was fine for about 2 weeks, now it’s happened again.


Now from looking in this forum I can see that it’s actually a bug with the application, is this correct?

No offence meant, but I can’t really trust a firewall that crashes, whether it’s a bug or been taken out by another application, it’s just too risky. I’ve only experienced this with the newer version, since the GUI was updated with new icons / graphics and the Defence + system introduced.

I quickly disabled the Defence+ system for a number of reasons, the main one was the amount of meaningless messages it prompts you to act upon, it just gets so frustrating and even though you tell it to remember your choices, it doesn’t. It works much better for me without it tbh.

Anyway, i’m going to finish this virus scan and if I find anything again, I’ll let you know, other than that, I’ll follow the steps pointed out on here.

Come on guys! :THNK

Firkin :

Did you check the version???, because since I recreated the error I had not troubles with the issue, as far I can see (No offense), but which version are working with??? or the, ahhh, and one last thing, the engine of CPF when the cpfres.dll happens still works, it’s the GUI that is affected, so as I say in my post the solution that the GUI simply should be be from the System GUI from the Oerating System (XP or Vista) and the problem will be gone

(B) (R) (V)



I have the latest versions of both Comodo and Avast and this bug still happens. It also takes a very long time for Comodo to try to load before the popups appear. This is with WinXP Home, fully updated. I have to launch Comodo manually, so of course I can’t launch it from the system tray icon, since it isn’t there. A fix would be gratefully appreciated.

For those getting the “cfpres.dll not found” error, get cfpres.dll from Program Files\Comodo\Firewall\repair and put it the Program Files\Comodo\Firewall folder. Reboot computer.

If you are getting “IsThreadDesktopComposited” errors, rename the DWMAPI.DLL file in WINDOWS\SYSTEM32 folder to DWMAPI.OLD.

I also did this (replacing cpfres.dll) yesterday to no effect. But I don’t think my error message says it’s not found, just that it can’t be executed or something.

Have you tried reinstalling?


I mean reinstalling the CFP 3.0…

Respectfully, this error has nothing to do with a need to replace the active file with one from the “repair” directory. The files are bit-for-bit identical. The problem is that the error pops up randomly so people do something and then assume they found a cure for the issue when it doesn’t happen the next time. But it will happen again… I can confirm that this error persists on my system with Nobody from Comodo has yet commented on this error anywhere I can find in the forums which disappoints me. It speaks to it not being repaired anytime soon :frowning:

Agree 100%

Actually, yes I did…no change. It’s a hassle to reinstall, too, because you have to answer all those prompts again.

May I ask when is Comodo is going to fix this bloody problem in this new version because it driving me up a reinforced concrete 500 thick hard wall (:AGY) (:AGY) :THNK and I’ve already add my vote (:AGY) (:AGY)

I’m averaging 3-4 times per week, so guess I fall in the 11-20 range (voted). I thought it was too much loading at startup, and stopped everything except CFP, Avast and BOC. But no joy. :frowning: It surely is aggravating.


Hello :

As far In can see some of you noticed the poll I post last week, I encourge for those who experience the cpfres.dll to colaborate with the poll. The intention is to send a powerful message to the developers of this great product (For me it’s a great product) to improve it.

Ahhh, and by the way I posted this poll in the .276 version , I invite to the ones who has the .268 version too, so again please, I ask for your vote.

The more the votes you post the better it will be, Ahhh and I will add a new option

HAPPY 2008



(B) (R) (V)


I’m not complaining about the Comodo Firewall product and the software, I believe deep down Comodo is a great firewall (:CLP) and I would never change it to another software firewall cause I am 100% stay with Comodo.

I am just asking and please I am already down to my knees just fix this bug problem…please. :■■■■

Speedy :

Relax, and nevermind, I know that you are not complaining, and the others who posts their issues aren’t complaining, just I’m a humble user (only have 54 post sent, counting this one), I like too much as you do this firewall for all that it delivers and how much cash do we pay for it??? 0 dollars,euros, pesos, bolivares, dinars, marks, etc etc etc etc. it’s a has a lot of features that if you want in another firewall you have to pay for it.

Unfortunately the GUI has this flaw, so when I posted this topic, I recreated the error, I did my research to find a workaround , and since then I realized what was causing the error, grabbed the keyboard, and posted the issue with version .276.

OK I’ll try to help you

  1. Read my first post begins with… “Guess what…”
  2. Tell me what it’s your version for short .268 or .276 ( or
  3. What Windows StartUp Programs you have installed in your machine
  4. Antivirus installed in your machine
  5. If you don’t know what are the Startup Programs (please see the image)

Now, if you have version .268, there’s a lot of users who has the same problem, I did have them with that version, but now I use .276, and since then I experienced only one time

So I invite you to give me more information and I’ll try to help you… but keep in mind that I’m not a moderator, just a simple user, so I’ll do my best to help you

So as, I said in my last post, I posted the poll to send a message to the developer team, and yes, this it’s a great product

(B) (R) (V)

So don’t be afraid to keep posting, thanks to collaborate with the poll and all of the users too

By the way, sorry for my written English, I know that seems to be like Tarzan

[attachment deleted by admin]


I have the latest version of Comodo Firewall v3.0.14.276, and as you said I have 7 on my Startup Programs at the bottom right corner.

  1. Avast 4 Home Edition Anti-virus v4.7.1098 as Resident Shields.
  2. AVG Anti-Spyware v7.5.1.43 as Resident Shields.
  3. Comodo Firewall with Defense+ as Resident Shields.
  4. NVIDA for my ASUS EN8800GTX Card.
  5. RivaTuner v2.1 for my ASUS EN8800GTX Card to control the cooling fans.
  6. SUPERAntiSpyware as on-demand.
  7. WinPatrol as Resident Shields.

Speedy :

As far I can see I think where may be your problem
But first let’s define the term MAY BE I could be right or I could be wrong

Let’s go in a slow pace

1.- Antivirus I had the same Avast and the latest build 4.7.1098 as Resident
2.- I have Counterspy 2.5.1042 Antispyware as Resident
3.- COMODO with D+ with the default settings except that in the D+ I set in to Train in Safe Mode instead of Clean Mode (check that too)
4.- AVG Antispyware v7.5.1.43 but in demand mode, I mean I it doesn’t load at StartUp

You have WinPatrol as Resident Mode. May I suggest you to disable the resident mode in one of your antispyware programs, if you have two antispyware programs it isn’t worth to keep both in resident mode, so I’m starting to think what’s happening in your machine.
Both antispyware programs are trying to gain resources and in a random moment they kick each others yelling “Heyyyyy!!! you, I’m trying to load…” and the other reply “Me too!!!..” so one antispyware silently doesn’t load and COMODO doesn’t know what to do and finally crashes

Tell me how it works but I think the issue are the antispywares
Regards MiguelAngelXP

(V) (B) (R)

[attachment deleted by admin]


AVG Antispyware is the only one as Resident not SUPERAntiSpyware it only demand mode it okay, my D+ wasn’t set as Train in Safe Mode as it was in Clean Mode and I disable Winpatrol to see how it turns out.

I find the D+ becoming very annoying I was thinking about disable it and going back to WinPatrol.

Thanks I think the problem still hide behind Comodo D+ just guesting as I am not 100% sure, their are a lot of people been complaining about the D+ problem.

Hi Speedy:

I see your point, there is a lot of people that has trouble with D+, hmmm when I was with version .268 I felt my PC heavy, so I will tell you what I disabled in D+ and try it out

  1. Go to the D+
  2. Press the Advance button
  3. Go to D+ Settings
  4. Click the Monitor Settings Tab
  5. Uncheck Protected COM, Interfaces, Protected Registry Keys and Protected Files, the rest of the options keep checked
  6. Press Apply and reboot your machine

And try the Train with Safe Mode setting for a while maybe one week , 2 weeks

Bottom line

In Clean PC Mode the D+ it’s very annoying that’s true but in Train in Safe Mode works fine

And again thank for your replies, this is why we are here to exchange issues and experiences, sorry I’m a sort of sleepy, and if a remember well I had bad experiences with Avast and SUPERAntyspyware together ,they didn’t get along between them even when SUPERAntispyware was in on demand mode im my machine, so I got rid of SUPERAntispyware (Clarification : I’m not saying that SUPER… is a bad antispyware)

(B) (R) (V)

Ahhh I suppose you’re a gamer and you are above the 1 GB RAM range???, when you wrote me that you own a a 8800 GTX video card, I thought "Maybe he has a 1 GB+ RAM computer


I am way above the 2 Gig DDR Ram using a the latest Intel CPU 6700 model, and yes I am a gamer and I’m also a Senior Structural Draftsperson doing a lot of CAD (Computer Aid Drafting) work specialised in engineering solutions in multistorey buildings in 2D and 3D design.

I’ve followed your instruction and let this go for 2 weeks to see how it turn out I hope, MiguelAngelXP if your using the latest Avast version the problem has been solved about SUPERAntispyware.

Their were alot of people using Avast with SUPERAntispyware as Resident or in demand mode in the Avast forum website not very many people complaining about it.

PS. In the D+ the my pending files are driving me NUTS! (:AGY) :THNK how do I kill this.