CPF3 and sandboxie not compatible on xphome? Sandboxie won't delete


I’m using sandboxie latest version with firefox 2009 (w/noscript, adblock plus, keyscrambler) and I can’t
get sandboxie to delete it’s own sandbox when I’m done surfing the net. It just hangs and won’t let me delete. ?? I’ve tried turning off the firewall and defense plus but doing that doesn’t help. Anyone have any setup rules or insight into how to get sandboxie and CPF3 to behave?

Hi Ahuramazda

Surprisingly your situation is what started me off ie I could not get sandboxie to delete the files from the sand box. By trial and error I discovered that the problem was NOT Sandboxie (in my case).

If you turn off the sandboxing and just run Firefox, you will find that, although Firefox closes,
firefox.exe is still running in processes on the Windows Task manager. It is for this reason (that the process firefox.exe will not shut down) that Sandboxie will not allow your residual files to be deleted.

Further, if you “explore” the sand box you can delete most files/folders except “user” User is where the Keyscrambler files are kept so I suspect the problem is here. The trick I suppose will be to configure Comodo but I have tried and failed

Thanks Terry,

I’ll keep poking around into this issue and see if I can’t figure out why suddenly I can’t get sandboxie to delete anymore. I worked with the previous CPF2.4 so hopefully it’s just a setting I need to tweak. I’ll check back every day in this thread to see if you’ve figured anything else out. I’ll let you know what I find too.

Apparently it’s a bug in Firefox or more likely the Keyscrambler addon.

Hi Japo

I fail to see why its a bug in either Firefox or Keyscrambler. Both worked harmoniously in Comodo v2.4

Its only since I installed CPF v3 that it doesnt work.

Even then if you disable Defense+ it works fine



Ah okay. Then I suppose you can grant FF or KS the appropriate permissions in the Computer Security Policy to avoid the problem.

Hi Japo

Thanks again

Thats what I have been trying to do but no joy. I am not skilled enough (Dare I suggest that Comodo seems a tad daunting in configuring)

Any help you can give would be greatly appreciated


Likely I’m less skilled but still… This should work to the best of my very limited knowledge: right-click on the CFP tray icon and select Defense+ Security Level > Training Mode. This should be like allowing all, but remembering to allow in the future anything executed while in training mode. So run FF then close, check if it’s gone all right just like when D+ is completely off. Then set D+ back to clean PC so its protection is back, the appropriate rule (whatever it is) should have been learnt.

This might be because in Clean PC mode Defense+ trusts everything detected at the moment of the installation with pretty much every action, but seemingly not with terminating other processes, for obvious safety reasons I guess. (The Windows System Apps and Trusted Apps predefined security policies have process termination already allowed though.) I’m not sure about this I’m saying, but at least I read other user saying that some sensitive permissions needed by BOClean including process termination had to be allowed manually because the clean PC mode wouldn’t learn them.

Hi Japo

Thanks for your reply.

Wish I could be more positive, but, tried it it did not work. Only thing that works is turning off Defense+ which defeats the object.

Thanks again