CPF version 2.2.0.11 has been released!

I would like to announce the availability of Comodo Personal Firewall 2.2.0.11.

What’s New In Version 2.2?

  • New! Added a new option called “Skip advanced security checks” to an application rule’s Miscellaneous section (This option will force CPF to skip leak checking on an application who has this option enabled. AVG Email Scanner compatibility issue is solved when user selects this option with avgemc.exe)

  • Improved! COM/OLE Automation Monitoring ( CPF now catches windows background intelligent transfer service hijacks, BITSTest)

  • Improved! DDE Monitoring (This improvement reduces number of “Modified the user interface” type popups)

  • Fixed! Bug that causes CPF not to remember some settings even if the user selects Remember option

  • Fixed! Bug that causes 100% CPU utilization in non-admin mode

  • Fixed! Bug that causes memory leaks in cmdagent

  • Fixed! Bug that causes CPF GUI to be unreadable while high DPI/font size settings are used

  • Fixed! Bug that causes false protection strength rating to be shown in the summary screen

  • Fixed! Bug that causes rules having [Any] attribute not merged correctly

  • Fixed! Bug that causes some security considerations text not be displayed

Please update your copies immediately or download and install the latest version.

Cheers,
Egemen

Thanks egemen.
(B)

Regarding the AVG email scanner.

I had to use the new option on both avgemc AND avgcc. There is no avgmc btw, probably a typo.

I also notice that after a reboot and my system comes up if I try to get my mail my email client stalls like it did before the ‘fix’. Seems that if I wait an extra minute or so I can then get my mail. Perhaps CPF is still initializing this new option? I never had to wait to get my mail before.

Also getting/sending my mail seems noticably slower now.

I’m still testing so I might have more feedback for you.

The download address, please! Should I redownload the whole program again? Isn’t there an accumulative patch? Clicking the download link at http://www.personalfirewall.comodo.com redirects me to the registeration form as if I am a new user! If I tried to check for updates using the command “Check for updates” available through the Launch Pad tray icon, none happens! Can you help, please?

You can update your copy by running the updater of CPF.

  1. Right click CLP tray icon → Personal Firewall->Open
  2. CPF GUI will be opened. The click on “Updater” button on the top-right
  3. Click on start button and follow the instructions

Thanks for the instructions, but that seems a little weired! :-[

On the other hand, I have just read Mileh’s post about the 2.3beta version at [url]https://forums.comodo.com/index.php/topic,650.0.html[/url]. So, should the download link for the stable 2.2 version be [url]Comodo Firewall | Get Best Personal Firewall Software for $29.99 A Year? I have tried that link and it works, but I still need your confirmation about that. :slight_smile:

Yes the link is correct. But you dont have to reinstall it. If you do, your previous configuration settings will be lost.

Egemen

the big news in this release is :

“Improved! COM/OLE Automation Monitoring ( CPF now catches windows background intelligent transfer service hijacks, BITSTest)”

Now, I think we are the only ones (or one of very few?) that pass this BITSTest that was recently reported. This is a really nasty leak that allows any spyware to call home. Not with CPF :slight_smile:

Melih

Excellent to hear. Also, I see at the top of the forums CPF stops a new threat, which is also excellent to hear.

Mike
(R) (B) (S)

"Improved! COM/OLE Automation Monitoring ( CPF now catches windows background intelligent transfer service hijacks, BITSTest)"
Does that mean I can enable the option "Enable COM/OLE requests"? It was made default, or I read it somewhere (here in the comodo forum) (i dont know which one ::) ) , that it should be turned off.

Hmm, when I found the popup telling me an update was available, I clicked to install and rebooted when prompted, only to find that when Windows restarted there was a little icon in the system tray telling me that I now had no network connection. Not happy. I tried rebooting again and even a system restore (to see if it would undo whatever had been done by the Comodo update), but still no network connection. Finally I uninstalled Comodo and installed Kerio, and now everything works again. Phew.

I don’t know if anyone else has had a similar problem, but I thought I should report it anyway. I’ll probably try Comodo again in a few months, as I really liked what I’d seen prior to the update. Cheers.

Using WinXP Home (Japanese) SP2, if that matters.

No you should not disable it. You should keep everything as default.

Egemen

It seems to me that your update was not able to be completed somehow. You can try to download and install a fresh copy.

But did you have any other firewall installed with CPF?What other security programs were you using?

Thx,
Egemen

When I updated the CPF was uninstalled and after reboot it wasn’t there!
I redownloaded manually and had to install it again. Nice release.

ps. after testing for a while (everything was fine), I decided to try the beta.

But for a beta is solid like rock!!!
(B)

Hi Pan,

This is the second time that your CPF is being uninstalled after the update. I do wonder what is going on? It was removed from the add/remove programs as well?

Egemen

Hello egemen; thanks for the reply. I didn’t have any other firewall installed (apart from the built-in XP firewall, disabled), and the only other security app I’m running is NAV 2006. After I rebooted when prompted during the update routine, the Comodo (launch pad?) icon was showing in the system tray and I got a couple popups from the firewall, which would lead me to think that the update had been completed, but I suppose it’s possible that it hadn’t.

Anyway, I’ll probably give Comodo another try one of these days, but not for a while. :wink:

Yes it was removed.

Well allthow the CPf seemed to reinstall itself, after the reboot the installation did not happen. I don’t understand either why it happens

Downloaded latest version and tried to install. Got the following pop-up during install:

1628: Failed to complete installation.

I have a standard system with WinXP SP2 + Security fixes and have no problems installing KERIO
from Sunbelt. Sorta gives me an uneasy feeling. Can’t even test it :slight_smile:

Is there a workaround for this?

Al

https://forums.comodo.com/index.php/topic,650.0.html try the beta version with our own installer.

Egemen

Can anyone post any screenshots of the new features?