CPF v3 and Ares cant connect

Just installed CPF v3 on my daughters PC and now she cant use Ares. We did the auto install and I have basically told her to allow any pop ups for the first few days while it learns - however she still cannot connect /download etc. Do i have to create some rule or policy for this. Any ideas would help as I am doing this remotely with her and tempers are getting frayed!

Try this tutorial on how to set Comodo to work with E Mule: https://forums.comodo.com/faq_for_comodo_firewall/tutorials_a_compiled_resource-t6167.0.html;msg45504#msg45504 . The same logic applies for any other p2p program.

I can’t find any info on ports/protocols used for Ares, so the info will have to come from the Event log: Firewall>Common Tasks>View Firewall Events. There, you will have to look for the program that is being used and note the details (protocol/ports/addresses) of any blocked connection. If you can work it out from that info and the link in the previous post, all well and good. Otherwise, send us a post with a screen shot of the Event log and details of the system being used (CPU, O/S, LAN setup or no LAN, connection type and any other active security software).

MMM - no luck with this problem. Firstly there is nothing in the log - which I guess is strange in itself. Next , as I am doing this remotely I tried to use remote assistance. That does not work either. So I aksed my daughter to unistall Comodo to allow me access to the PC. With no Comodo installed I could use Comodo. So I dowloaded a fresh copt of V3 installed it using advanced default options as I will be using P2P and when I restarted and tried to connect with Remota assistance it did not work. Ares still does not work and there is nothing in the log file - its empty. The PC is an HP 3.0Ghz processor with Win XP Home edition. all up to date. Any further ideas or is there some incompatibilty with Comodo and HP. Am I better off using a different Firewall? Any further help advice as my daughter would now like to fire me as my technical support foed not work along with her PC!

Hi bigbadger

This looks like you need to find a resolve or you are in deep doo-doo.

I’m not sure I can figure it out but I can maybe help you find what port Ares is trying to use.
Can you go to Firewall → Advanced → Network Security Policy and find the rule that should be there for Ares. (I hope there is one). Click on it and then click edit. Click the box where it says to log as firewall event if this rule is fired. You will then have to click apply a couple of times to set the rule. Then try your application again and you should see something in the events log.

With this information I’m sure one of our rule gurus will be able to make a rule for you.


The log file is not updated actively - you have to make a connection attempt and then look at the event log. Also, events that happen on a previous bootup are not shown unless you click on the More button. If there are still no events to view, you have to ask if the connection is being blocked by the local ISP. I noticed that Ares claims to be able to run on many campus networks where other p2p programs cannot, but it also cautions that there are some networks that block it as well. Can your daughter connect without a firewall (a momentary connection should be safe - but she should have a plan to disconnect her modem/router or wireless link afterwards)? The other possibility is that the Log… checkbox has not been selected on the Block rule. Some application policies seem to not have a Block rule, so you may have to write one. To do so, click Firewall>Advanced>Network Security Policy>(locate and select the program/browser or wharever is used to connect with Ares)>Edit. On the Edit dialog, Make sure that “Use a Custom Policy” is selected. Click the Add button and enter the following in the dialog:
Block (and check the “Log…” box)
Source Any
Destination Any
Details Any
This rule specifically blocks all traffic not allowed by the rules listed above this rule on the policy. For some reason, a few programs that are set up during installation seem to have Allow rules written without a final Block rule. The “Log…” part of the rule is what generates Events on the Event log. If there is a Block rule without the “Log…” part, that can be changed by selecting the Block rule and clicking Edit instead of Add in the above procedure and then clicking the “Log…” box on the rule creation dialog.

Ares listens by default to TCP port 23302 according ot this page: http://protocolinfo.org/wiki/Ares . Usually you can change that port in the settings of the program it’s self.

If you have to open that port for Ares, click Firewall>Advanced>Network Security Policy>(Locate and select the entry for the program that accesses Ares)>Edit. (I will assume that the option is “Use a Custom Policy” - if it is not, note the Predefined Policy used and then click “Use a Custom Policy” then click “Copy from” and choose “Predefined Policy” and select the Predefined Policy previously in place. This allows you to edit the policy for this application specifically. Then continue as follows).
On the Edit dialog, click the Add button and then enter the following on the rule dialog:
Source: Any
Destination: Any
Source Port: 23302
Destination Port: Any
Click Appy, Apply and Apply

Make sure that there is a Block and Log rule after this rule in the policy for this application (see previous post).