CPF using huge amounts of CPU time

CPF is using from 16% to 60% of CPU time on my system. That’s a lot! It appears to make the system quite unresponsive over all.

Most of the network traffic is utorrent, some from emule, and CPF is configured for them as recommended in this forum. Besides those, the log shows about 8-15 incoming packets being blocked per second.

Any idea what I can do to reduce the amount of processor time CPF uses?


Welcome to the forum :slight_smile:

Before you post, please search in the forum, as many things have been discussed before.


As I understand, the problem is the logging in the firewall.

Logging is only one of the causes, and it’s the easiest to diagnose and re-create the situation. This relates to cpf.exe. However, if it’s cmdagent.exe causing the high cpu then it’s more complicated.

Ok, well, I don’t have the problem, so I haven’t bother to dig deeper in this

But thanks for the information :slight_smile:

Do you want to know how to have this problem? ;D. Monitor with Task Manager or whatever program you use while having a ton of alerts in the logs. The easiest place is pc flank exploit test (choose the ‘all’ option). It’ll consume even more cpu if you have the Logs window opened ;D

I must be overlooking something, but I see no simple method of limiting logging. Where is it?

In any event, perhaps I’ve found part of the problem: being too specific in the application rules for the p2p apps. In addition to the network rules for emule and utorrent, those apps were configured in two rules each: one to permit all outbound connections and one to filter inbound connections by port. Since the inbound connections were being filtered by port in the network rules anyhow, I eliminated the app rules that checked the inbound ports, and CPU usage seems to have dropped.

It would help to have some form of diagnostic logging – seeing, for example, exactly what rules are being triggered, along with the time (with an accuracy, say, of milliseconds).


Thanks for sharing this solution, djc. Since I don’t have emule, I can only comment on uTorrent. If you have the default “Do not show alerts on applications certified by Comodo…” on then uTorrent doesn’t need any application rules (unless the parent executable is something other than explorer.exe, like your browser).

There are many methods to disable logging, but no possible way to control them at the application-specific level in current versions. For each network rule you can edit them and enable or disable the alerts. If want to disable an entire monitor module’s logging, right click in the Logs window and uncheck the one you want.

If you want to see the date and time and other details, just right-click in the Logs window and export to an html file.