CPF problems with HTTPS, Warcraft 3, Hamachi

(ver I’m an experienced user of Zone Alarm Free Edition and wanted to try CPF. Got a problem. Installed CPF on a fresh disk image containing no firewall or antivirus, using defaults. At every point along the way of this I allow all apps access as the CPF popups appear. Firefox, Gmail, Hamachi, everything works fine. Installed Avast Free Edition. Works fine. Installed Warcraft 3. Can join games but cannot host them, so I start troubleshooting. Ports are properly forwarded through my Netgear router and this worked fine with Zone Alarm on the old image. Look into CPF network monitor, app monitor, and the rest. Try adding network rules for Warcraft 3 ports per the other help topics (which I have search extensively). Doesn’t work. Tried a bunch of other network rules per the many many help topics I read, none work. Found out that now any website using SSL (i.e., the URL starts with https://) can’t connect. Examples are Gmail, banking, Amazon login. Hamachi doesn’t login either (but did initially). CAN connect to non-SSL websites and LAN computers. Delete all the network rules and run through the Flash tutorial I found in another help topic to bring me back to a simple config. Warcraft 3 and https doesn’t work. Turn off CPF. Doesn’t work. Uninstall CPF and reboot. Doesn’t work. Reinstall CPF with defaults. Doesn’t work. The only option left to me seems to be to re-apply the fresh image and start over. What’s going on?

I’m running Windows XP SP2 with all security hotfixes to date, new hardware, cable modem connected to NAT router, static computer LAN IP address, router ports are properly forwarded. Windows Firewall is disabled. No other firewalls installed or uninstalled.

you’ll probably find your answers in the Faqs posted [url]https://forums.comodo.com/index.php/topic,894.0.html[/url]… read the online gaming and order of rules FAQ’s

I suspect a missing Network rule to allow incoming.

So did I, so I tried a network rule to allow all incoming connections on all ports, and deleted the one that blocked all incoming. No dice. I read many of the posts in the link above already, but I found them individually. Good to see they are all in one place. I’ll read through them again plus the ones I didn’t find the first time.

This also doesn’t explain why I’m blocked even after I uninstall CPF.

If the connections are blocked after uninstalling CPF, then there is another problem unrelated to CPF. Wrong network setup?Some other firewall?

CPF will surely not be able to block anything after being uninstalled.