CPF Beta heavy system resource usage [resolved]


I’m loving this new beta of CPF but one thing though, I’ve notice that the system resource usage of CPF Beta is much better that the previous older version. However after using it for a day with no problems, the cmdagent.exe componet shot up to %67 percent and combined with other processes on my computer was contributing to 100% CPU which would slow web surfing to a crawl for about 10 seconds. This occured when I launched internet explorer. It only happened once so far and this has not been a problem since but perhaps this is an indicator that this CPU factor which was very annoying in the stable version of CPF still needs a little work.

I’m running Windows XP SP2, all available updates from Microsoft.
Active Virus Shield from AOL is running
Intel Celeron D Processor
Intergrated Intel Graphics Card
1GB of Memory

Anything else I left out? My computer is virus and malware free.

This is somehow related to AV i guess. The latest stable version for example, must have the same behavior. Does it?

Lets test and see.

I’ve posted the same problem (high CPU usage) here:


Yeah tell me about it. I’ve been reporting this high CPU ■■■■ for months already and obviously it falls on deaf ears.

You’d think that developers would know that just because it doesn’t happen to them on their test machines it can’t happen on other peoples machines.

We are talking about computers, not gaming consoles, where there probably aren’t any two machines exactly alike.

But wouldn’t disabling the DLL injection means crippling a major function of CPF: the Firewall would “leak”? ???

just wanted to mention here that I’ve had to switch back from beta 2.4 to release 2.3. My computer, while using cpf beta, was like crippled. Not that cmdagent.exe or cp.exe were using too much cpu%,or ram, but that anything else took a very, very long time to start: that includes booting time, and almost any application start, even opening a window or a folder took time. I first solved the issue by totaly removing cpf beta from the pc, and after a couple of days , as I did not want to exclude cpf for good, I reinstalled version 2.3. It’s not that bad with 2.3. Hope things will be fixed with the release of 2.4 (non beta). I mean that I had to remove cpf 2.4 beta for the same reasons I removed ZoneAlarm from my sytem a few weeks ago. So please guys do something about it. This ressource issue also happens sometimes with 2.3, but as I said, not as bad as with 2.4 beta.

Another minor, but anyway annoying issue with both 2.3 and 2.4 beta is the disappearing of some icons in the sytem tray after a reboot: programs related to these icons have started normaly (their processes appear in task manager), but the icons in the system tray don’t come out anymore. This happens only when cpf is loaded. And that reminds me of a similar (and well known) issue that I’ve had a while ago with a Norton Security suite; but there it was worse: icons did not come out, and their related programs had not started either. The guys from Symantec knew about the issue and advised to install the suite immediately after OS install. Great! and ridiculous. One should be able to install and uninstall and reinstall a program anytime on a pc. Well I don’t know where the problem comes from with cpf, but I’m a bit fed up with not seeing anymore these icons that I need at startup, in the system tray (lower left side of the screen).

Sorry but I’m a bit upset, cause I already asked for help before in this forum concerning these issues; I’ve had replies to my posts, but no solution in view, whatsoever. I mean I ask again today because I like this firewall. I could just forget these issues with cpf, not loose time writing posts, and go see somewhere else. But I’d like to use cpf further on, because it’s also full of very good features.

                             ok, that's it for now.
                             cheers to all


anyone there? posted something 5 days ago, just above…I mean is that still realistic at all to expect an answer? At that stage, I have totaly stopped to use cpf. I might not use it ever again.


changed my mind…gave a try to beta and the ressource issue seems to be solved.Congratulations.

You should never give up… ;D
Sometimes the answer takes some time…
It can depend on different reasons. Not enough time, didn’t see the post, don’t know a good answer and so on… :wink:
Remember, never give up! :wink:
Good luck with CF.

hi AOwL=99,

yeah actually the latest 2 beta releases of cpf seem to be quite ok concerning ressources. I just installed the one released today and I like the new features: bytes sent and received, new icon in systray showing traffic, brilliant. Anti-buffer overflow was removed but it does not matter, can wait till

                                 all the best
                                 apache  (:WIN)

I have 107 now, but I will install 111 in a minute… :wink:


I also noted in the CAVS forum that until recently you had ST w/its “HIPS” running. When I had that, I experienced a lot of lag in surfing; that “HIPS” used a lot of resources in that setting. Just turning off that feature of ST sped things up quite a bit. If you took it off in order to reinstall CAVS, that might account for some of it (or it could be completely unrelated, and the development team was listening to you after all… ) :wink:


the info you get in the alert windows is much more detailed than before; may be I should stop posting here cause the topic was"ressource issues with cpf beta" and now we talk about the new features of beta…

Well, you have a point there Apache… :wink:
It will mark this as resolved and lock it, so it wont be cluttered with our chatting… ;D