CPF and TSE : no firewall alerts

I use my PC 98% of my time from TSE. From work I open a SSH connection with a tunel and I lunch TSE.
I’m testing CPF, so I put only the necessary rules to connect from work.
Thi smorning I’m connected to my PC, I lunch IE and IE can not connect to Internet. No alert popup from CPF.
I try an update of my Anti-virus software: the same (out).
I manually added a rule for IE, I choosen Apply, but the rule is not used (when I return to the config screen I can see my IE rule).
I tried other firewalls (I rebuild my PC very month) and they work fine under TSE (I get the alert popups).
So is it normal ? Is CPF build to be uncustomized from TSE ?
Best regards.

Can you start IE and connect to the internet when you arephysically using your PC, rather than via a Terminal Services connection?

Ewen :slight_smile:

Yes, from home (directly in front of my PC) when I launch IE I’ve an alert popup from CFP. I authorized IE and I was able to surf.
After I removed the rule.
Now from TSE, when I lunch IE, nothing, no popup, no access to internet.

Hang in there. I’m asking around because I can’t see what the problem could possibly be.

Logically, if you can connect when physically on the console of the home PC and can also successfully establish an SSH session to home from work, then I can’t see anything that would be stopping it. The alerts are displayed using the primary video driver and are displayed within the same video space as the desktop.

It’s got me twigged???

Are there any relevant entries in the logs?

Ewen :slight_smile:

The View Firewall Event shows me an empty list.
May I check a log file somewhere else ?
It’s curious because I manually added the rule for IE based on “Use a Custom Policy” Copy From Predefined Security Policies - Web Browser. I pressed the apply button.
I closed CFP (it stay in the tray). I reopen it and the rule is here. IE can not go to Internet and no alert popup.
So from TSE the created rule is not used !! The problem is not only the alert popup it’s the configuration itself that does not work properly.
Thank you to spend your time on this problem.

At the lunch time I’m returned home.
I logged to the PC. No popup on the screen.
I launch IE and it connect to internet (no popup). I did not modified my IE rule created from my TSE session.
Now I’m back to work, from TSE I can launch IE and it works fine.
I tried a FTP client program from TSE and it can not connect to internet and no popup from CFP.
Any idea ?

If I can ask a question here… It’s apparent something is wedged somewhere, but to find out where, could you run the Config Reporting Script (sticky topic at the top of the forum page) and post the result here? There may be some rule or such out of sequence and it’s not logging anything.

If you have Windows Automatic Update turned on, it could be that something in the underlying Terminal Services has changed a configuration or something. A quick way to check that possiblity, is to eyeball the C:\Windows\WindowsUpdate.log (location on my WinXP machine) and see if there have been any recent updates done.

I did an other test:
I have 2 PCs at home, so I did a TSE from the second PC to the first one. I’ve no rule about IE in my firewall.
From TSE I launch IE. IE was not able to connect to internet, no alert message.
I rapidly connected to the first PC (so I ‘killed’ my TSE session) and I saw the popup alert about IE trying to go to internet. So curiously the popup message don’t go in the TSE session and stay in the first PC.