cpf 3 alert just wouldn't go away

I am at now.

At the installation, I had probably opted to switch on Defense+ not knowing what it could be, but yesterday I somehow went to explore it and found 1000s of file “waiting for my review”. I got scared that defense+ is doing so many activities behind my back thus slowing down my pc. So I purged all files and Disabled Defense+. I just don’t want it. Period.

Ever since, comodo keeps on shooting a reminder every 5 minutes or so (screen capture attached), telling me "Your Defense+ Security level is still in “installation mode”. Would you like to switch back to your previous mode? and it keeps on for several seconds then disappears only to reappear again. Clicking no doesn’t do anything, it anyways comes back. And there is no way to switch it off on this alert window.

I have even chosen keep an alert on screen for 0 seconds, but it keeps on appearing and stays till whenever it wants.

I am sick of it. You guys are cruel and pathetic that you introduce a new feature and roughshod your users to use it. It is sickening and stupidity that a pop up would appear every 5 seconds and there is no way of shutting it out. You guys should be put in jail for troubling your users like that.

to get rid of it, I had to switch on on “Yes” and it closed without taking me to some option window or whatever. It must have done something that is convenient to you and not convenient to me.

Defense+ might be a useful feature but I don’t want me forced to use any useful feature in such highheaded, highhanded way.

I don’t want defense+. Tell me where to download some previous version of comodo pfw that didn’t have defense+ and I would use that. Or, I would go to my good old ZoneAlarm.

All the good association of a year with you, and in one day you spoiled by it such severally by some of your brilliant developer or executive forcing his will on me.


[attachment deleted by admin]

Hey Vsrawat…I don’t really appreciate threatening Comodo’s team… they work very hard to provide us with a free product.

Either way, let’s keep this peaceful and I will try to help you the best that I can.

I’m not sure you understand what defense+ is,
Here is the frequently asked questions,

Also there is a VERY good help file, Click on Comodo → Miscellaneous → help

As for the pop up, It says

Your defense+ security level is currently in “installation mode” Would you like to switch back to your previous mode?

I’ll try to make that message even more clear… If you click no It’s going to stay in installation mode, Thus- you will keep on receiving this pop-up.
If you click Yes it will switch back to your previous mode, Thus- you will not receive this pop up.

Defense+ is a really great program, Please do some reading before you decide to throw it away!
If your sure your pc is clean. of malware, you can put it in CLEAN PC mode. you will only recieve a new alert for anything new that comes onto your pc.
Or, You can use Safe mode. Most users use this.

If you want to disable defense+ you can do this;
Comodo → defense+ → advanced → defense+ settings → permanently disable defense+

Okay I’m done laughing. Comodo starts out on normal mode, and something must’ve happened to trigger it to switch to installation mode, I’ve turned it off before without any problems so I don’t know how the thing got into installation mode.

Comodo was just warning you that the setting was switched into installation mode, which, as the name implies, should only be used when installing something then switched back, and if you wanted to change back. Since you kept hitting no, you’re essentially telling it that no you’re installing something and not to change back, hence why it only changed on yes. If you really want to get kinda technical about what it did, open up the FW controller. Below network defense box, there should be something that says proactive defense. On the bottom right hand corner of that same box, there’s a line that says switch to installation mode and if you click on it, it switches to something that says switch to previous mode. That’s all it did, clicking yes essentially just had the same effect as clicking switch to previous mode.

Besides, if you don’t like D+, no one forces you to use it for V3, and you’ve already clearly figured out how to disable it. You could always uninstall/reinstall V3 and tell it to only install the FW (kind of pointless really since you can just disable and save the time).

If you don’t want pending files then put D+ in safe mode. The reason for the pop up about install mode is simply. You must have switched Comodo into install mode which is only a temporary mode while your installing something. That alert is suppose to be there telling you to switch back as a safety warning. Dont pick on a program cause you don’t know how to use it. We are here to help you and if you want help then be nice. Making negative comments aren’t necessary. Please take the time to read the help file system. Go to Miscellaneous/Help. The reason the alert will not go away is cause its NOT suppose to. It is a warning telling you that your security is down and you need to switch back.

The other responses say it all.

By the way… You can remove pending files from time to time as the list builds up if you wish NOT to submit them.


OK. The prompt is gone. Defense+ stands disabled. I don’t know whatever I am losing, but I am at peace again.


In any case, I repeat that it was cruel of you to put such a persistent alert that nagged more than a wife. In the next update, better make it more descriptive, let there be some option to switch of the alert, may be, suggest some default that it should take and go ahead if the user doesn’t respond or responds in negative.

I had been using zonealarm since ages, but then their latest versions became more comprehensive, started doing a lot of things, wanted me to choose between a lot of options that I didn’t understand and didn’t bother, popped up a lot of warning and information that didn’t make any sense to me. So, I went back to their earlier versions and continued using them, but then I came to know about Comodo and switched to it a year back and was very happy with it, expect for last 24 hours.

Seems Comodo is also going the same way as I described about zonealarm in above. It might be good and intellectually satisfying for techies and nerds and geeks, but a common person doesn’t understand much about firewall and doesn’t want to get bothered about knowing its messages nor to responding to them. Any pop up coming from a firewall is very unsettling as if the Pirates of Caribbeans are going to enter to our house through our net connection.

So, my humble suggestion is: keep your firewall silent as much as possible. It should not intrude into non-techies’ lives.

bye, till ur lovely product troubles me again. Thanks for everything.

You should enable D+. Its the HIPS protection of the firewall and you are losing security by disabling it. Pop ups are part of any firewall till it learns all your programs. To aid in pop ups you can use D+ and the firewall in training mlode for a week or so. A firewall is suppose to give you alerts. Thats how you know its working. Its doing its job and protecting you. Please take time to understand why Comodo is giving you alerts. Its not nagging its doing what it is suppose to b e doing. All alerts go away once your programs are learned. ALL FIREWALL are like this. I have used everyone out there and they are all the same. Every firewall goes through a learning process. Alerts are NORMAL behavior. Comodo doesnt give me any pop ups cause I have had it installed for months and all my programs are learned. At first I was getting alerts like you and thats normal.

Your opinion is negative cause you are not taking the time to understand Comodo and why its giving you alerts If you think its nagging you then its cause you clearly aren’t understand why your getting alerts. D+ can protect you from viruses. If you took time to learn and understand what Comodo is all about then you would release why its the best firewall out there.

It’s his choice…

Thread Closed.