CPF RC1 32-Bit Bug Reports

I used AKLT to test CFP V3, and the defense+ can’t completely block all the keylogging, like number pad input.

my keyboard model : Dell RT7D00 PS/2

[attachment deleted by admin]


Thank you very much for the report. I have verified the issue. This is a serious bug and will be fixed with the next BETA.


In order to provide enough informations to fix bugs please include those infos in your posts
Please submit one bug per post and change the subject to describe your post.

1. Computer information
2. Operating System information
3. Actively-running security and utility applications
4. Specific symptoms of the bug, and steps you can take to reproduce it.
5. Specific steps you have taken to try to resolve it.
6. If you pc reboots or you have a BSOD read How submit a BSOD bugreport for additional requirements.

Edit By Moderator

Keylogger test still a problem in RC1.

Ref: Here


System Information:

IBM T41 Laptop
Intel(R) Pentium(R) M processor 1700MHz
1GB Memory
Windows XP + SP2 + WUS security Fixes
Symantec Antivirus Corporate Edition

Hitting Cancel on Alerts creates a permanent block rule if “Remember my answer” is checked.

Ref: Here


System Information

Note: please read to the end :smiley:

I was testing “Painkiller Overdose” demo today and as I tried to execute it, the CPU usage rised to 100% for 10 minutes(!!!), and only then the game loaded.

I actually watercool CPU+GPU+Northbridge with Cu waterblocks, eheim 1048, 6/8, dual 120cm radiator, normal temps ranging 44c and 47c on full load, but in THIS particualar case, temps went up to 54c(!!!) it was really unbelievable for me.

So just after entering, the game was veeeery sluggish in MAIN MENU (options). So, I thought it must be my weak system(doh!), so I droped the settings(res,details so on) and tried to restart. For sake now, I closed ISP Connection, CPF3 and turned AV scan off.

“Overdose” loaded 15 minutes… in the fact it didn’t finish it. I was out of balance and called the task manager to kill it. What i saw was cmdagent using constant 100% cpu load!
Killing it manually, overdose started in 5(!) seconds, like a rocket. Temps dropped to 45 in seconds.

CPF has global rules to allow loopback, but there were even no requests that about app. I would also note, that defence+ was disabled completely, and i do not use any other hook- watcher and the system is actually clean(I surf mostly on education sites).

Software: XPSP2,updated,lastest drivers. NOD32,BoClean,CPF3,RivaTuner
Hardware: AthlonXP 3200+, nForce2Ultra400 (Abit NF7-Sv2), 1GB Ram, gf6800

Corrections: “Nfoerce” and “fill” instead of “Nforce” and “full”.

In certain cases the file status in ‘My Pending Files’ is incorrect.

Ref: Here


System Information

  1. P4 HT [ at ] 3,7 Ghz 1 GB RAM

  2. WinXP Pro SP2 32-bit + online updates

  3. Avira Antivir PE[b]

  4. CFP allows to save improper port range rule.
    Start port: 1010
    End port: 1000

    The rule will be saved but obviously won’t work. [/b]

  5. N/A

  1. P4 HT [ at ] 3,7 Ghz 1 GB RAM
  2. WinXP Pro SP2 32-bit + online updates
  3. Avira Antivir PE
    4. ‘A Single Port’ field still allows to type more than 5 digits.
  4. N/A
  1. P4 HT [ at ] 3,7 Ghz 1 GB RAM
  2. WinXP Pro SP2 32-bit + online updates
  3. Avira Antivir PE
    4. ‘Predefined Firewall Policies’ and ‘Predefined Security Policies’ still have messed up short descriptions.
  4. N/A
  1. P4 HT [ at ] 3,7 Ghz 1 GB RAM
  2. WinXP Pro SP2 32-bit + online updates
  3. Avira Antivir PE
    4. Adding a new policy to ‘Predefined Firewall Policies’ works not quite correctly.
    If you copy from/add some rules first instead of naming the policy then you can’t type a name for the policy later ( the proper field is greyed out/unclickable).
  4. N/A

Font still being truncated in Defense + Settings


Window Settings:

DPI -115 (Customized at 120%)

Resolution -1024 x 768 pixels

Font size - Normal


System Information

[attachment deleted by admin]

  1. P4 HT [ at ] 3,7 Ghz 1 GB RAM
  2. WinXP Pro SP2 32-bit + online updates
  3. Avira Antivir PE
    4. ‘Active Connections’ still cause random crashes (I’ve already sent crash.dmp). Also, rolling up current connections doesn’t work as it should.
  4. N/A

I have a Dell 8200 Win XP Home Edition. On downloading RC1 it indicated that I had a problem. I have System Safety Monitor installed. I downloaded and it seemed ok till the second re-boot. This computer is wireless through a Linksys USB adapter to a Linksys router. They would no longer connect. It works fine with 2.4. Is there some way.

in firewall’s ‘active connections’ window collapsed connections list for an application expands when, presumably, any of the connections there changes. effect: you’re constantly forced to observe your p2p app connections. am classifying it as a bug because i utterly fail to see any rationale behind this.

This is the fifth beta (now RC1) I’m trying and no success :THNK
The problem is always the network driver

I’m attaching the diagnostics report. What makes me think is:

[Incompatible Software]: No

  1. Probably the registry key, for any reason, isn’t being able to register. Can anybody guide me how to create it? Seems that I don’t have incompatible software.

  2. Why the driver is not being detected as signed? (see first picture).

C’mon programmers, this is the 5th release and the same errors continue here… I want Comodo :THNK

[attachment deleted by admin]

I usually receive 3 errors in a row running cfpupdat.exe or cfpsbmit.exe when I attempt a connection using start or submit buttons
I have a P4 HT, My system internet browser is Firefox, OS: XP sp2 32bit, AV: Avast
Since this is very annoying I looked for more info using Dependency Walker

The issue is related to RASAPI32.DLL (Base Address 0x76ea0000)

Using Dependency Walker profiling function I got no error but I noticed that RASAPI32.DLL is loaded only when i press the start or submit buttons…

I guess that something prevents RASAPI32.DLL from loading when Dependency Walker is not used to launch cfpupdat.exe or cfpsbmit.exe

  • The instruction at “0x76ea3cd9” referenced memory at “0x76ea3cd9”. That memory could not be “written”(translated)
  • The instruction at “0x76eaa773” referenced memory at “0x76eaa773”. That memory could not be “written”(translated)
  • The instruction at “0x76ea32a5” referenced memory at “0x76ea32a5”. That memory could not be “written”(translated)

This happens here too. :frowning:
Running on AMD Athlon 1000 MHz
Windows XP SP2
Antivirus: Avira AntiVir Security Suite (without firewall)

Hi Comodo

Pretty serious problem encountered here. Started with the last Beta and is in this current RC1.
The install goes fine without a hitch, after the re-boot cmdagent.exe sits at 100% cpu for a very long time over 10mins. CPU, fans etc screaming at me to stop this process. Defense + was showing all the processes it was learning but the computer was unusable.

I’m sorry that I didn’t report this sooner but here are the specs:

HP laptop
Win XP SP2
CPU Type Mobile DualCore Intel Core Duo T2400, 1833 MHz (11 x 167)
System Memory 1015 MB (DDR2-533 DDR2 SDRAM)

Comodo BoCLean 4.25
Avira AntiVir PE Classic

With the other Beta’s, I never had this sort of problem. Let me know if you need anything else. If you need a log of some sort, I would need to re-boot into safe mode and get that file over to you guys.


Please uninstall BOclean and report if it solve that issue.