CPF BETA Workarounds[CLOSED]

If you have an application that was causing or having conflicts with CFPv3, and have figured out a method to avoid those conflicts by changes to Firewall or Defense + rules or settings, please post those specific details here for the benefit of other users.

This is the first version of CFP 3.0 beta that I have used so I’m not sure if this issue existed with previous beta versions. I have my screen DPI set to 120. My eyes aren’t what they used to be so I use the larger dpi size to increase the size of the screen icons and text. When I installed CFP I was surprised to see the gui stretched and the portion on the right is missing and unaccessable. A few other have encountered the same problem (THIS Post). Apparently, this version of the beta does not support large size dpi settings. I hope this gets fixed in a future version.

To correct this problem you can go to your Control Panel-display-settings-advanced and reset your your dpi to normal size (96 dpi). This defeats the purpose of incresing your screen’s DPI to enlarge the icons and text and the screen icons and text will appear a little smaller on your screen but this will correct the problem of CFP’s screen truncation.

I have the same problem with not seeing the whole screen of the firewall interface. I cannot change the DPI setting because there are more icons on my desktop than will fit on a 96DPI screen. It would also scramble the order of the icons and I really don’t want to spend 20 minutes sorting out the icons every time I have to do this exercise. HOWEVER: I have discovered that if you click on the “Summary” button and then press the right arrow key (perhaps more than once is needed) the edge of the outline on the button to the right of the Summary button appears. Pressing Enter opens the Firewall settings dialog screen. The next button is also available by pressing the right arrow key when the edge of the outline around the Firewall button is showing and then pressing Enter. You cannot see the effect of pressing the right arrow key, so you have to just try the method on faith.

AnotherOne, if you adjust your screen’s DPI from 120 to 96 you will be able to fit more icons on your screen not less. Cheers Jim

Well, if there would be more icons, they would be so small that they would not be very usable. Besides, I read elsewhere that the problem is not always solved by going to a lower resolution. Personally, I think that the problem occurs for people that have 16:9 aspect ratio monitors.

Hey Folks

I know member “AnotherOne” has this issue as well as a few others, so hopefully this can help you guys too! My CFP is now displaying PROPERLY while still using 120DPI settings…here’s what I did before I noticed this new change.

I run Nvidia Beta display adapter drivers for the Geforce 8800GTS card and noticed Nvidia had a new version out, 169.04 now. So last night I d’loaded the new drivers, uninstalled the 163.75 I had and installed the new ones. If you guys also run these Nvidia Forceware drivers, upgrade to the newer one and make sure to UNINSTALL the old ones first. The display is a mess after the reboot to finish the uninstall but it’s workable to install the new ones.
After installing the new ones I had to go into the NTune utility and reset all my dual display options and re-adjust the color, resolution, and reffresh rates once more. 3 things to note if you use Ntune CPL for Forceware drivers, (1) newest one is version, (2) on the “Adjust image settings with Preview” page, check the “Let the 3D Application Decide” or you’ll have troubles with Roxio MyDVD backgrounds (and possibly others, including this GUI issue), and (3) set the Flat Panel Scaling to the “Use my Display’s Built-In Scaling” setting.

After this I went into Personaliztion (in Vista), chose the “Adjust Font Size DPI” setting and then “Custom DPI”. Check the “Use XP Style Scaling” and grab the ruler with your mouse and move it around some but set it back at 125% which is 120DPI.

After that I decided to open the CFP CPL at which time it opened with a correct GUI size (which was not like that before last night), and my jaw hit the floor…literally.
So, I’m not exactly sure exactly when or which of these things finally kick started it into working, but one of them did. So, uninstall and reinstall your display drivers first and see if that’s it and if not, try some of these others and see if that helps.
Me…I’m just stinkin happy to be able to finally get into this new beta and do some testing and tweaking!!! :BNC

Good Luck to you others, I really hope that one of these things helps you get your’s going too! I really think it’s probably reinstalling the display adapter drivers that did it myself. I think CFP’s install routine now jumbles something up & reinstalling it after CFP is installed already, sorts things out once more.


Really guys…that’s SERIOUSLY CONFUSING when you zap main posts like this without notifying the OP or leaving a link to it from it’s previous location…cripes…
I had a heck of a time finding this and the other members whom I PM’d with a link to this post will now have broken links and will probably not find this now.
Not “everything” has to have a neat little spot to fit into…the boards become overrun with sub-sub-sub-child forums for every possible issue and nobody can find their way around without a GPS. Just my $.02 there

Anyway, some rather bad news. After a reboot the GUI size issue is Back and will not respond to anything I tried before, except I have not reinstalled the display adapter drivers again. If that’s what it takes to get the GUI working, then I’d need to reinstall those drivers at least once daily and that’s NOT something I intend to do. (:SAD)
I will continue trying to find a workaround for this (now that it’s in the workaround forum, I guess I should call it such), and if I can find one that sticks I’ll let everyone know.

Don’t be too ■■■■■■■ the Comodo guys. My eyes also are no longer what they never used to be anyway(?!), and I’ve been running at 120DPI for years. In my experience NO PROGRAM EVER DESIGNED has been made to accomodate the ‘large fonts’ setting. Dialog boxes that have large areas of grey space, or that have text running off the side, or have checkboxes stacked so closely that they obliterate each other are par for the course. Sometimes you get lucky, and the programmer just coincidentally happened to leave a lot of space in their dialog boxes, and things fit OK, but generally, large fonts will wreck most things!

I wouldn’t go that far. The Windows system has no problems with a larger DPI. I can think of dozens of applications that adjust correctly. Thunderbird, Lotus Notes, MS Office … the list goes on. Now days, many programmers are not conscientious enough about stuff like this. IMHO that and adequately testing the GUI is where the problem lies.

Al (test with 120 DPI) Adric

Hi Chappy - I found your post eventually, but I run an ATI card and it is a bit different. Oddly, I tried updating the drivers and the ATI dialog window at the end of the installation had font spacing problems. I have complained to them, assuming that their software should scale the windows to fit the monitor properly. I mean that it should be possible to see all of the window’s parts, even if the font and DPI and aspect ratio are non-standard. It may still be a problem that Comodo needs to fix (it would be a lot faster than waiting for ATI to re-write the video card drivers).