CP causing bluescreens on resume from Standby and Hibernation, on Vista

so, I’ve a Lenovo W500 and have, since the day I got it, had some problems with the graphics and some problems with the fingerprint reader. both, I’ve found out have been caused by Comodo.

with the fingerprint reader, there were two files %systemroot%\LogonUI.exe and one of the Lenovo Fingerpring Reader dlls that needed to be allowed, in safe mode, before booting, otherwise the system would hang at the logon screen, with no progress.

with the graphics, I don’t know the root of it. whatever happened, when you went to resume from Standby or Hibernate, the machine would bluescreen, with the notice “BAD_POOL_CALLER”. I posted a few minidumps from one of the crashes (which I’m doing with this post too) and one of the members there analysed it and found that “inspect.sys” was implicated in both dump. I then tried to disable the firewall and firewall service, restarted, then tried to go into and resume from Standby and Hibernation, to no avail. only when I uninstalled the program completely was I then able to go into standby and hibernation and get back out of them again.

I love Comodo and it’s easily the firewall of my choice, but currently, there’s no way I can use it and I hope that someone can help me get this sorted. I can’t bring myself to use the Windows Firewall, I really can’t.

thanks for any help that people can provide.

[attachment deleted by admin]

hi guys, I’m just wondering if anyone had a chance to look into this, I’m currently using the windows one, which I really hate.

Hi seaders,

I had the same problem, and am currently running the latest beta to test it, and it seems like it’s fixed.

Thanks for the reply, Ronny, did you have both problems, the fingerprint and the resume bluescreening, or just the bluescreening? I’ll try the beta now.

is there a different beta that you have access to that’s not on the main site, because I downloaded and installed the newest one,
and the problem was still there. both of them, the fingerprint reader and the bluescreens from resumes.

I only have the hibernate/standby BSOD, i don’t have a fingerprint reader so i can’t test that.
You can find the beta only on the forums, Under CIS, Beta Corner:


Please be aware that this beta is for testing purposes only, launch for final is scheduled for the 10th of February.

righty-ho, that’s installed and it seems to have sorted the problem, I’ve put it to sleep twice and hibernate once and not one bluescreen. fingers crossed there’ll be no problems.

thanks for the help, Ronny.

That’s great to hear, then it can assume it’s fixed :-))

Please be aware of the following, if you imported your “old” settings then your av database path is the wrong one for the beta version.

nah, I very rarely import the old settings of anything like this, always nicer to start afresh, I feel, so that wasn’t a problem. also this is a work laptop and we have to use a specific AV, Symantec Client Security, unfortunately, so it doubly wasn’t an issue!

you certainly can assume it is fixed and thank you again.

Is that confirmed by now? Melih was suggesting to do so but wanted to talk to the devs first.

Nope, i was only “quoting” Melih on what i though was the latest status :slight_smile: