Could not save user settings

Hi all,

I run CB on 5 computers and I have been having a recurring problem on one of them.

Since installing early this year, on one of the computers CB began periodically losing its user settings and something refusing to save them after change. I turn settings on or off and they stay that way for a while, but then mysteriously revert to defaults.

Even when CB appears to have correctly saved its settings, it continues to automatically install updates even though I have told it not to. I have uninstalled completely (including settings) and reinstalled with no change in the behavior.

The computer which are behaving have entries in the registry under HKCU\software\comodogroup\comodobackup\settings and a folder under \appdata\roaming\comodo … the oddball computer does not - all the registry entries are missing except for the Windows Context Menu which is enabled. The key/subkey permissions all look ok (same as other computers) so CB should be able to write to them.

Has anyone seen this? Any ideas? I’ve been burned by automatic updates before (including by CB in any early version), so I prefer to leave them turned off.


Forgot to mention: reset defaults does change the registry information, so CB definitely can write to the keys.

I also have tried importing HKCU\software\comodogroup\comodobackup\settings from one of the working computers. That seems to fix shell integration, but it doesn’t make any difference to “scan for files” or automatic update - they remain enabled each time I open CB regardless of the registry settings.

And even with existing registry entries, I still get a “Could not save user settings” error.