Correct SetUp & Parameters for Ad-Hoc WiFi

Good evening everybody, ;D

I have been encountering a little issue with CIS, and I’m trying to get it solved if anyone ever had the same pb before…
I want to set up an internet connection sharing between my PC (Vista32) and my iPod Touch4.

  • The PC is linked to the Internet via ethernet connexion (wire!) and has no pb accessing the web.
  • I set up the ICS in Windows, no using DHCP.
  • The iTouch joins successfully the ad-hoc network
    and here is the stuff, it won’t connect to the Internet, at least when CIS is running.
    Disabling the firewall provides full access to Internet on the iPod.

here is sumup of config :
PC : LAN connexion → DHCP /// WiFi connexion → TCP/IPV4 set as below :

iTouch : WiFi connexion as below :

  • Static - (router = PC)
    DNS : the one of my internet provider
    HTTP Proxy is set to OFF

again no prob. to join the wifi ad hoc network, but the internet acces fails.
What rules do I have to create so as to allow the ICS ??

2 events in the firewall log when connecting to the wifi network

  1. Windows Operating System asked for UDP out from the main PC destination port 53 - DNS
  2. svchost asked for UDP in from iTouch IP to unknown IP destination and source port 123…

I’m set to “safe mode” and alert setting is “medium” and box “This computer is an Internet connection gateway (ICS server)” is of course checked…

As I said, disabling CIS makes things easier, but with a worse protection, which I’m not satisfied of.
Thanks for reading me till the very end…this is kind of frustrating >:-D
Waiting for your suggestions.

First of all make sure you disabled Do not show popup alerts.

When you get an alert for port 53 allow and see if that solves the problem. Port 53 is for DNS look ups. In short it translates the url (f.e. to the actual IP address (a set of numbers).


Thanks for answering.
I partially solved the pb.

“Do not show popup alerts” was unchecked.
Even though when I got the itouch connected again today, the firewall wouldn’t ask for anything… ???
I unchecked the ICS option.
Then had a look at the firewall log (pic posted) wich showed that it had been blocking several requests (without asking…). So I created a rule accordingly for Windows Op. System, TCP, Out, from my computer’s IP.
Then suddenly a popup aert appeared : DNS request out, so I allowed. Didn’t change anything really.
Then when refreshing the page on my iTouch, new alert : HTTP, port 80 from my computer. So I allowed, and everything worked!
The problem is I don’t really understand why. And also, the rule I created is for my computer’s IP (which I have to get by DHCP as my ISP is for large amount of computers), so I may have to change the rule if the IP changes !
Comodo seems to have dark secrets…

[attachment deleted by admin]

For my understanding. Your computer directly connects to a modem (are you on a cable connection?) without a router in between. Your computer acts as ICS server and provides a wireless access point through which your iTouch connects to the web.