Context menu problem with XYplorer

Hi, I’ve been using Avast antivirus with Comodo firewall for years but decided, a few days ago, to give CIS a try and so far it looks pretty good. Haven’t done a plethora of tests yet but I feel safe and secured. It’s Comodo after all. Of course I’m missing some functionalities but not much. I will make some suggestions in a near future when time and mind permit.

My main problem right now is that Comodo options are missing in the context menu of the great piece of software that is XYplorer (advanced Windows Explorer). Strangely enough, Avast was showing.

I know that CIS is in the 64bit folder but can’t remember if Avast was too, I guess not.
XYplorer is a 32bit application, but should be 64bit in a near future.
I’m using Windows 7 64bit.

I’ve read a lot about that problem and how to apply some tricks to be able to get Comodo in the context menu but wanted first your opinions and maybe a real solution if possible.
Solution can be read here: Fix for 64bit Explorer Context Menu in XYplorer - XYplorer Beta Club

Going back to Windows 7 32bit or using Windows Explorer cannot be part of the solution, it’s out of the question. >:(

Thanks in advance :slight_smile:

It looks like a legit solution to me.

The tutorial also has a solution for Comodo. That solution is for v5. For v6 you will have to change cavscan.exe to cavshell.dll. That should be the key to getting it ready for v6.

Hi EricJH and thanks for the suggestion but unfortunately it doesn’t work.

I was about to write back about that and asking for help. I guess you’re right about that solution being for V5. All I get is Cautomaton showing for half a second in the taskbar but then nothing.

Here is the line I added in XYplorer Tools > List Management > Portable File Associations

|“Scan for virus|C:\Program Files\COMODO\COMODO Internet Security\cavshell.dll”*;>“C:\20120223 Cautomaton (0.9.0)\cautomaton64.lnk” /m “Scan with COMODO Antivirus”

I’ve tried with with same result.

I had tried previously with cavscan.exe but it was not working.

I guess I will look for a replacement until XYplorer is 64 bit for which there’s no ETA.

By the way, Avast was installed as a 64 bit application. It was in the Program Files folder in Windows 7 64 bit.

Thanks anyway.