Connecting to a VPN

I am currently pulling my hair out trying to connect to a VPN with Comodo firewall up. Searching through the forums has turned up scattered information, but nothing has helped thus far.

I am currently using Comodo version 3.09.229

The address for the VPN I am trying to connect to is…

Actually here is some information from this particular VPN service on how to connect through a firewall…

“If your router/firewall supports PPTP pass-through, you should have no troubles connecting. Many routers/firewalls handle PPTP connections fine even though they do not explicitly advertise PPTP pass-through capability. Your firewall rules must be set up to allow outbound connections to on TCP port 1723 and IP protocol 47 (GRE).”

Now I’ve tried setting Comodo up according to these instructions, but I still can’t connect. (I’m sure I set something up wrong) I know it’s not my router or anything, because as soon as I disable Comodo, I can connect to the VPN service no problem.

Can someone tell me, step by step on how to accomplish this?

Thanks in advance!

Welcome to the forum NegativeX,

What I found out was that if you use the hostname( in a rule it doesn’t work. I’m using the beta of CFP. What I had to do was go into Firewall>Common Tasks>My Network Zones and create a new Network Zone and enter the hostname there. Also give it a name you can remember. Then you can go back and make a rule that would look like this:

Allow-check the checkbox to log
Source Address: ANY
Destination Address: choose “Zone” here and pick whatever you named your Network Zone)
Details: Choose “GRE” as the protocol from the drop-down box. It is near the bottom.

That should get you running. Put this rule at the top of your list until you get the VPN working then you can move it down if you want.


Hi, i done your recomendation, but Comodo show me in Events what System Idle Process GRE is Blocked (i create rule in Global rule section), and i create rule in Application rule section for application System Idle Process with this settings, and all work fine (:NRD)

Sorry for my bad english :slight_smile:

I using Windows XP x64 Professional SP2. This does not works.
If I trying to allow and log GRE in rules when I see in logs what GRE is blocked.
If I setting firewall security level to disabled and after that trying to connect VPN the connection establishes successful. After that I can to disable VPN, to switch security level back and try to connect to VPN again. It will be successful. Rebooting makes VPN connection impossible again.

Later I’ve tried to allow GRE & IGMP for Global Rules, and for “System Idle Process”, “svchost.exe” and “System” processes. Now it’s works, but not just after loading. I’ve need to wait 1-2 minutes before I will can to connect to VPN.

COMODO Firewall have serious problems with logging and global rules.
Logging: By reading logs user unable to understand why certain connection was allowed or denied.
Global rules: GRE not denied but blocked, when allowing GRE then GRE connection will be logged but still not allowed.