conflicts with age of empires 3

It seems the firewall has some problem with age of empires 3.

When I using the firewall , it will block me to find the game rooms on LAN or by typing IP address even through I set the application to trust application ,and I also tried to set the firewall mode to disabled ,it also not work.

I tried to uninstall the firewall then I can find the game room again.

It seems the firewall block the UDP packet received from other host because when using the firewall I see the network usage in the firewall, port 2299 either UDP in /UDP out, one of it must be 0 bytes usage.

Does anyone know how to solve the problem? Or is it a bug of the firewall that wrongly blocked the UDP packet?
I am using Win XP Pro SP3 and the firewall version is


Hi d2003

Welcome to the Comodo forums

Have you tried all the suggestions in this thread. Post back and let us know.


I disabled defense+ when I install Comodo Firewall and I also tried training mode or disable the firewall but it doesn’t work, I also tried to right click and exit the firewall ,however after I uninstall the firewall the aoe3 woks again.
So I wonder Comodo firewall “disabled mode” is it really disable all the protection.

You are right. When you disable or even Exit the firewall - a process cmdagent is still running and it can be a cause of the blocking :frowning:

But is there any way to let me play the game without uninstall the firewall?
I can play other games but not aoe3 and I already trust that application.

But your problem is strange 88) I have Comodo’s CFP 3 and play AOE 3 and it’s extension without any problems :slight_smile: I just use the Vettetech mode ;D (Set the firewall to training mode before launching the game). But you already tried that, so it’s odd that it didn’t worked :frowning:

Try deleting the rules for AOE 3, set the Firewall and Defense + to Training mode and launch the game again :slight_smile:

Can you play LAN games with the firewall or you are playing ESO Online?
I can’t play the aoe3 LAN games with vLan (a VPN software for playing LAN games) while using firewall,but I can use vLan play other game while using firewall.So I just don’t know how to solve this problem. :frowning:

Odd 88) I can play LAN and Online games with no probs :slight_smile: (Though I have another problem with CFP 3 - constant internet loss :()

You can try deleting the rules for AOE and vLan and then lauch them again in Training mode. Or you can try Hamachi

I reinstall the firewall and set to training mode but it doesn’t work (including using Direct IP to connect) . :frowning:

Hi, regarding the AOE3 lack of network connectivity.

I ran AOE3 in a XP 64-bit and noticed the following:
the machine static IP address is;
the multiplayer screen shows address as

Then, I ran AOE in a XP 32-bit SP3 and noticed the following:
this machine DHCP allocated address is;
the multiplayer screen shows address as

The XP 64-bit machine uses Comodo CFP 3, the XP 32-bit machine does not. (:NRD)

Is CFP 3 the culprit?!

Hi, sorry for the rush comment!

As mentioned above, I was puzzle by the different IP addresses in my XP 64-bit machine. The reason…
I have installed VMware workstation in this machine, it creates two virtual network adapters and two additional networks internal to my PC. AOE3 was picking out one of these network addresses. (:WAV)

But the lack of network connectivity persisted after fixing the IP address problem.
When CFP3 exits the CoMoDo Helper Service, cmdagent, remain running; no way to stop it, only can be disabled which requires PC reboot. After rebooting the PC: CFP3 indicates CoMoDo Application Agent is not running; AOE3 connectivity problem remains–I should have experimented further.

I decided to uninstall CFP3 and voila! network connectivity achieved!..

I can make any game work with Comodo. Did you read my thread? Did you try putting the firewall a and D+ in training mode?

You may have previous entry’s that’s stopping changes being made while in training mode.

Delete the old entry’s, and then go into training mode and try again.

Firewall → Advanced → Network Security Policy

I had this problem also, I just read the “A Note To Gamers” thread and might try that some time, but im not sure if that will work sense I even disabled the firewall to try to get the game working and it didn’t, so for now ive uninstalled comodo…

No reason to uninstall Comodo. I made the note to gamers thread. I play tons of games and Comodo works with them all.

I cant get Age of Empires 3 to work with comodo firewall either.

I am running the 64 bit Comodo, version, on two computers, one with XP x64 and the other Vista x64.

I cannot get any games to show up in the LAN list when these firewalls are running. I’ve had several people around here for a LAN and I cannot join their games and they cannot join mine, as no games show up in my lists when they host or my hosted games will not show up in their lists. But they can join each others games because they are not running Comodo.

I have tried just about every setting known to man. I’ve created rules, I have deleted these rules and run both firewall and defense+ in training mode, I’ve disabled defense+, I’ve disabled firewall, I’ve put AOE3 in as a trusted application. I have done everything recommended in the previous posts. The only thing that solves this problem is to uninstall Comodo.

I really honestly believe there is a problem with AOE3 and Comdodo firewall. I have tried everything and I am open to suggestions.