Conflict with a game.

Hi guys,

I was asked to post here, because of an unsolved help ticket.

Ticket Details =================== Ticket ID: EYL-546556 Department: Internet Security Support Priority: Default

Ever since I installed CIS (not only 2013), I can’t join or host a match from a particular game: Rainbow Six Vegas 2 (others seem fine).

I think I tried every possible idea within my knowledge but in vain.

  • Activated “Game mode”;
  • Disabled IS firewall;
  • Added exceptions in application rules;
  • Opened router and IS ports.

  • HIPS are disabled by default, as well as Windows firewall - disabled during CIS installation;
  • Using Windows 7 Ultimate x64.

I hope these informations help to solve it.

Hello and welcome to the Comodo Forums!

Try changing both the firewall and defense+ to “Training mode” then run the game, this will set the application in a mode where it will not block any application connection attempts (firewall’s job), or application actions (defense+'s job).

To do this open CIS and open advanced settings, click Defense+ then click HIPS Settings, change the mode to training mode (near the top of the settings pane).

Do the same for the Firewall by going to Firewall and then Firewall settings.

After running the game, try putting back on “clean pc mode” or “safe mode” and see if it continues to work.

If you are trying to host a match and people are having difficulties connecting to your match it may have to do with your global rules so you may wish to review those.

Hello Justin, thanks for the welcome.

I did as you said but somehow and unfortunately it didn’t worked.

Just to clarify: when I try to host a match, it immediately logs me out back to the main menu and say: “Failed to initialize the service”. Takes about 7 tries to be able to log in again. As for matches, I can join but I’m able to go as far as loading screen goes. After that I’m sent to main menu again.

Could this be a severe bug/problem between CIS and PunkBuster (hack protection service adopted by Vegas 2)?

Hi DekosNamax,

Sorry to hear it didn’t work, I don’t think it’s an issue between Comodo and Punkbuster as I play an online game that utilizes punkbuster and I don’t seem to have any issues, however it may not be the same version of punkbuster your game utilizes.

Try the steps I outlined above again, however this time, try deleting all the rules for your program in both the Firewall and Defense+, the rules that are already in the settings for the programs are probably interfering with the firewall and defense+ “learning” what it needs to.

Hi again.

I don’t know what to say…

It didn’t work. =/

I removed all rules from “HIPS rules” of Defense+ and “Application rules” of Firewall but it still persists.

Posting the firewall log after trying to connect with the game would be helpful to see what its trying to do.

Hi aim, how do I do it?