Configuring Comodo Firewall V3 for P2P apps [CLOSED]

Great work on V3, works brilliantly on my Vista Ultimate x64 :BNC

Just can’t find the right option to allow the Azureus program fully through the firewall, if I tell Comodo V3 to allow everything then Azureus runs perfectly but setting it back to learn and Azureus tells me I’m firewalled. :THNK

Been through many settings but can’t seem to find the right one.

Any help would be great, thanks ;D

Hi Radeon

Try this HELP guide

All the help is available in the forum! Just search a little bit! If u still have troubles then post!


Thanks for replying. Have set the firewall as described in the link you gave me and tried many other different combination but V3 will still refuse to let Azureus fully through.

When I had V2.4 on XP I setup the port settings with no problems.

Wonder if anyone else with V3 has any P2P problems.

I am too having the same problem with utorrent. I managed to set up port forwarding with the previous version ok. Had a play with the settings but still no luck!

Any ideas anyone?

Network security policy-network control rule:

allow TCP/UDP
a single port: P2P APP Listening Port

Just put it above the block rule.

In V3, if you need forward a port, you should tweak the default network global rules.

you can click Firewall → Advanced → Network security policy → Global Rules
add a new network control rule:

Action : Allow Protocol : TCP or UDP Direction : In Source Address : Any Destination Address : Any or your computer IP adress Source port : Any Destination port : the port your P2P program Listening

Remember to add these rules over the blocking rule [Block All Incoming Requests]

Hi all!

I’m runnign utorrent with CPF 3!
No problems here!

Change da settings as “Ubuntu” has mentioned! PLUS you have to add a rule to the “specific application” under Application Rules!
If you can remember in 2.4 you had to choose the application as well as the port in order to get it working and it was all in the same window!
In this version it’s a bit different and you have two separate tabs to change the settings! But the functionality is the same!

And under global rules make sure that all the “RED” ones are at the bottom!


Thats was it, moved the red one to the bottom and Azureus instantly worked.

Thanks :BNC

First of all, I’d like to say ‘hi’ to famous Comodo family. Even though it’s my first post here, I’ve been following the development of Comodo security suits for some time and finally decided to try them out as they looks very promising.

I know that CFP V3 is still in development phase but when setting it up I ran into some doubts. It seems for me (please correct me if I’m wrong) that allowing the incoming connections for the particular port (i.e. to make utorrent work), as described in Damitha’s and ubuntu’s posts above (by putting it in a global tab), automatically makes that port vulnerable to attacks. The port is then open to all kind of traffic, not only the one made by utorrent. Shouldn’t there be an option to limit the usage of the open port only to one application (here: utorrent), to minimize the risk of intrusion? Or maybe allowing it in global tab is just the part of the job to make it fully operational and the port will not be open until it’s ‘re-open’ by the rule put in application tab?

I’d be very thankful if you could clarify the issue. Thanks in advance!! (:WAV)

Comodo’s firewalls use a method I call adaptive stealthing. If there is a network rule to open a particular port, that port will only be opened if there is an application running that can use that port. The ports are not just opened because there is a rule, they are only opened if there is a rule AND an appropriate application.

Hope this helps,
Ewen :slight_smile:

adaptive stealthing (:KWL)

Thats a good term it describes it well


Just to get a bit more info flowing here, I use Azureus and had no problems at all with CFP3 in a fairly basic setup. All I had to do was allow all the popups that came when I opened it for the first time after CFP was installed, hit the “Trusted Application” box when it was there to check, and always checked “Remember my Answer”
It took a little while to get my NAT showing in green, but it did and has been fine ever since.
One other weird thing happened today tho, but I’ll start a fresh thread for that so I don’t hijack this one.


Thanks for the quick answer, Ewen! Adaptive stealthing will, for sure, make me sleep well tonight. (S) I feel much safer, now, though I still wonder what is the “appropriate application” you wrote above? Is it possible that any aplication installed on my system - i.e. spyware - will be allowed to communicate by already opened (adaptively stealthed) port? I know that this is most probably strictly theoretical question as firewall’s hips will warn me about such event (won’t it?), but my point is if CFP V3 is somehow checking which application is accessing the port, that was opened by the rule in global tab?

Aha, this is what I was looking for. Thanks. :slight_smile:

I don’t know whether this have been stated or not but not only did I have to allow my P2P program (Utorrent) but I also had to set the stealth port wizard to “I would like to see firewall alerts for incoming connections”