Configured Firewall with LAN-Uplink, how to configure Wifi accordingly

I configured for LAN which software is allowed to access the internet under which constrains. Now I moved to a Wifi connection to the same network and with the current ruleset all connections seems to blocked ans no Alerts appear where I cold allow/disallow. There must be something in the configuration that I missed which makes my configuration network-specific or adapter-specific. Even though it is the same network and even if I enforce the same IP address as on LAN I cannot establish network connections with CIS fw active. What may be the issue? thanks.

You say than configure firewall in network for connection via cable, correct?
In wifi you not received alert from comodo firewall… This can happen if driver comodo firewall not install in device network.
see in setting driver network if filter comodo firewall present (see image);
in case negative, try install filter comodo firewall…

sorry my english

Thanks Liosant, very useful to know.

What’s the name of the Comodo Firewall driver file that has to be added to the WiFi adapter, is it “inspect.sys”?
Needs the Comodo Firewall driver file to be added from this directory “\Windows\System32\drivers\inspect.sys”?

not, inspect.sys is file than loading if service installed in device adapter network wifi or cable;

see image…
if file inspect.sys not present, only one clean install solved…

sorry my english!

Ah, yes of course, the image shows how it goes.
It’s clear to me now, thank you. :-TU

If the filter was not active for the adapter, all traffic would be allowed when CIS fw is running. The opposite is the case - so I dont think that this can be the solution.

It would do no harm to check if the filter is present for the WiFi adapter, is the filter listed?

You made rules that only worked when your system was assigned a particular local IP address that has since changed when you connected over wifi, as routers assign IP address based on network adapter MAC address, thus the MAC address of your LAN adapter is different form wireless adapter. You need to change whatever single IP address you set for source and/or destination address and use IP address subnet mask or address range as the address type for the rules.

Thank you, but

As expected, it is.

It is the same network, so destination IP is the same. The rules I use say “source IP: any” and as my original post says this issue persists

even if I enforce the same IP address as on LAN
, so it cannot be an IP-related issue but must be a MAC or NIC-based issue (and no, in the rules I used MAC is set to any as well)

Just a guess . . .
Could it be that the MAC addresses, which are unique for each network adapter, are linked or locked to the current rules somehow and therefore won’t work for the WiFi adapter?

That’s the Question. The rules are all Any src IP and/or Any Src MAC - at least what I can see. That is why I’m so cunfused that it does not work.

Have you checked the firewall logs for any blocked events? Do you have any block rules and do they have logging enabled for the rule? Are the rules in the correct order as rules are processed top to bottom, where top takes priority over rules below it? Do you have any of the following options enabled: block fragmented, IPv6 filtering, and/or anti-ARP spoofing?

No, I did not check the logs. I will when I use WiFi the next time. Logging is enabled for I think every rule, at least the random sample I just checked has logging enabled so it might be the default setting. IPv6 filtering and anti-ARP spoofing are enabled. I don’t understand how the order of rules can be relevant if LAN is working but WiFi is not?