Configure home network

hi there,
how can i properlly configure my home network ?
my ip adress is, my gateway is
i should set and mask ? or and mask ?
Thanks is more correct if you trust all devices on the network.

Go to “Advanced Settings → Firewall → Network Zones” and do :

  • Tick/Check “Enable automatic detection of private networks”
  • Tick/Check “Do not show popup alerts and treat locations as” and set as “Home”

Then remove all existing (Home) zone names from the “NETWORK ZONES” list and then click OK button.

Restart your computer.

After your computer has been restarted CIS will add new (Home) Network Zones to the “NETWORK ZONES” list automatically.when it finds new devices on the Home network.

Either one will do the same thing as it will cover all IP addresses on your local network, you shouldn’t need to do anything as CIS silently detects the first connected network and assigns it as a home network, then creates allow global and application rules for the home network.

It seems every time I restart my PC that Comodo adds a new network zone; it just keeps counting up. When my vpn switched from tap to tun adapter, this seemed to stop. Unfortunately, now that I have heard that CIS doesn’t support or filter through a tun adapter, I had to switch to the OpenVPN protcol on my VPN. It is currently up to Home #27. Strangely, it leaves all the previously used Home networks in the list not to be used again unless I go and delete them. 1-27 and tomorrow it will be on to #28.

Do all newly added network zones have different IP addresses after computer restart?
If so than probably OpenVPN assigns new dynamic IP addresses each time when you restart your computer and than CIS adds those new dynamic IP addresses to its network zones because it detects a new Home network.
Maybe it is possible to merge (cover) all network zones into one network zone with a proper IP address (range) and Subnet mask setting so that CIS doesn’t add new network zones anymore after computer restart.

It looks that way. The virtual tap adapter zones Home #1, Home #2, etc. all have different addresses. The wifi IP address seems to be stable. Every once in a while I delete all the excess zones.