Configuration import/export does nothing


Im a long time user of Comodo firewall, possibly 3 or 4 years now, and i use it across multiple machines within a home network environment.

Introducing a new machine into the fold recently i was hit with an issue ive had many times but never actually resolved, and in the end always done manually; migrating the predefined rulesets i use as standard on other installs.

Im sure the configuration import/export should do this (reading other threads people suggest it does) but it doesnt for me and it never has in all the time ive used the product, on any machine ive ever used it on.

So, what am i doing wrong? I go to Manage Configurations/Export, save the file, transfer it to another computer, import the file, activate the config, reset the computer, but it never works. Always the most recent version installed, always in the same path (apart from sometimes the drive letter, which looking in the cfgx file is wildcarded anyway).

Is there a workaround for this? Maybe the rules can be saved via registry key or an ini file or something? Or is manual input the only alternative?

Many thanks.

Edit: Just tried an experiment, Closed CF, renamed the custom config ‘COMODO - Proactive Security.cfgx’ and overwrote the one in the program folder. Didnt seem to achieve anything.

On closer inspection of the custom cfgx file there doesnt appear to be any reference to any predefined rules which ive made myself. Presumably this means that you cannot export custom rules via this method?

Indeed you can’t do a straight copy from one machine to another. The export function is meant to save the configuration of one machine over different versions of CIS.

I saw a post by Ronnie where he gives a tip on editing the config files. You can find the post here. I think the catch may be in the Group UID that should not be copied… That being said; I have never tried this. This is at your own responsibility.

I see, thank you.

Yes, I was considering manually inputing the rules into the cfgx file but it was the UIDs that put me off. Thanks for the pointer, very helpful, once im home i will experiment and see if i can get it moving.

Will report back.