Compatibility issue with CIS Antivirus and latest Windows 7 SP 1


there seems to be an issue with CIS Antivirus component after installing Microsoft’s latest update for Windows 7 (two updates plus the release of SP 1 as of 22 Feb 2011).

My system, a DELL XPS 1340 laptop, with Windows 7 Pro 64bit came almost to a halt after installing the above mentioned updates. In detail, those updates are:

KB2484033 (update) - installed correctly
KB2488113 (update) - installed correctly
KB976932 (Windows 7 Service Pack 1 for 64bit systems) - installed correctly
KB2387530 (update) - caused error during installation

After installing the Windows updates as listed above and after restarting the laptop, the system was rendered almost unusable, responding extremly slowly, almost coming to a halt. Unable to execute applications or only with very much delay after which they would not respond any more. The task manager did not start up after choosing the corresponding option from the task bar (right click on task bar, then selecting from the menu). It was not possible to shut down the system either through the different options available in Windows (Start menu, F4 on desktop, etc.). In short, the system was basically not responding.

Only when I disabled the Antivirus component of CIS Premium, all of the sudden all programs started working correctly, although I received an avalanche of security request from CIS (strangely, because only the Antivirus was set to disabled, not so the firewall or defense functions). I did not understand why it would ask e.g. if Firefox and many other common applications should connect to the network when those applications had been run under CIS before, having been already confirmed to CIS as OK (“remember answer” was always checked.

This is just to let others know that there’s an issue in case they run into the same trouble. From here on I do not currently know what the next step will be, but I suggest COMODO looks into this and provides an update for CIS ASAP, as I’m sure there will be many others with this issue.

BTW, CIS never popped up a message asking to allow the newly installed applications to be executed or access the network. I was completely silent until I disabled the Antivirus component! I had restarted the laptop about 5 times, so there was enough opportunity for CIS to react to the updates. It didn’t and the system slowed down almost immediately after reboot.



I just installed those same updates and have noticed no problems.

The difference is that I had the antivirus disabled during the installation. (I always have it disabled and only use it for manual scans.)

Let’s see if other people have had the same problem.

No problems here either.

Did you have the antivirus enabled?

Possibly related post (W7x64 SP1 & CIS).

I didn’t have problems with SP1 for x32 as such. But, I did note elevated CPU for cmdagent during the SP1 update, which seemed to be slowing it down (just prior to the actual install). I temporarily disabled CIS’s AV & this resolved the issue.

actually I think there is a problem with the new update.what happened today that I was working on my laptop and I had to go to have lunch and when I came back and started using my laptop,it suddenly stop working.everytime I start my laptop and after 5 minutes everything freezes and I have to restart.I saw the windows 7 updates and I installed them hoping that they will solve anything but they didn’t.until I saw this thread about disabling the antivirus and it actually worked! I also noticed that there is an update about stopping the new weird message that tells you that there is a new update (I saw that one again btw) so it has nothing to do with SP1.the conflict is between windows 7 + new update + comodo antivirus.I will keep disabling the antivirus until comodo solves this.


I have Windows Seven x64 and installed SP1 few weeks ago. No problem till today.
PC freezes after few minutes of working. I have re-installed CIS, same problem.
With disabled antivirus no problem.

Please, solve this problem!

i dont think it is just CIS, I had just installed SP1 about 20 mins ago and its being a pain in the a$$…I had CIS AV stateful, Defense+ clean pc mode, Firewall safe mode (both with create safe app rules) I noticed nothing in AV logs about a stop and I have it on high heuristics, Defense+ didnt say anything was unrecognized, and nothing was sandboxed.

After the reboot and Stage 1 of 2 completing I logged in and then everything got really slow still no issues with CIS but I did notice that some .NET framework kept taking up 25%CPU for about 15 mins and then after it stopped I tried to look into CIS and it just responded very slow. I tried to open task manager but seems to hang for quite a time before it opens and alt+ctrl+del doesnt respond so quickly either. I then had it shutdown and which it is still in the process for the last 15 mins, it is preparing windows for configuration. I think this is just not CIS but an issue with SP1 and updates. I think ima just uninstall it for now once pc shutdowns until this is resolved since I had no issues until installing the update.

I think MS ■■■■■■■ up something and if you search around not just CIS users are having issues with this SP1 update and some complain about longer boot times

I’m having the same issue and I still haven’t downloaded windows 7 SP 1 so no I don’t think it’s related to it.

I have installed SP1 few weeks ago and CIS work properly till today!
If it’s SP1 problem, why i don’t have noticed any freezes past week?
It’s CIS problem, cause with disabled AV windows works w/out freezes.

@Hakimy: Do you have automatic Windows Updates enabled and if yes, how exactly is it configured? Does it download and install new updates automatically?

I just got this problem this morning and I don’t have windows 7 SP1 installed.

Edit: SNIP. I may have inadvertently hijacked nopik’s thread.

@opatys: it checks for updates and install them at 3 am.this is the default settings and I haven’t changed anything.but like I said,the problem is with the new update and comodo has nothing to do with SP 1 (which I’m downloading at the moment).

I am also having an issue with Windows 7 x64 this afternoon. I did install SP1 yesterday but didn’t start experiencing problems until just over an hour ago.

I was just doing some file sorting on my hard drive when my computer started hanging, hard. It would take 5 minutes for the simplest task to complete, such as opening a file or even opening a dialog screen on an already open program. I did a hard reset, and upon rebooting found “WerFault.exe” running, right around the same time that my system started the hanging behavior again. Correct me if I’m wrong, but isn’t that the Windows component that runs whenever a program crashes?

I also noticed that Comodo was asking me for permission to do just about anything, including allowing Firefox to connect to the internet, and letting the most basic of Windows functions run. I also noticed my Defense+ Trusted Applications list was completely empty. I had Comodo run a diagnostic, it fixed the problem, and I rebooted. Well, Comodo’s functions were once again working, but I still had a problem with the system hanging.

I finally disabled the Antivirus and Defense+ modules, did another hard reset, and now my computer is working 100% fine. Perhaps a patch is needed?

Based on what some members have posted, this might be an issue with the two updates (KB2484033 & KB2488113) that appear following the installation of SP1… or it might not (of course).

Not sure these are the same issue glifford, as most (so far) are not seeing/reporting cmdagent faulting/crashing.

But i have same problem and couple of events in log:

Faulting application name: cmdagent.exe, version: 5.3.45685.1236, time stamp: 0x4d348b32
Faulting module name: unknown, version:, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0000000003b2e3cc
Faulting process id: 0x774
Faulting application start time: 0x01cbd37e572cf662
Faulting application path: C:\Program Files\COMODO\COMODO Internet Security\cmdagent.exe
Faulting module path: unknown
Report Id: 9d303d7d-3f71-11e0-86f2-83d866290802

Then please post in the topic that glifford mentioned, thanks.

I just have a look at avast forum and some users there have also problem since win7 SP1 update.

No lockups or crashes with Win 7 32bit here. Updated to SP1 couple hours ago everything went smooth.