Comodo Won't Uninstall/Reinstall

A. THE BUG/ISSUE (Varies from issue to issue)
Yes, won’t uninstall/reinstall no matter what I do:
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: noticed that the cmddata.dlmdb was getting inordinately large so decided to get rid of it.
2: found advice at to not delete the file, but rather save the configuration and then uninstall comodo and reinstall and then import the configuration
3: Tried uninstalling using windows uninstall function. Did not do anything.
4: downloaded and ran ciscleanuptool_x64.exe. Many of the messages appeared in red indicating that files could not be deleted/accessed. It took a long time and finally ended with a “RESTART” button on the bottom right.
5: I hit the “restart” button and the computer restarted and presented me the ciscleanuptool dialogue again.
6: Ran the tool assuming it needed to do a final cleanup after reboot. It ran again and spewed out a bunch of red “cannot delete/access” messages again before ending with another “RESTART” button.
7: Hit “restart” again and the same thing happened all over again.
8: Hit “restart” again and this time stopped the ciscleanuptool before it could run again.
9: Downloaded latest version of cispro_installer.exe and tried installing. It started, extracted files, and disappeared. I waited about a minute thinking it might just be getting itself together in the background, but nothing was happening and I couldn’t see any indication of it in task manager.
10: Noticed that there were three comodo tasks still executing in task manager after reboot, so tried killing them. I could stop two of them, but the 3rd wouldn’t quit.
11: Tried rebooting and trying again a couple times to no avail.
12: Tried running the uninstaller a couple more times. No effect.
13: Went back to the restore point that the uninstaller created.
14: Once that was done, I tried installing latest version of comodo again and just left it. After about 10 minutes, the install dialogue came up and I tried to proceed through it. But it quickly came up with a message saying that it needed to be uninstalled first.
15: gave up at this point.

One or two sentences explaining what actually happened:
see above
One or two sentences explaining what you expected to happen:
Expected it to uninstall and install.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how you tried to fix it etc:
No idea.

Exact CIS version & configuration:
Not sure. Assuming it’s the latest as I think it has been auto-updating. Can’t tell now because I can’t get into it.
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Firewall and antivirus.
Have you made any other changes to the default config? (egs here.):
Not that I can recall.
Have you updated (without uninstall) from CIS 5, 6 or 7?:
Assume it has been updating to latest automatically
if so, have you tried a a a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
see link below with sysinfo file.
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=Non except whatever comes with windows 10 by default b=none

C. ATTACH REQUIRED FILES (delete this section (section C) after attaching required files)

Link to google drive with all logs, files, etc.:

Restart / reboot windows into Safe Mode and run ciscleanuptool_x64.exe again and follow the instructions. That should remove CIS completely.

That Worked!

Hi All,

If the CIScleanup tool fails and you still think you have Comodo installed and can’t re-install, provide the following log files as input in post:

  • You will find log in same folder from where uninstall tool was executed
  • You need to find all logs from Windows temp folder (Windows Key + R and then type in %TEMP%) of following format:
    COMODO *_uninstall.log

Thank you for supporting.