COMODO Windows Tweaker 1.0.55931.13 BETA BUG Reports

Please post all bug reports & BSOD’s here.

Be sure to include:

  • Your Operating System (and whether it’s 32bit/64bit);
  • Security Software Installed;
  • How you produced the problem;
  • How you tried to resolve the problem;
  • Screen-shots with the error (if any);
  • Post Memory Dumps on crash if you encounter any;
  • Any other Additional Information;

Diagnostics finds manual.chm altered and cannot repair. In dialogues with Finish and Cancel as options Finish does not work.
System Information
Windows vista basic 32bit 1gb ram with 1.25gb ready boost AMD Athlon 4000+ Other programs running Avast 4.8.1290
Note i had just uninstalled Comodo Internet Sercurity and Apple mobile device driver.

Re the above known issue, Is this issue related to it?

I had to reformat my VM because of this nasty error after cleaning Privacy & Applications (All). Maybe this is similar. Couldn’t boot at all.

Windows XP SP3. And yes… It was in VM. :slight_smile: Production is fine. :wink: I had to use my camera to take a picture of the error, I think either the Privacy Cleaner or Application Cleaner when I cleaned utorrent and the rest wipped out alot of shell32’s. Anyway pic below, Hope it helps!


[attachment deleted by admin]

We know about this issue , and it will be fixed in a future realease.

Thanks for the post

Thanks. Just confirming.


Windows XP

Automatic updates for this program. A window opens showing this message:

“Your Comodo Windows tweaker is up to date.
Please press Finish button to exit.”

But when you press the Finish button nothing happens. The Cancel button has to pressed in order to close the window.

I second that


Comodo System Benchmark, processor tab, wrong spelling: runing instead of running

“One thousand threads are runing in the same time”.

Overall tab: “Testing processor speed with different”
With different what?

Comodo System Settings - Web Browser, wrong spelling Intenet instead of Internet
Temporary Intenet Files

Is there any way this program can display actual processor speeds?
My hardware setup is Intel Core2 Quad Q6600, G0 processor.
The default speed (upon purchase) is 2.4GHz, actual current OC speed: 3.627GHz

Vista Ultimate x64, CIS, Avast
hardware list available upon request.

Please see attached images for listed bugs:

  1. CPU actual speed is incorrect.
  2. System Benchmark/Disk causes the window to crash, test becomes aborted as a result.
  3. Privacy Cleaner needs enhanced security wipe methods included as options.
  4. Startup manager does not show anything.

[attachment deleted by admin]

Not necessarily bugs …

All modules appear to use a generic “Clean process …” warning dialogue if the user attempts to start one module while another is still running. The wording “Clean process” is not applicable in all cases.

Some modules display a progress meter in the centre of the modules window, some display the progress meter in the status bar at the bottom of the modules window and some don’t display a progress meter at all.

Window pane dividers are not adjustable and some are too small to be useful.


  1. Export folder structure as an XML file.
  2. Able to compare two exported XMLs and display increases/decreases. (May be able to use the File Compare code to help this)
  3. Display folder properties when hovering over a chart segment.
  4. Adjustable width on LOCATION pane.
  5. Option to save/print chart of folder size detail listings.


  1. Tests are absolutely irrelevant as there is no indication what they are being tested against, or what is a good or bad measure. This applies to all tests.


  1. There should be a progress meter displayed whenever the app is still gathering Internet related information.
  2. When a file path extends to a second line the second line of text is truncuated along the bottom edge.


  1. Ability to export the hardware and software inventory


  1. Any changes made to the Privilege Manager need one, preferably two confirming dialogues, as changes can have implications way beyond the understanding of most users.
  2. Right clicking on an unhighlighted process does not display the context menu available for that process. You have to left click the process to select it before you can right click to modify it. A right click should automatically shift the focus to that object and display the context menu.


  1. Does not support wildcards for locating files - you have to explicitly add the file/s to be renamed.
  2. Needs to support multi-ended rename operations - i.e. replace X number characters with a specified string, starting at position Y from the left or right end of the filename (excluding suffix). e.g . In the case of a file called DSC20081122_010.JPG, which is part of a series of .JPG photos taken at a party on 2008-11-22, we would be replacing 8 characters (matching the input string “20081122”) stating at position 4(LEFT) with the output string (“party”), resulting in a new filename of “DSCparty_010.jpg”. This input string, output string, left/right and start position sequence should be able to be applied to a folder, not just named files. Have a look at “THE Rename” to see how it should be done.

Other than that, Mrs. Lincoln, how was the play? :slight_smile:

Ewen :slight_smile:

File Pend Delete

  • Doesn’t work for locked folders

  • Impossible to drag files to the “Comodo Pend Delete” window. You have to browse for them, which is awkward.

  • When you click “Add”, a new window opens. When you then select a folder from the file list, a new “bar” opens at the bottom of the window, on top of the Select and Cancel buttons. You can’t get rid of that bar, except by closing and re-opening the window.

  • It would be great if this “delete locked files” item could be added to the send to menu, for easy and quick access.

Privacy Cleaner
it is impossible to exclude individual cookies from being deleted. For example, with Firefox the entire file cookies.sqlite will be deleted, including cookies you want to keep.

All cleaners:
impossible to overwrite files, they will just be deleted.

Having 4 different cleaners is not really convenient. Why not combine them in a single location?

  • There is a Privacy Cleaner with separate windows for applications, internet and Windows.
  • There is a disk cleaner that covers some other items.

Pend Delete
It is only possible to use it to delete files, while it can happen you just want to move a file that is locked. There should be an option to only unlock the file and not delete it.

File Wiper

  • Does not wipe things like file name, file size, date.
  • Does not update the listed files after wiping a file or folder.


AFter using Cleaner functions my Windows XP SP2 said I did not have disk defragmenter program installed. The option to disk defragment in Explorer/right click on hard disk was grayed out. (nevertheless Defrag.exe was still there in \windows\system32

Using CIS


Thanks for the post . This will be fixed in a future release.

  • Windows Vista 32bit
  • Comodo Internet Security;
  • Go to Update./ Update the software;
  • N/A;
  • Picture is attached;
  • N/A;
  • When you click the finish button, it seems to not be working.;

  • Vista SP1 x64
  • CIS
  • I started Disk Cleaner and noticed huge volume of temp files. Because scaning takes to much time, I decided to delete this files myself. Then I resumed scaning, but scaning continued from the same point when I did stop it, which is not possible, since I deleted entire folder.
  • N/A
  • N/A
  • N/A
  • N/A

GUI bug when you set the start menu transparency (Windows XP SP3 Royal/Media Centre Default Theme)
Can’t clean any files in Disk Cleaner

[attachment deleted by admin]

With Windows Vista I had similar problem but I didn’t see start menu at all only the user profile picture…
When I restarted my PC then start menu worked again.

Windows Vista 64bit SP2 beta


Hmm… I’ve restarted at least 3 times and still my start menu remains relatively invisible except for the right border and the user icon. Can someone help?

I had that too & nothing that I could think of at the time would fix it. Not even changing themes worked. In the end, I reverted to Restore point (which I’d created for that specific purpose). Although, I’m a little vague when it actually happened or what did it… probably because it was not immediately apparent. A possibly related component, the Visual Styler crashed, so I never got to use that.