Comodo wants to update after new update

Comodo informed me last week thru a balloon that there was an update. I download the update and went thru the update process. This week the balloon pops up and tells me there is another update. I downloaded the update again. Rebooted and it again tells me there is a update avaliable. Why am I getting update notices every time I reboot my machine?

I have Version, which I updated to yesterday. Today, I am prompted to update again to the same version. What’s up with this ? When I go manually to the update field, it says I need to update to the version I already have. Thanks, Freep.

Some people here also experience same problem.

EDIT: so far only Vista users with UAC turned on affected by this issue.

I decided to uninstall the latest Comodo firewall and go back to version At least I never found any bugs in it. The latest version asked me to get updates every time I rebooted my machine. It also messed with my internet by not recognizing my ethernet connection. In the latest version I turned off automatic check for updates but the ethernet was still a problem.

I have the same problem. Ever since yesterday it made me update every time I restart. I updated today and restarted and when windows booted up it showed a information box saying windows has recovered from a serious error. At the bottom it asks if you want to send the error report or not. I got three of those. Next I realized that cfp.exe wasn’t started and only cmdagent.exe was started. So I tried to go on the internet and surely enough, it didn’t work.

Next, I tried to start comodo. Nothing happened when I opened it and the process didn’t appear in the process list. Next, I looked at ipconfig /all. Usually, it would display my 3 NIC’s. Now it showed nothing at all:

So my nic drivers are completely ■■■■■■. So the next thing I do is try to uninstall comodo, figuring it would take their custom drivers off and restore my actuall nic drivers. NOPE. I open start menu → uninstall comodo, and it says image is valid, but for a machine type other than the current machine:

So the next thing I did was went to control panel and tried to uninstall from there. Nothing happened. It just removed the uninstall button from the add/remove programs window.

The last thing I tried was loading comodo firewall from my usb stick to reinstall it. FAIL AGAIN WTF. It asks me if I want to uninstall comdo instead of installing it. I press yes and then it just closes.

How can I take Comodo’s custom shit off so I can normally use my network cards again?

Here is my crash.dmp file. It wouldnt let me edit my post… I am also sure I don’t have a virus or anything because I haven’t used any vulerable programs or opened any exes besides commercial ones that are obviously trustable for the past couple weeks.

[attachment deleted by admin]

I have the same problem with I have “updated” five times now. Every time I reboot I am told that a new update is available.


add me to the list. i keep getting prompted to install the same update.

To all members please follow CFP BUGREPORT BOARD NOTICE or this topic will only match the ones in the feedback or help boards.

As there evidence that this issue affect mostly Vista platforms all xp users please post into the help topic to see if it will be possible to gather supplementary informations.

  1. Intel Core 2 Duo (64 bit processor running in 32 bit mode)
  2. Microsoft Windows Vista Ultimate 32 bit build 6001: Service Pack 1, .668
  3. Avira Anti-Vir, Comodo Firewall Pro ver, DVD43, Windows Sidebar, Gateway Camera Utility
  4. Um install on windows vista, and then reboot (notice update either install or ignore it doesn’t matter), and then repeat the process upon every reboot.
  5. I’ve tried uninstalling completely because the first time I installed comodo stole my permissions because my computer went into s3 sleep. So after a reinstall, and another update, uninstall, reinstall, update reboot update reboot update reboot I gave up.
  6. Both D+ and Firewall are in Train with safe mode, and i’ve only added custom blocked apps. Haven’t changed any other settings.
  7. “If you pc reboots or you have a BSOD post in BSODs: Please add your minidump files here”
    My pc hasn’t rebooted because of Comodo. UAC is on, and I’m not turning it off nor am I going to run things in Administrative mode. That is ridiculous considering that one version lower did not have this problem.

I have the same friggin problem!

Vista 32 home premium

I’v tried it all.clean uninstall,deleting every comodo mention in regedit etc etc

no matter what when i install the latest it pops up saying new update.also in about the version it says is installed is so i guess it isn’t updating at all.

it might be because i was testing it in the alpha etc maybe left some traces(guessing its the same with you) or what.but its actually been like this for a very long time i can’t seem to truly clean it off my system even with reg edit.

hope their is a solution soon

Any word on fixing this bug? It is very annoying to see the messages every day saying there are updates, and there really are not any.

OS: Vista 32bit

Still doing this for

I guess that more info are needed please run the scipt in the attached archive.

[attachment deleted by admin]

Has anybody tried to update from these bogus update notices? My system was trashed 4 times on 4 different versions with same problem. I get an unrepairable BSOD after reboot. I have to resort to a backup to reboot.

I am experiencing the same problem as other users are when updating comodo firewall, also when I try the diagnostic tab it says errors encountered and ask me if I want to fix them so I say yes ant thew whole thing starts again and again. ???

Add me to the list, BUT, this has been going on since i ‘converted’ from Kerio to Comodo FP at its first 3.x release, but only on Vista. The XP machines properly update, boot and show the new version number in the about box (which is where to check if it applied properly).

Now, I will try to install the whole thing again, but now from the administrator account rather than the user with temp.admin rights… that is maybe the cause?

Update: So switched to Administrator (hot swap) and low and behold, Comodo showed .320, so seemingly the update stuck, but some flag file is not being reset. The exiting in User account and reloading still shows .309 (the previous point releases from a full re-install to get to .309 also did not stick the updated version numbers in BUT, the software is truly updated none the less)… just the ‘reminder’.

I ran the script posted earlier:

User Xxx Member of {Administrators, }
Logged on machine XXX at 2008-03-26 22:32:19

Vista User Access Control Settings

EnableLUA 1
FilterAdministratorToken 0
EnableInstallerDetection 1
ValidateAdminCodeSignatures 0
EnableSecureUIAPaths 1
PromptOnSecureDesktop 1
EnableVirtualization 1
ConsentPromptBehaviorAdmin 2

Also, to comply with the bug submission rules:
* CPU (32 bit or 64 bit): 32
* Operating System information (including Service Pack Version): Vista SP1, but same with Vista
* Actively-running security and utility applications (Optional if you post a Comodo Firewall Pro Configuration Report): Avast 4.7 Home
* Specific symptoms of the bug, and steps you can take to reproduce it (step by step).: Every time you boot or wake up, it says there are new updates. You tell it to update, and it claims to update to the latest level, but when it checks again, it says there are updates.
* Specific steps you have taken to try to resolve it.: Cannot
* Brief description of your Defense+ and Firewall+ mode (Custom, Train with safe) plus mention if you modified any setting in ADVANCED section of D+ and F+ (Optional if you post a Comodo Firewall Pro Configuration Report): Defense+ is off…running simple firewall
* If you pc reboots or you have a BSOD post in BSODs: Please add your minidump files here: Does not
* Report if you are using an Administrator account Or a Limited User account. Vista users please Report if you have UAC Disabled or Enabled (Optional if you post a Comodo Firewall Pro Configuration Report): An admin account

abward thanks for the report.
we are continuing the discussion here:;msg145966#msg145966