Comodo updater steals focus [NBZ]

The bug/issue

  1. What you did:
    Not applicable

  2. What actually happened or you actually saw:
    Every time the background comodo updater is run it steals focus from the current active window.

It happens every time i watch a movie, the movie program (MPC-HC) gets windowed and reports that Comodo updaters is stealing focus, this also happens with other programs but it is most notable with my movie player.
Comodo Internet Security v5.3.181415.1237

Please fix it, shouldn’t take more then a few minutes to track down and fix this.

And it’s not just me that have this problem:

  1. What you expected to happen or see:
    comodo being a good citizen, a good boy playing nice with all other programs on the computer.
    Stealing focus is bad practice, annoying for the user and against microsoft’s guidelines.

  2. How you tried to fix it & what happened:
    Send me the source code and i will fix it and send you a patch.

  3. If its an application compatibility problem have you tried the application fixes?:
    Not applicable

  4. Details (exact version) of any application involved with download link:
    Not applicable

  5. Whether you can make the problem happen again, and if so exact steps to make it happen:
    Open a movie, play it in full-screen and wait for the background updater to start and the movie program will get windowed.

  6. Any other information (eg your guess regarding the cause, with reasons):
    Programmer didn’t read the windows docs carefully enough.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:
    Not applicable
  2. Screenshots of related event logs and the active processes list:
    Not applicable
  3. A CIS config report or file.
  4. Crash or freeze dump file:
    Not applicable

Your set-up

  1. CIS version, AV database version & configuration used:
    CIS 5.3.191415.1237 (NOTE: make this version string copyable in about box in next update, please!! )
    virus sig: last updated 3/29/2011 4:22:15 PM

  2. a) Have you updated (without uninstall) from CIS 3 or 4, if so b) have you tried reinstalling?:
    No, clean install

  3. a) Have you imported a config from a previous version of CIS, if so b) have U tried a preset config?:
    I have not imported anything, manually

  4. Other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here. )
    Disabled sandbox and antivirus due to malfunction, lack of settings and user control and plain annoyance.

  5. Defense+ and Sandbox OR Firewall security level:
    Defense+ : Safe Mode

  6. OS version, service pack, no of bits, UAC setting, & account type:
    Windows 7 Ultimate SP1 64-bit
    account type: Normal w7
    UAC: Normal w7

  7. Other security and utility software running:
    No other software (excluding my brain and paranoia )

  8. Virtual machine used (Please do NOT use Virtual box):
    Not applicable

[attachment deleted by admin]

Thank you for your issue report.

Moved to verified.

Thank you