Comodo update error message

I get an error message titled cpfupdat.exe-Application error.

The instruction at " " referenced memory at " ".Click on OK to terminate the program.Click on CANCEL to debug the program.

After I click OK another message appears.After I click OK nothing is terminated.You can see the images here

How can I stop these messages from appearing?Someone please help!!
(I’ll attach the images)

[attachment deleted by admin]

I have the same Problem/Bug.

On Xp/sp2 and version pro: I got the same error messages!!!

I think the problem is with the auto-update function of the comodo. I notice that when im not online (dialup) the auto-update just crashes… with those 2 messages. :’(

Why? I dont know :frowning: maybe couse there isnt an active net connection… ???
I hope some expert could help us on this.

Hi guys. I, too, am battling with this same issue. Funny thing is that it didn’t happen until I updated my installation… I was running, which I downloaded in November 2006 and only tried today. I activated it and then did an update and saw the error you’re talking about on the first restart.

It almost seems like the updater tries to check for an update, can’t find an active connection and then crashes, like you said. Question: is Internet Explorer (or whatever browser you use) set to use a LAN connection or do you have a default dial-up? I set mine to LAN so that I can control when the connection is triggered. It’s really annoying to have to cancel the prompt to connect twenty times an hour… I’m thinking that because my system is set to LAN, CPF assumes there is an active connection. ???

There is another thread regarding this (and other issues mixed in) at,1462.0.html. Unfortunately, no solution was found. The plaintiff said he’d try the current version some months later (his posts were in October 2006) but now, six months later, the current version still has a problem.

Moderators or gurus, any comments? There’s been nothing new on this topic for months… My current version is and I’m running Windows XP Pro SP2. Anti-virus (in case you want to know) is NOD32 and I have no other funnies running that check on things in real-time.

So far, I’m quite impressed with the interface and functionality. I hope it keep going well.

I can only think of the general advice of disabling other software during the CFP installation to avoid conflicts; a clean installation if you will.

If that doesn’t work then it’ll be better to contact the official support: and link them to this thread or other related ones for reference.


If you have v, I’d recommend going to the install package icon, right-click and select delete. Then Download version 2.4 straight from Comodo

Uninstall 2.3, and install 2.4. Too much of an upgrade to go thru updater, IMO.

As Soya points out, make sure you disable/turn off other active security applications (AV, HIPS, etc) while installing CFP, as they are very likely to cause an issue.