Comodo Unite Network Adapter

Can someone please explain how I remove ‘comodo unite adapter’ from my list in the device manager.
I uninstalled the software and tried to remove it from the device manager but it fails to do so.
any help would be appreciated.



Windows 7 Ultimate x64

no one…anyone ?.. :cry:

Hi Mike,
You could try removing it in Windows safe mode, or/and try the unofficial Uninstaller Tool for Comodo products.
This does work well with some partially failed uninstalls.
Good luck and sorry I not able to suggest more.

I downloaded the ‘Tool’ as you instructed but I’m not seeing an option for Comodo Unite on it
unless my eyes are worse than I thought…but I thank you for your suggestion ‘captain’.


Sorry is EasyVPN there? If so thats the one to try.

Thanks again…yes it was there but it didn’t offer any results after running it unfortunately…
I reinstalled comodo unite and then uninstalled using revo uninstaller and then the comodo uninstaller tool but still no joy I’m afraid…thanks anyways buddy…your help is much appreciated.

for now I’ve disabled it in the network adapters…it doesn’t seem to be causing any issues as such…I just wanted to be rid of it.

If I remember correctly you have to use Device Manager /View view hidden devices

It should I think it will be under plug and play not sure as awhile since I used it this way to remove the adapter please check elsewhere if not in that list.

Thanks Dennis…
The comodo unite adapter is clearly visible in the device manager but I can’t remove it no
matter what direction I take…it seems it’s there to stay…:slight_smile:

Sorry it really needs someone with it install to help you, there should be a way to remove it.


The only other thing I can suggest trying is in the Network and Sharing centre, change adapter settings, organize may give the option to uninstall, that failing sorry I was of no help.

Thanks to you both for your efforts…much appreciated.
if I do have any success I will report back here…it may prove useful to others.

Thanks Mike and good luck :).

Sorry I did not read your first post before I suggested Device Manger :-[

I will try a couple of things on VM next week if you still cannot remove it.

Good luck


Hello Mike;

The Comodo Unite Script is completely out-dated and not up to date.

Try These Steps

Warning; Doing the following steps may cripple Comodo Unite/EasyVPN Installation; This is intended to manually remove CU/CEVPN Driver(s)

(It’s best to do the following to do the steps in Safe Mode)

(Start > Right Click - Computer > Properties > Advance system Settings > System Protection -‘tab’ > Create > Follow steps to create a system restore point.

Must be logged in as Administrator.
Go To Add/Remove Programs and Uninstall Unite if Installed > Restart
Open Command Prompt (Start > Programs > Accesories > Right Click - Command Prompt > Run As Administrator)
Copy and Paste the Following Lines

REG DELETE “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\DIFx\DriverStore\cmdatp_ED5944871A490CC1944D650166634AD3E1BD6074” /F

REG DELETE “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\DIFxApp\Components{BFAD94FE-7B36-41FD-989F-877CD1E9EF29}” /F

REG DELETE “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Components\EF49DAFB63B7DF1489F978C71D9EFE92” /F




Close the Command Prompt

Please note; The following steps may require you to unhide folders, including system files please Open Folder Options in the Control Panel > Appearance and Personalization> Folder Options > View > “Show hidden files and folders and drives”> uncheck “Hide protected operating system files(Recommended)” > Apply > OK

Open Explorer and View “C:\Windows\System32\DriverStore(And The Subdirectory of ‘FileRepository’)” and Delete Any Folder/Files with ‘cmdatp’ in the title (Typically you’ll find the following files/Folders in the DriverStore Directory

Open Explorer and View C:\Program Files\Comodo and Delete the Folder “Unite”

Open Explorer and View C:\Windows\System32\drivers and delete “cmdatp.sys”


Check if Driver still exists and if Service “Comodo Unite MultiLogon Service” in Services.msc and Device Manager.

You may try to install Unite again if you wish.

Please report back soon :slight_smile:

Many thanks Jacob for the extensive instructions…
however after completing all of the steps it yielded no success…I did however then undertake to re-install Comodo Unite and it introduced a second Comodo Unite adapter into the device manager.

Once again I used Revo Uninstaller to remove Unite and it also removed the second Comodo Unite adapter from the device manager…the problem is however that the solitary problem entry is still with me so I’ve actually achieved nothing apart from realizing that Revo did actually remove the second adapter entry.

Again many thanks for taking the time to try and resolve this issue…I’m assuming that the problem is here
to stay but I’ve disabled it and upto now I’m not seeing any issues because of it…
I can’t figure though how it managed to survive since I’ve used Revo each time… :-\


Hi Mike,
Just another thought depending on how long ago of course, you haven’t got a system restore point prior to original Unite install by any chance?

Unfortunately not…:frowning:
I’m an Acronis True Image user and my backups will take me back several months.
makes you wish sometimes though you did use system restore also.

thanks again.