Comodo tries to update it's self and can't due to file not properly signed?

I keep getting this same error and over that’s there an updated version and when the file completes it’s download it errors out.
see picture below!!

Can Anyone tell me what this is? and Can it be fixed?

Thanks In Advance :slight_smile:


Dragon tries to update and cannot due to an “unsigned” down file, see below:

Can anyone help me with this? Do I have to some-how down this update manually
and install it??

Thanks in Advance… :slight_smile:

(:WAV) gems3125

1 step -
Download Comodo Program Manager

2 step -
open Comodo Program Manager , click Programs ( on the left side )
wait till all programs apear in the dox.

3 step - in the program list click on Comodo Dragon , click uninstal - complete uninstaling - click no for buck up wait a moment & a box apears where you will see all registry to clean , on the botom right corner click continue . CPM will clean everything.

4 step -
restart computer

5 step -
Having now Comodo Program Manager instaled on you PC , download Comodo Dragon again .

From now on Comodo Program Manager will have everything under control & will instaling any new updates from alone in the backgrund.


watch video [url][/url]


please dont not double post it is against the forum policy

i have merged your topics together.

I can confirm this behaviour also.
Any fix coming please ?

I’m having the same issue and I’m not installing Comodo Program Manager to update a browser. Looks like it’s back to regular Chromium if this doesn’t get resolved :-\


same problem here on Windows 8.1.

“Downloaded file is not properly signed”

I’m having this exact problem, after dragon started crashing upon opening I decided to reinstall, but now it wont update. It gives me the same error as the OP.

Currently I’m stuck with Version and COMODO programs manager doesn’t seem to have anything to do with updating Dragon :c

I have tried restarting my PC but the updates still aren’t signed :c

The exactly same thing just start happening to me today, I have no idea what to do, I made a backup of comodo dragon files, but after reinstalling, its stuck at version 49 and it doesn’t let me login into google