COMODO Time Machine 2.2.121064.147 RC BUG Reports

Tryed installing and was given the message about A RAID controller is detected (pic below).
Went ahead with install anyway as i know i dont have RAID set up. Things seemed to be going ok but on restart got the message “The discs total sectors is not consistent with the disc size. Setup cannot continue”
On presssing enter system booted CTM icon came up then vanished as did all trace of it ???

1.Windows 7 32bit
2.CIS 3.13
3. ^
4.Haven`t yet

3xHard drives, 1x500GB Hitachi Deskstar(connected via SATA cable, set in BIOS to IDE), 1x 80GB Maxtor, 1x40GB Maxtor(connected via IDE 1 master, 1 slave).
Windows 7 on the 500GB disc along with MBR, Page file etc. 80GB drive empty, 40GB drive contains Image.

[attachment deleted by admin]

  1. Your Operating System : vista HB 32b sp2
  2. Other Security and Utility Software Installed: CIS\CTM
    3.Start machine up.
  3. Made more diskspace availeble
  4. Upload Memory Dumps on crash if you encounter any: none
  5. Attach screenshots to your posts to clarify the issue further: yes
  6. Any other information you think that might be useful: no

All disks have enough GB except D: the HP recovery disk.

[attachment deleted by admin]

I cant install CTM RC

  1. Your Operating System : Windows 7 64bit
  2. Other Security and Utility Software Installed: CIS\CTM
  3. Install CTM
  4. Havent
  5. N/A
  6. Attached
  7. N/A

[attachment deleted by admin]

Long live Win 7 :wink:
Xman :smiley:
Sorry you’re experiencing problems all the same though, XP SP 3 lives on
Good luck dude :-TU
Xman 8)

I troed to uninstall CTM with Windows Vista 32 sp2 but it doesn’t. I tried it with Revo uninstaller but it doesn’t. How to uninstall CTM from my machine.

When I restore, I am getting “Windows Error Recovery” screen. After selecting “Start Windows Normally” Windows boots fine and everything works normally but this screen appears everytime when I restore my system.

OS: Windows 7 Ultimate Multiprocessor Free (2 procs) (x64) v6.01.7600.1, LangId 041f
OS build is known as ‘Windows 7 (x64)’
BuildLab: 7600.16385.amd64fre.win7_rtm.090713-1255

Hi Eljo.
Don’t try to uninstall CTM using the 3rd party uninstall application. You should uninstall CTM using its uninstallation in the start menu. If it doesn’t work correctly, you can reboot and enter sub-console, then uninstall CTM using uninstall button in sub-console.
After uninstall, CTM will clear itself.

Btw, please tell me your detail step of uninstalling. It will help us to reproduce the problem.


Are you taking snapshot with administrator account?

No. I am taking snapshot with custom account.

[attachment deleted by admin]

I mean the account that you use to logon Windows.

Yes, I am using administrator account.

I have an Acer laptop with Vista and only a 30GB C drive. By moving files to D and turning off system restore I managed to increase the free space to 12.2 GB, as with CTM installed the free space was reducing and down to 7 GB.

I then got the message to run disc clean repeatedly and the disc got very noisy. The free space was still 12.2 GB.

I successfully restored to baseline on uninstalling CTM.

Presumably I will be unable to ever use CTM on this computer?

Are you sure u log on Windows as built-in administrator? Actually, this account is disabled by default.

My account is a member of the local Administrators group.

I am using COMODO Time Machine 2.2.121064.147 RC.

I was copying many huge files to my HDD from my external HDD. Hours later when I come back, CTM took a snapshot with a snapshot name called something like “Low space” and the Windows explorer showed 100GB free out of 300GB. Strange. So i deleted some older snapshots. Strangely, Windows explorer again showed 100GB free. Restarted Windows. still 100GB free .

I think CTM does not show the HDD space status at CTM GUI. So I restarted widnows again many times and pressed HOME to enter just before Windows started to restore or delete snapshots, CTM kept restarting windows, failing to enter into windows environment. I decided to uninstall CTM and anchored at a snapshot (not the base snapshot) . Finally windows was able to start properly. or else I need to use Acronis True Image boot disc to boot. (will ATI boot disc really boot up ?)

After I have uninstalled CTM, my uninstaller did a scan and discovered that there are registries and more than 10 CTM files not removed when uninstalling. Fortunately, my uninstaller was able to find and delete them successfully to prevent slowness of my laptop.

I would like to suggest that CTM

  1. to show the status of HDD space used by CTM .
  2. should warn when HDD space is less than 20% free or left with 50GB free.
  3. Will ATI boot disc really boot up under the above scenario ? I would suggest CTM to have its own boot disc.

CTM shows your disk space information after you perform disk compact:

[attachment deleted by admin]

Yes, that is the problem. Pls try to run CTM as Administrator, then take snaphost.
In fact, Windows has a flag to show whether it is shutdown normally, and CTM need to set it when take a snapshot. However, if CTM do not have administrator privileges, then the flag can not be seted by CTM, so this problem occurs.

Pls try to run CTM as Administrator, then take snaphost.

I run CTM as admin manually, then take a snapshot and no more recovery screen. Thanks.

CTMTRAY.exe should request for elevation when needed in this case.

Bug or as intented?

Event driven scheduled task program name text input field max lenght is not enough for long file names.

[attachment deleted by admin]

Which one is right?

According to help file:

“Event - Takes a snapshot every time before the occurrence of a specific event like before running a setup program. This is helpful to roll back your system to previous state if the installed software malfunctions or contains viruses.”


“When running the program” (when? after?)