Comodo thinks wireless network is new

Another bug I’m having with this new version: occasionally at boot up, Comodo will think my home wireless network is new and will ask me to name it. If I use the same name, it says it already exists. If I cancel out of the dialog, the wireless doesn’t connect. I can “repair” it and it works again but this is very annoying. I am getting to the point where I will be looking for another FW. (:AGY)

What is your OS? What is your NIC? Are you using Windows WZC or Vista equivalent, or a utility for your NIC? Is your link encrypted? Does this happen when you use “resume”? Are there other visible routers with the same SSID or also on you automatic connection list?

OS is WinXP SP2 fully auto updated.
Not sure what you mean by “my NIC”. It’s a wireless router (Buffalo) on a DSL connection.
Using “WZC” (I had to google it) although I don’t think it’s called that in SP2. All other connection utilities uninstalled.
Wireless is encrypted using WPA-AES.
This occurs (so far) on boot only, not on resume. It is intermittent (has happened twice). Of course I don’t reboot all that often.
No other routers with the same SSID but of course there are a few auto connection networks (family, girlfriend etc.) Two were added during the holiday, but only once did the “new network” message come up.
Any info would be gratefully appreciated. Thanks.

I have had similar confusion happen occasionally on my XP machine without Comodo, so it may just be a function of the XP connection service. Your NIC is your Network Interface Card, usually a built in Intel or equivalent, or an add on card from one of the wireless router vendors. I am using Vista, but that is enough information now for someone to help you. Regards; Ed.

This is a Comodo dialog. I have always had Comodo on my laptop but it hasn’t happened prior to installation of v3.0x.

The NIC is the built in Intel, I forget the number but probably the most common one out there in laptops.

Sorry; missed that this was the Comodo dialog. You can go to miscellaneous/settings and uncheck the “automatically detect new private networks”.

OK. I assume this won’t disable any functionality when I do try to connect to a new one?

No, this just eliminates the popup. There seems to be confusion between XP and Comodo sometimes as to whether a connection is new or not.

I’ll try it. Thanks for your help.

Not to hijack my own thread, but any news on the cpfres.dll issue?

Queston out of left field:

Does your wireless network adaptor have a static IP or does it get one automatically from the wireless router?

If it gets one automatically, can you check if your zone is defined using a netmask or whether it’s defined using a range of IP addresses. My thinking is that if your zone was defined using a netmask and your IP was (for example), if you later acquired an IP of, your zone definition (using netmask) would be rendered invalid.

If this is the case, try changing the zone definition from netmask to IP range and include all required IPs (including your router) in the range.

Hope this helps,
Ewen :slight_smile:

I know it acquires it automatically, it is not static. I’ll check these settings when I get home and post back. Thanks.

Edit: I am too much of a network newbie to know how to change these settings. I have looked all over the “properties” of the wireless connection, the network adaptor and the router and I can’t see how to change any of them from “automatically obtain” or from “netmask” to “IP range.” Sorry to be so dense but if anyone can point me to the right dialog(s) I’d appreciate it. It’s WinXP SP2.

Bump for edit

Go to Firewall /Common Tasks /Network Zones /Click on your IP address under name /Click on edit / Then your IP Range.
Screenshots below.

[attachment deleted by admin]