Comodo System Utility Opens and says loading but nothing happens.

I see that the requirements does say for Win10 which is the OS I have and is a 64 bit MacbookPro/dual boot system. System Utilities runs fine on my old XP machine but on Win10 it opens and says loading. After 10 minutes it still is loading but never finishes. I am also using Comodo Program Manager and CCAV which both run fine on my pc.

Any ideas? I have also tried reinstalling and have tried running it with Administrative Priviledges but still have same issue.

I do not think it was actually updated for Windows 10, or Windows 8/8/1 for that matter.
This forum post is still valid;msg808615#msg808615

On the System Utilities web page, I don’t know how official the system requirements are when it says “Windowws 10”

Thank you. I was wondering the same thing but thought someone might know for sure. I have issues with Comodo Programs Manager as well where it runs but does not seem to monitor any installs. I think both issues are caused by both programs not brought up to speed with Win10. They are both really nice programs and wish that they both would work.

You are correct about Comodo Program Manager. It has not been updated in a few years, and has quietly been abandoned.

It is a shame that Comodo creates nice applications, only to move on to something else and forget about them.

CSU worked fine on my old laptop running windows 10 32-bit. When I upgraded to a new laptop running windows 10 64-bit, it will not run. It installs w/o complaint. It “runs” to the extent that it opens the main screen with a “please wait” and “loading” messages next to each component and just sits there. Forever. So it apparently not 64-bit compatible. It is a shame. I used to like it.