COMODO System Cleaner 2.0.108716.5 Public Release BUG REPORTS

Please post all bug reports & BSOD’s here.

Be sure to include:

  • Your Operating System (and whether it’s 32bit/64bit);
  • Security Software Installed;
  • How you produced the problem;
  • How you tried to resolve the problem;
  • Screen-shots with the error (if any);
  • Post Memory Dumps on crash if you encounter any;
  • All log files of CSC, if you had logs enabled;
  • Any other Additional Information;

When updating from 2.0.107697.4 to 2.0.108716.5 using the internal updater, the process wiped out all of by previous backups. The update process should prompt you whether you want to keep your previous backups. Also, when it updated the applications list, it wiped out my previous settings as well. Mentioned here.

I did have my previous backups backed up on disc, so I suffered no loss. I did have to go through setting up CDC and CPC again.

I would like to see “Restart Later” added to the Power Clean restart prompt. Access to the Power Clean Settings and the Power Clean Log file through the GUI (without having to run Power Clean) still need to be addressed.

Nice update. I do think it’s good to have the malicious entries removed from the main list in CRC. Maybe it could be added to the “Extended scan for expert users” under the settings tab.

Good job Guys! :-TU


I requested that also a while ago, but there were some problems with doing that they told me. I’m not sure if they’re capable of doing it now, but I still hope it


No problem! I can wait. They’ve come a long way in refining CSC! I have really fallen in love with Comodo products and I’ve only been using them for about 9 months. The progress they’ve made is outstanding! :smiley:

There are two detections for the portable and one for the installer at

Sunbelt displayed “” for the portable version, but viewing the link again omits this (and the dash).


Both the setup and the portable versions were tested before making them available for download.
I guess DrWeb found a FP entry. As you can see, other antiviruses didn’t found anything.

Windows 7 RC 64bit
Cannot start comodo system cleaner because siteareaconfiguration(?) has errors(?)
“Sidestillingskonfigurasjons feil” in norwegian.

CPC (latest version - 5) is not able to clear my recent files history of MS Office 2003 (Word, Excel or Powerpoint), though these are detected correctly when I scan the CPC. However, when I clean, CPC reports that these links (.lnk files) are cleaned, but it is still there in the recent file list of respective application.

P.S. Just to check whether this has anything to do with my computer configuratin, I tried to clear it with Revo Uninstaller and it was able to clear the recent list.

XP SP3 32 bit, CIS full, MBAM and SAS on demand

As pointed out by LAR Grizzley, removing the old backups while updating to .5 is a bit odd. At least CSC should ask whether we want to keep them or not, as being alerted by many programs while uninstalling. Fortunately I noticed Grizley’s post and kept the backup at another place before updating, so I was able to retain it.

CSC (.5) removes ‘user defined bookmarks’ of Firefox (3.5.2) even when ‘bookmarks’ or ‘backup bookmarks’ are not ticked under CPC. However, ‘default’ bookmarks of firefox (recently bookmarked or Mozila Firefox) are not removed. The ‘user defined bookmarks’ are removed even when it is placed under ‘Mozila Firefox’ folder in Bookmarks.

CPC is not able to remove Firefox history or cookies when firefox is open. That is okay, but CSC may give a notification in such cases (as being given by Ccleaner) to close Firefox if these are to be cleared.

XP SP3 32 bit. Security Applications - CIS Full (MBAM & SAS on demand free versions)

Reason for edit - second para added

  • Your Operating System (and whether it’s 32bit/64bit);
    Vista x64 Sp2
  • Security Software Installed;
    CIS latest version
  • How you produced the problem;
    Run latest csc
  • How you tried to resolve the problem;
  • Screen-shots with the error (if any);
    See below
  • Post Memory Dumps on crash if you encounter any;
  • All log files of CSC, if you had logs enabled;
  • Any other Additional Information;
    My csc will simply not run, tried fresh install, reboot etc still get the same error

[attachment deleted by admin]

Same bug as Fieseler.
OS : Win 7 x64
I produced the problem by running latest CSC.
I tried to reinstall using the version .5 only but nothing changed.
Currently i’m running the .4 version which is working.
Did same test as Fieseler and same result as him.


I found some strange Behaviour in System Cleaner.

When I click on System Information, it scans for my Computers Components which works mostly fine.

But each Time I switch a Component, for example Monitor to Audio, it seems that the Listbox ( or what Component is beeing used ) isn’t purged before new Data is being written into it.

So everytime, the List gets longer while the old items remain inside.

Tested it 3 times so it seems that this is indeed a minor cosmetic issue :wink:

I know that bug well because I often forget that while writing my own Applications :-[

Edit: Just noticed its in System Information under Software aswell, not just only Hardware
Also attached an Image to the Post, just hope it works^^

[attachment deleted by admin]


The problem was fixed, and the change can be seen in the next update.

Thank you

You said that in this version the installation bug will be fixed. But it still wants install to Program Files (x86) instead of Program Files. This bug is way too old. When you are gona fix it? :frowning:

Same here.

Hi mates

For starters my system specs:
Vista Home Premium SP2 64bit
CIS, standalone AVG linkscanner, Windows Defender (real-time)

I downloaded the portable version of your CSC for 64bit systems (ver. 2.0.108716.5), extracted it and tried to open csc.exe. Unfortunately I was greeted with the following message (which I had to translate): It is not possible to run the application because its simultaneous configuration is incorrect. More information is available in the application event log.

I went to mmc.exe and these are my findings:

Tab ‘General’

It is not possible to generate the activation context for D:\INSTALKI\CSC_SETUP_2.0.108716.5_xp_vista_server2003_win7_64bit\COMODO System-Cleaner\CSC.exe". Error in the manifest file or in the rule file “D:\INSTALKI\CSC_SETUP_2.0.108716.5_xp_vista_server2003_win7_64bit\COMODO System-Cleaner\Microsoft.VC90.MFC.MANIFEST” in line 11. The identity of the component found in the manifest is not the same as the identity of the requested component. Reference is Microsoft.VC90.MFC,processorArchitecture=“amd64”,publicKeyToken=“1fc8b3b9a1e18e3b”,type=“win32”,version=“9.0.21022.8”. Definition is Microsoft.VC90.MFC,processorArchitecture=“x86”,publicKeyToken=“1fc8b3b9a1e18e3b”,type=“win32”,version=“9.0.21022.8”. Use sxstrace.exe for a detailed diagnosis.

Tab ‘Details’


  • Provider

[ Name] SideBySide

  • EventID 35

[ Qualifiers] 49409

Level 2

Task 0

Keywords 0x80000000000000

  • TimeCreated

[ SystemTime] 2009-09-03T13:38:46.000Z

EventRecordID 6185

Channel Application

Computer DAMIAN-PC


  • EventData


D:\INSTALKI\CSC_SETUP_2.0.108716.5_xp_vista_server2003_win7_64bit\COMODO System-Cleaner\CSC.exe
D:\INSTALKI\CSC_SETUP_2.0.108716.5_xp_vista_server2003_win7_64bit\COMODO System-Cleaner\Microsoft.VC90.MFC.MANIFEST

Hope this helps!