COMODO System Cleaner 1.1.64942.34 BUG REPORTS [CLOSED]

Please post all bug reports & BSOD’s here.

Be sure to include:

  • Your Operating System (and whether it’s 32bit/64bit);
  • Security Software Installed;
  • How you produced the problem;
  • How you tried to resolve the problem;
  • Screen-shots with the error (if any);
  • Post Memory Dumps on crash if you encounter any;
  • All log files of CSC, if you had logs enabled;
  • Any other Additional Information;

Vista Ultimate x64 SP1
CIS 3.8
Install CSC

This is simple to explain - I downloaded the x64 version (not the portable). Then installed it.
The software installs to the Program Files (x86)/Comodo folder instead of the Program Files/Comodo folder.
If this is indeed the x64 version of this software, should it not install in the correct folder?


Yes, it is the x64 version(and this can easily be verified). This is more like an installer issue(our installer script for the moment refuses to put this into the correct program files folder). We’ll fix this in next release.

The problem i reported before still exists. Also, i want to remind, that my system was not modifyed with nLite.

Thank you, Andrei

I know comodo doesn’t support windows 7, but that doesn’t mean I can’t give a bug report. Whether it gets fix or not, I just letting you guys know :slight_smile:

  • Your Operating System (and whether it’s 32bit/64bit);
    Windows 7 version 7057 RC1

  • Security Software Installed;
    CIS w/o anti-virus, BoClean, Avira Premium, malwarebytes

  • How you produced the problem;

  1. For the portable version, everything installs just fine, but none of the icon are clickable.
    Example: You can click on “Analise my registry” and nothing will happen.

  2. For the regular version, (For registry cleaner) when the scanning
    “In-dept search” <------ it pop-ups an error during this stage process
    The error says “an error occurred during the registry scan process”

  • How you tried to resolve the problem;
    if you remove the check mark on “In-dept search” there will be no error

  • Screen-shots with the error (if any);
    Don’t know how

  • Post Memory Dumps on crash if you encounter any;

  • All log files of CSC, if you had logs enabled;

  • Any other Additional Information;
    For a program thats not supported, you guys are elite :comodorocks:

This latest version of CSC solved my problem with CDC’s Safe Delete function. This problem has existed on one of our 2 Vista Ultimate SP1 computers ever since Safe Delete was incorporated into CDC. This time when I ran CDC, the Safe Delete function brought up the Finalize or Restore window after reboot and when I clicked Finalize, instead of immediately rebooting the computer, the file deletion progress window opened like it is supposed to and showed the file deletion progress until completion. Thanks.

XP SP3 32bit with CIS, BoClean and Winpatrol. CCleaner running on startup.

In settings I selected to run CSC on system start to see what that did.

Soon after starting up yesterday, Winpatrol notified changed startup for CSC which I allowed.

I then had BSOD 0X00000008E (0XC000005, 0X8062DFB1, 0XA9AA2B08, 0X00000000)

Computer would not start in any mode reporting CONFIG\SYSTEM file damaged.

Being a Dell I had no XP disc to try a repair, so re-installed from the Dell partition and re-installing all programs and back-ups.

  • Your Operating System: Vista Ultimate SP1 32bit
  • Security Software Installed: CIS, BOClean, Spyware Blaster, Super AntiSpyware, Malwarebytes AntiMalware
  • How you produced the problem: ran the latest version of the Comodo Disk Cleaner
  • How you tried to resolve the problem: had to uninstall and reinstall Netgear software and MS Office 2007
  • Screen-shots with the error (if any): NA
  • Post Memory Dumps on crash if you encounter any: NA
  • All log files of CSC, if you had logs enabled: The CDC.log file is attached.
  • Any other Additional Information:
    (:AGY) (:AGY) (:AGY) (:AGY) (:AGY) (:AGY)
    Prior public release versions of CDC did not cause this problem. This problem only began with this latest release. Some folders are being cleaned by this current version of CDC that obviously were not cleaned in prior versions. In the CDC.log file listing files removed from C:\Windows\Prefetch I have noticed Netgear WN121T files that relate to the Netgear SmartWizard interface that no longer functions after running CDC. I believe that these are probably the missing files that require the Netgear software to be uninstalled and then reinstalled for the Netgear SmartWizard interface to function properly and for the computer to have Internet connectivity. Also on this computer, when clicking on the C:\ drive in Windows Explorer, the Windows Installer popped up stating that it was installing Microsoft Office XP Professional, but needed that installation disk to complete the installation. The CDC.log file for this computer is attached.
    (:AGY) (:AGY) (:AGY) (:AGY) (:AGY) (:AGY)
    Similar problems showed up on all our other computers. We have 2 Vista Ultimate SP1 32 bit desktops configured exactly alike, 1 Vista Business SP2 32 bit notebook, and 1 XP SP3 32 bit notebook. When trying to open an MS Office program on the two notebooks, the Windows Installer popped up up trying to install MS Office. The installation disk was required for this reinstallation on both notebooks. Office XP is on our old Sony notebook here at the house and Office 2007 is on my wife’s notebook that she takes to work with her. These Office programs had been working properly prior to running CDC.
    (:AGY) (:AGY) (:AGY) (:AGY) (:AGY) (:AGY)
    I updated CSC to the latest version and ran both CRC and CDC on my wife’s notebook Sunday afternoon before she left for work in a town 50 miles from our house. Yesterday evening when she attempted to open an Office program, the Windows Installer popped up and said that it was installing MS Office 2007 Professional, but needed the installation disk to complete the installation. So she couldn’t work on what she needed to and the MS Office installation couldn’t complete because naturally she didn’t have the installation disk with her. I had to drive over 100 miles there and back the next day with the MS Office 2007 installation disk so that she could use her Office programs the rest of the week for work-related tasks. Running both CRC and CDC had never caused a problem like this before, so I never even thought about checking Word or Excel to make sure they functioned properly before she left. Running CRC didn’t cause any problems. This problem was caused by CDC cleaning some necessary files that should not have been removed.
    (:AGY) (:AGY) (:AGY) (:AGY) (:AGY) (:AGY)
    I don’t care if Safe Delete is included in this program or not. The program itself should be safe to use. It is ludicrous to have to check every single program on the computer to make sure it still works properly before using Safe Delete to either Finalize or Restore the files cleaned by CDC. Everyday programs that are absolutely necessary to complete tasks such as using Windows Explorer, accessing the Internet, doing word processing and spreadsheets should NEVER be affected by CDC cleaning. That crosses the line where CDC is a safe, useful program to keep your computer clean of junk files to where it becomes an unsafe, unuseful program that is a time-wasting liability to the computer user.
    (:AGY) (:AGY) (:AGY) (:AGY) (:AGY) (:AGY)
    This post is accompanied by an army of angry faces only for effect and to let the developers know what a serious problem they have created with the release of this latest version of CSC. I am not personally angry, just irritated and disappointed to think they would release a version to the public that would do this out of the clear, blue sky. What is this, about the 5th public-release version of CSC and none of the prior versions caused this problem? That should NEVER happen! That is just a rush to correct bugs that ends up creating more bugs than it corrects and destroys trust in the CSC program itself. Comodo System Cleaner has taken one step forward and two steps back with this latest release.
    (:AGY) (:AGY) (:AGY) (:AGY) (:AGY) (:AGY)

[attachment deleted by admin]

I had a similar experience with OpenOffice Larlyles.

Using the power clean function completely killed it. Attempts to repair the installation were unsuccessful, as was even a full uninstall and clean reinstall of OpenOffice. I’m really not sure how CSC could cause a completely fresh installation not to function, but it did. After restoring the backup I had CSC make (thankfully) all is well…

I made a thread about it down below.

Not very happy that it does this, because as you say, it’s impossible to check every single program on your machine after doing a cleaning.

I have not had this problem with previous versions, but this was my first attempt at a ‘power clean’ (I had only previously used the registry and disk cleaners) and now I’m admittedly not very enthused about trying another ‘power clean’ as it appears a bit too powerful…

Hi HeffeD,
I had read about your OpenOffice problem in your post on the other thread. I have never done a privacy cleaning either, because I had previously read on the forums about some of the problems people have had after privacy cleaning. Also, privacy cleaning isn’t something that I really have any need for. But I have always been able to successfully use CRC and CDC without any major problems. I did have an issue with CDC’s Safe Delete function on one Vista Ultimate computer, but this latest version of CSC actually took care of that. This was not a major issue anyway, because I have always been able to clean junk files using CDC without any problems.

I can’t remember ever having a computer problem of any kind after using CDC, until now. I would expect registry cleaning to cause a problem every now and then, but I would never expect disk cleaning to create problems like it has. I will not use CDC disk cleaning again until the next version of CSC is released. I will then test it very carefully to make sure that it doesn’t break any programs. This latest version of CDC did such a thorough cleaning job that it even erased the trust that I had previously placed in it.

I really don’t have a need for privacy cleaning either, but thought I’d give the power clean feature a try. Not very impressed at the moment…

  • OS: Windows XP SP3 32-bit
  • Security: Kaspersky IS 2009
  • How you produced the problem: Downloaded and ran a new and “improved” updated version of the Comodo System Cleaner
  • How you tried to resolve the problem: Finally had to do clean reinstall of Windows XP SP3 to get things back to normal–not fun
  • Screen-shots with the error (if any): None
  • Post Memory Dumps on crash if you encounter any: None
  • All log files of CSC, if you had logs enabled: None
  • Any other Additional Information: Windows would not load after first run of CSC except in Safe Mode, and Windows/Office Update no longer worked after I finally got system to reboot, and several other additional aggravations

Couldn’t agree more!!! CSC came to me very highly recommended! I first began using CSC about four or five versions ago and LOVED it. Then out of the blue my computer crashed–fixed that (finally)–then Windows Update quit working–fixed that (finally). Did not reinstall Comodo System Cleaner. Guess what? My machine now works like a dream. When I come back here and no one is complaining, I MIGHT give it another chance.