Comodo STILL not addressing Facebook video problems?

Worked again for a day on Dragon 13th July! Now back to the same “video unavailable” messages when I try to play embedded clips.
This is now happening of twitter as well…no message on twitter - the clips just won’t load.

The other thread about embedded videos on here appears to have been deleted? You don’t have any solutions? Not good enough, Comodo >:(
I love Dragon browser but I can’t fully use the two sites I use the most on here?

Get it sorted please!

Hi Billy Leeds,
Have you considered reporting these issues to Twitter and FB?

BTW: No topics or posts regarding embedded videos have been deleted as far as I can tell.
Is this what you are looking for?


Your posts can be found in merged topic Videos stopped playing on facebook [Merged].

What version of Dragon are you using?

Hi - using Dragon version Vids suddenly started working on facebook again :-TU but just won’t open in twitter…

Very odd, this whole problem, reading through the other thread.

Have you tried with Twitter and FB, as the problem may be on their end. Don’t always assume Comodo is at fault.

With websites I always take into consideration things could be on their end. They are more likely to change than browsers.