Comodo Security Agent could not be started. [Merged topics]

Hoping, but, Not sure if I cam posting this message in the correct area, ADMIN, please move it to the correct location for me. Thank you very much.

Every time my computer is rebooted, a window appears after the reboot that states the following:
COMODO security agent could not be started. Would I like to run the diagnostic tool to fix this problem?
I always choose yes.
However, the diagnostic tool has never found the problem (s) or any problems to be fixed. this i find odd.
Plus, This has been going on for months now!

So why is this happening???

Is my computer at risk and is my comodo protection compromised if the security agent is not started?

I am using windows XP Pro V 2002 with service pack 3 with graphics by ATI radeon 200 express and pentium 4 CPU 3.0 Ghz

I have the same problem, after restarting my PC I can not use comodo “local” antivirus. The cloud-based is working good though.
I am using windows 7.

2 PC with Windows XP sp3 - Comodo Firewall doesn’t open. One message : Comodo security Agent could not be started. Internet access is broken.

I have had this since starting with Comodo 8 a year or so ago, and it is still going on with CIS 10. Windows 7 SP1 x64. After any start/re-start, the message about the agent could not be started; the enquiry as to whether I want the diagnostic tool to run; the tool always saying it hasn’t found anything wrong; oh and the Windows Action Center flagging two issues- that I have no firewall or antivirus running.

Two things:

1 If I then click on the desktop shortcut to start CIS, it then starts and runs fine.

2 If, when the computer is starting, i leave it at the logon screen for two or three minutes before logging on, then the problem doesn’t appear and the desktop appears with CIS running, the widget opem, no error messages from Comodo or the Windows Action Center.

Came here looking for help/solutions, never found any. I presume something about the timing of the laptop startup sequence and loading of the desktop conflicts with the Comodo startup … Comodo maybe needs to delay its startup a little on my system to start properly. Haven’t found a CIS configuration setting to do that, unlike another security suite i used to use. So I just eaither logon straight away and manually start CIS, or I leave the logon screen for a couple of minutes, then logon so CIS does complete its startup itself.

Annoying. (Though not as annoying as the new problems I’m having with CIS 10. Seriously thinking of trying some of the alternatives.)

Good observation. It is usually caused by very slow startup.
Another idea would be to reset registry permissions to default.
It can also be caused by incorrect hardware detection or incompatibility. Kind of.

hahaha my english is so bad…

This problem (“Comodo security Agent could not be started…” when the computer boots. Not possible to stard Comodo services as Comodo Virtual service Manager. Access to internet is impossible except if Comodo is uninstalled) seems so old :-\ (with version 8, and actually with version 10).

My observation : There is one problem with the key and subkeys HKEY_LOCAL_MACHINE\SYSTEM\ControlSetXXX\Services\CmdAgent (replace XXX by 001 or 002… In my case, it’s 009). After Comodo uninstall, it is not possible to delete this key in Windows registry. I tried regedit, regedit32, PsExec (you find this one into Microsoft PSTools), Malwarebytes Regassassin, change key permissions, reset registry permissions to default (using SubInAC), etc…

Comodo version 6 don’t use this key. So no problem if I install this one.

Does anyone have any suggestions?

So is there an actual way within CIS to tell it to delay trying to start for a little bit until other services etc are running? A product i used to use had that as a configuration setting for just this problem.

Another idea would be to reset registry permissions to default.

Which registry permissions? I’m certainly not setting the whole registry back to its factory defaults from 2011!

Only permissions (security permissions). Your registry does not back to its factory defaults. Excuse me my excellent english ;D

Responded in a similar topic.

After ~10 years with CIS I ran into this issue, too. :frowning:
If the cistray.exe does not run, it is not affect the security (think I), only the ability to manage the CIS. The main is the cis.exe, it can not start on my machine (win8x64hun). There is a registry entry
char string “COMODO Internet Security”, value is “C:\Program Files\COMODO\COMODO Internet Security\cistray.exe”,
so I did a new one:
char string “CIS main”, value is “C:\Program Files\COMODO\COMODO Internet Security\cis.exe”.

It seems to work for me. When my machine starts, cis.exe starts, too. Little later I start cistray.exe manually, with a shortcut.

Of course, it is not very nice. 21st century… Yes… Back to the ox cart… But what to do? Comodo seems not to like us, poor users…

Hello, guys. Comodo downloaded an update yesterday, and CIS stopped work after it. I’ve got an error with ‘comodo agent could not be started’. It’s my first time when I face this error, so I don’t know what to do. CisReport is here. If someone can help me or link guides/FAQ, I’d be happy. Thank you.


I’ve been using Comodo Firewall (not sure about v.10, i think i upgraded it to it when it did come out) for years without problems, but when version. came out, for some reason everytime i start/reboot my comp; popup comes up and says “Comodo Security Agent Could Not Be Started” , same problem that others have here.
Problem occured to me when CF started to update itself and it hang itself to (sorry cant remember just right) "starting cmdinstall.exe((or .dll cant remember))
When it just stayd there about an hour i clicked STOP button and thought that i have to reboot my comp, after rebooting it presented to me that cmdagent problem.

I’ve tried multiple suggestions from forums like
Plus other suggestions which i found on the forums.

I’ve reinstalled CF couple of times;

  • uninstall, reboot, install
    -uninstall, reboot to Safe Mode, using registery cleaner (CCleaner) to get rid of some of registery keys and by manually with REGEDIT, rebooting to normal mode, installing
    -Uninstalling in Safe Mode
    -Used restorepoint to before installing version. (when it worked); Bad idea->black screen (undid restorepoint so now it’s fine again)

I CAN open COMODO Firewall by clicking CF shortcut to open it and it does run in my system (cis.exe and cisTray.exe are on my Windows task manager) i can do all the stuff which i was able to do before and it seems to work, BUT:
- cmdAgent.exe AND cavwp.exe doesnt show up in WTM (task manager) even if i try to open them manually so i want to also know
do i need them?
I mean, does CF still work fine without them or does it now miss some parts?

Tried also to run Comodo’s own diagnostic tool and it did not found anything after every reinstalling attempt except this last part, i attach that .zip file which it generated.
I won’t do anything before i get more info about this, so i won’t mess it up more.

I might add also that my other computer had that same updating problem But;
-when it hang on that “starting cmdinstall.exe” thingy, i just pressed pause, pause again and then STOP, it closed updating window and just… worked? It also has now updated version from CF (tried updating it and it says it’s up to date (Product version atm says
It also doens’t have that cmdagent problem after rebooting.

just after upgrading to CIS 10, after a reboot I become this warning:
I have to run CIS manually to get it in the systray.
Is this a know issue?
Here the report:

The same behaviour after update on XP Professional SP3 :frowning:

Yes. It’s a known issue.

Hi Gongila.

This bug is already recorded and we will fix it soon.
Thank you for feedback.

Kind Regards,

Hi InfMagma,

It’s a known bug. Thank you for your feedback.
Fix will be done soon.

Kind Regards,

Hi NotRandomName,

This bug is already recorded. Thanks for your feedback.
Fix will be done.

Kind Regards,

Hi friends,
thanks for your reply, I am happy that the issue is known.
At the moment I simply doubleclick on CIS icon after the boot and ok.

PS: desktop ok, but on my laptop after upgrading to CIS10 the Windows Aero theme disappeared, and it is not available in the menu (only basic and classic), there is a way to restore Aero?

Had the exact same thing happen after upgrading today. Glad to see it’s being worked on. :-TU