Comodo Repeatedly Crashing [Issue Report]

I was recommended to post this as a bug report by EricJH here.

In short, Comodo keeps crashing on me. This has happened three times in the last three days or so. The first time Comodo crashed, I was simply reading a product page on using Chrome. The next day it crashed again immediately after taking my PC out of standby. The firewall was functional just before putting my PC to sleep, and 20-30 mins later I logged back on to find the “Ooops you have found a bug in Comodo Internet Security” window. I did NOT send a bug report either time.

About 30 minutes ago Comodo crashed again while I was in the middle of installing Microsoft Network Monitor. cfp.exe had been terminated/crashed, but cmdagent.exe was still running. This time I DID send a crash report. This is regarding the last crash, but the three crashed may be related.

The bug/issue

  1. What you did: Installed Microsoft Network Monitor.

  2. What actually happened or you actually saw: Comodo crashed about halfway through the installation. The “Ooops you have found a bug in Comodo Internet Security” window popped up.

  3. What you expected to happen or see: Comodo should not have crashed.

  4. How you tried to fix it & what happened: N/A

  5. If its an application compatibility problem have you tried the application fixes here?: N/A

  6. Details & exact version of any application (execpt CIS) involved with download link: N/A

  7. Whether you can make the problem happen again, and if so exact steps to make it happen: The problem seems to happen randomly (see above paragraphs).

  8. Any other information (eg your guess regarding the cause, with reasons):

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
  3. A CIS config report or file.
  4. Crash or freeze dump file: Attached.
  5. Screenshot of More~About page. Can be used instead of typed product and AV database version.

Your set-up

  1. CIS version, AV database version & configuration used: See above.

  2. a) Have you updated (without uninstall) from CIS 3 or 4: No.

    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:

  3. a) Have you imported a config from a previous version of CIS: No

    b) if so, have U tried a standard config (without losing settings - if not please do)?:

  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):

Firewall: safe mode, ipv6 filtering checked, all options under “Advanced” checked
Defense+: maximum proactive defense, safe mode, unrecognized files = untrusted

  1. Defense+, Sandbox, Firewall & AV security levels: D+= , Sandbox= , Firewall = , AV =

D+ = safe mode
Sandbox = Enabled
Firewall = safe mode
AV = Not installed

  1. OS version, service pack, number of bits, UAC setting, & account type:

Windows 7 SP1, 32-bit, UAC enabled, Administrator

  1. Other security and utility software installed:

Avast Internet Security 6, firewall uninstalled
Malwarebytes PRO 1.51
Panda USB Vaccine

  1. Virtual machine used (Please do NOT use Virtual box): None

[attachment deleted by admin]

Thank you for your Issue report.

Moved to verified.

Thank you


You’re welcome, thanks for having a look at it! Comodo is the best firewall out there and I recommend it to my friends and family when I fix their PCs. I’m glad to help in any way possible. :slight_smile:

I’d just like to add that after this last crash, the Comodo installation seems to have become corrupted. I restarted my PC and logged on, and at the point where Comodo would normally load up, the startup process seemed to halt and my entire PC locked up. I had to restart in safe mode to get to my desktop, after which I tried running Comodo diagnostics. The diagnostics found errors with the install, but it said something along the lines of “some errors could not be repaired, would you like to save a report?”

I’ve attached the repair report to this post, and hopefully this will help track down the bug! I ended up having to disable the Comodo startup item and service to get back to my desktop and completely uninstall CIS. I’ve done a clean install but I have no idea if the same problem is going to occur again.


[attachment deleted by admin]