Comodo Programs Manager 1.2 build 90 BETA 3 BUG REPORTS

Please post all bug reports & BSOD’s here.

Be sure to include:

  • Your Operating System (and whether it’s 32bit/64bit);
  • Security Software Installed;
  • How you produced the problem;
  • How you tried to resolve the problem;
  • Screen-shots with the error (if any);
  • Post Memory Dumps on crash if you encounter any;
  • All log files of CPM, if you had logs enabled;
  • Any other Additional Information;

- Your Operating System (and whether it’s 32bit/64bit);
Win7 x86

- Security Software Installed;
CIS 5.3, NOD32 v4

- How you produced the problem;
I’m using Opera 11.10 alpha Build 2039.
Installed several Widgets from and tried to uninstall some of them.
CPM wants to uninstall the complete Opera installation including all other widgets

  • How you tried to resolve the problem;[/b]
    Used the usual way to uninstall them.

- Screen-shots with the error (if any);

  • Your Operating System (and whether it’s 32bit/64bit)
    Windows 7 64-bit

  • Security Software Installed;
    Comodo Internet Security Suite, Comodo Time Machine, Comodo Program Manager

  • How you produced the problem;
    Just exited a program. It comes and goes and happens with numerous apps.

  • How you tried to resolve the problem;
    Not much

  • Screen-shots with the error (if any);

  • Post Memory Dumps on crash if you encounter any;

  • All log files of CPM, if you had logs enabled;

  • Any other Additional Information;
    Message pops up on the screen several times a day. Usually after exiting a program. This machine was built fresh this week and the Comodo apps were the first ones installed after the OS. One updated piece of information. The error is now happening several times a day when I am not even home. Nothing in the even log gives me any clue as to what could be causing it.

Above the message are the letters “MFC” each in a solid colored box. An orange box with the letter “M” rest on a green box with the letter “F” in it and a blue box with a “C” to form a small pyramid.

The primary message is :
TODO: has stopped working.

Faulting application name: CPMPopulateDBTool.exe, version:, time stamp: 0x4d47b431
Faulting module name: ntdll.dll, version: 6.1.7600.16695, time stamp: 0x4cc7b325
Exception code: 0xc0000005
Fault offset: 0x00000000000515b0
Faulting process id: 0x15f4
Faulting application start time: 0x01cbe5ddd98fca2c
Faulting application path: C:\Program Files\COMODO\COMODO Programs Manager\CPMPopulateDBTool.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report Id: 18a3c4ac-51d1-11e0-b501-00221582ec52

Any ideas what it might be?


Can you make a dump file of the CPMPopulateDBTool.exe process exactly when it crashes?
I will send a PM with the information where you can upload the file.
Thank you.

I’ve got another problem. I’ve seen it referenced in previous versions but have not seen a solution anywhere.

I’m unable to run the application now. Every time I start the program, it generates this error within a second or two of starting.

Comodo Program Manager has stopped working.
Problem signature:
Problem Event Name: APPCRASH
Application Name: CPM.exe
Application Version: 1.2.34328.90
Application Timestamp: 4d7743e2
Fault Module Name: Applications_DLL.DLL
Fault Module Version:
Fault Module Timestamp: 4d6ca20c
Exception Code: c0000005
Exception Offset: 000000000000e510
OS Version: 6.1.7600.
Locale ID: 1033
Additional Information 1: 7f2d
Additional Information 2: 7f2d9690fd46e1ff52228aa915782a6d
Additional Information 3: eca2
Additional Information 4: eca2147b6c4a5be15537bac912548c1f

Read our privacy statement online:
Windows 7 Privacy Statement

If the online privacy statement is not available, please read our privacy statement offline:

All of the system details are the same as with the other problem I posted. You can find the dump file at - free file sharing and storage


On another note here. This version did not appear to fix the problem with te “TODO:” error message. Checking the logs, it does not appear that CPMPopulateDBTool is running in the version you sent me. I’m not sure if this is by design or not, but figured I should mention it.

Just checking in to see if you have any answers to my previous post? I would really like to be able to get into the program. I’m in the process of rebuilding my machine and I still have about 40 apps to install. I would feel a lot more comfortable about it if CPM could actually be used on the PC.


The test build provided only includes the fix for Applications_DLL.DLL crash. The ‘CPMPopulateDBTool.exe’ crash is also fixed and will be included in the next release.

You can keep CPM 1.2 build 90 installed and use the test build provided for normal operations until the next version will be released. The test build should be deployed to a different directory from the one used for the CPM 1.2 build 90.
The ‘CPMPopulateDBTool.exe’ crash can be avoided by deselecting the ‘Take part in our Contribute Program’ option from the CPM 1.2 build 90.
Thank you.

Some Monitored Applications when updated, leave behind a “Partially Uninstalled” listing for the OLD version in CPM. CPM lists both the old version (partially uninstalled) and the updated version (Monitored).

When I uninstall the older version (Partially Uninstalled) using CPM, the entire application is removed - including the newer version which I wanted to keep! This appears to be a bug.

CPM 1.2 Build 90
Windows 7 (64 bit) SP1

I installed Amazon MP3-Downloader 1.0.9 to download some songs.
Afterwards I wanted to completely uninstall it and CPM wanted to delete the newly downloaded MP3s.

Here’s a free download to reproduce this:

I’m using Win7 x86

Yes this is a bug, the applications are seen as two different ones although they are related.
Can you please post the application name? We will try to fix the issue in a future release.
Thank you.

We will fix the issue in a future release.
Thank you.

I experience the same with Evernote.
Since updating I have a partially uninstalled Evernote v4.2.1 listed and a installed v4.2.2.
Another one I’ve just found:
partially uninstalled: Opera 11.10 beta build 2048
installed: Opera 11.10 beta build 2077

Here is one recent example: VLC Media Player (VideoLAN). I had version 1.1.7 “Partially Uninstalled”, and the update version 1.1.8 “Monitored”. Uninstalling 1.1.7 using CPM 1.2 build 90 removed all versions of VLC from my system.

And here is an even more serious problem:

Using CPM, I uninstalled a Monitored program - Counterpath X-Lite 4, which is a SIP soft-phone application. After the uninstallation and a re-boot, I discovered that 3 other unrelated applications had also been removed: Skype, Voxox (another SIP soft-phone), and Faststone Image Viewer!

There are errors in the list of files and Registry keys being removed when I uninstall Monitored programs using CPM build 90. Sorry, but I can’t continue using an app that deletes the wrong registry keys.

CPM is conceptually a very valuable tool. However, I will wait for the release that fixes these bugs. Thanks!

Please provide us more information about the issue.
Were the applications part from the same package or did the monitored application Counterpath X-Lite 4 showed as dependent on the other applications in the uninstall process?
Did the standard uninstaller of the other applications launch?
We will try to reproduce and fix the issue based on the provided information.
Thank you for your support.


Let me expand my original explanation - hopefully it will help you troubleshoot and identify the root cause of the problem.

(1) All 4 applications (X-Lite 4, Skype, voxox, and Faststone were installed after I installed CPM … and all were “monitored” by CPM.

(2) When I uninstalled X-Lite 4 using CPM, there was no warning message indicating dependencies with any other installed programs. I have seen this warning before, but not in this instance.

(3) CPM triggered the X-Lite 4 uninstaller ONLY - none of the other 3 uninstallers were launched.

(4) After X-Lite 4 was removed, CPM offered me a long listing of Files and Registry Keys that were left behind and could be removed. This is where I noticed Files and Registry Keys that didn’t belong to X-lite 4.

(5) I accepted the default offered lists without any manual editing (Files and Reg. keys). CPM suggested a reboot.

(6) During the reboot, a CPM screen opened notifying me of “Forced removals”. After the reboot, X-lite AND the other 3 applications had been removed from my system.


Did the other three applications appear as partially uninstalled after the uninstall? If they were completely uninstalled, they should have appeared as dependent on the X-Lite 4 application.
Anyhow there must be a relation between this apps because the entries can’t mix up without a common point. Please tell me how they were first installed. Were the apps updated during their lifetime?
Thank you.

These are excellent questions - and quite honestly, I do not remember all the details you are looking for. Let me try:

The 3 removed applications did NOT appear as dependent on X-Lite when I removed X-Lite. I am 100% certain of this. However, I do not know if they appeared as “partially uninstalled” afterward … as I removed CPM without checking this detail.

I believe that all 3 applications (Skype, voxox, and Faststone were installed on my system using CPM …and I don’t think that any of them were ever updated.

Your comment about “common point” is interesting. All 4 applications are from different vendors … however 3 of the 4 (X-Lite, Skype, and voxox are VOIP / Telephony apps … maybe they shared come common system-wide drivers? The 4th app. (Faststone) is a photo viewer / editor … so I don’t see any linkage there.

As I mentioned earlier … when I removed X-Lite using CPM - CPM clearly identified files and Reg. Keys belonging to the other apps. that would be removed. I do not know why.

Sorry if this doesn’t answer your questions completely.
Thank you.

I have other questions that might solve the issue.
How were the setups obtained? Were they downloaded with a browser or they were transferred via another monitored application? Do you have third-party applications with which you copy/move files?
Thank you.