COMODO Programs Manager 1.2 build 106 Public Release BUG REPORTS

Please post all bug reports & BSOD’s here.

Be sure to include:

  • Your Operating System (and whether it’s 32bit/64bit);
  • Security Software Installed;
  • How you produced the problem;
  • How you tried to resolve the problem;
  • Screen-shots with the error (if any);
  • Post Memory Dumps on crash if you encounter any;
  • All log files of CPM, if you had logs enabled;
  • Any other Additional Information;

Windows 7 Premium 32 bits
CIS 5, and EMEt. On demand malwarebytes, SAS, Hitman pro.

I installed CPM 1.2.188360.106. After that i realized that i had several programs monitored (not DT monitored), which did not make any sense, since i did not update CPM, it was a clean install.
My idea was that something remained from the first time i had CPM in my computer, about 6 moths ago. I uninstalled it because it was unstable. If i am not mistaken it was CPM 1.0 build 30.

Some monitored programs were “partial uninstalled”, so i decided to uninstalled them.
I tried 3 programs and before the confirmation, i saw that the files that were going to be removed were from the main program. I decided to proceed anyway because i had maid a backup image. After that my programs were removed.

The programs were:

VLC 1.1.7 (partial uninstall). It removed VLC 1.1.9.
Opera 11.01 (partial uninstall) . It removed opera 11.10
Freemake Video Downloader 2.1.0 i think (partiall unistalled). It removed Freemake Video Downloader 2.14.

The only programs that uninstalled correctly were Firefox 3.6 (partial uninstalled), i have FF 4.01 and revo unistaller 1.91 (partial uninstalled), i have 1.92.

I have an extra information. My original programs were installed from this application, but freemake video downloader was not.

Why did this happen? Was it because of the original application (CPM buid 30), or because of ninite, or other reason?

I am going to restore my backup, but is it safe to uninstall programs that i already removed in the past with revo but still appear in the “partial unistalled” of CPM in “Monitored”?


Whenever I’ve seen the partially uninstalled status it has been due to updating an application. The previous version is listed as partially uninstalled. I wish it wouldn’t do that.

The internal storage file remained from the previous CPM installation so all the applications mentioned were monitored with CPM build 30. Meanwhile the applications were updated or installed without having CPM installed, so the new apps weren’t monitored. When you later installed CPM build 106 the only applications detected as monitored were the old ones, without “knowing” of the new versions installed.
I think this is the case so it was basically an issue with the CPM build 30.

As long as the “partially uninstalled” or “monitored” application status remains after a CPM update and not after a CPM uninstall and the “partially uninstalled” status is not due of an application update, the app is safe to uninstall.

Thank you.

Thanks for the answer Alexandru Andrei

Just installed latest version of CPM (upgrade from 1.0), for which thank you. It’s a great bit of free software. The best uninstaller I’ve ever used (previously zsoft & revo).

However I have a query.

The executable CPMpopulateDBTool is constantly running, and much of the time (over about a week now) using [Edit] 30-40% CPU. Seems to make a svchost instance consume a lot too sometimes, [Edit] taking the total to near 90%, but less sure about that. Happily the usage is pretty well managed - seems to reduce CPU sharply when I do something else, so its not getting in the way too much.

I think I know what this tool is doing - analyzing apps monitored on my PC and transferring the installation details to the central database server so others can do database uninstalls of these apps. Is that correct?

I’m very happy to make my contribution in this way and its probably fair to say I have a lot of monitored apps, but I just wanted to ask whether it should be working so hard for so long? Will it eventually terminate, and if so in how many days?

Best wishes



  • Your Operating System (and whether it’s 32bit/64bit); XP32 Sp3. 3Ghz processor, 3GB RAM, 5GB disk space free
  • Security Software Installed; CIS 5.4.x
  • How you produced the problem; CPMpopulatedatabase tool ran automatically after installation of CPM version 1.2
  • How you tried to resolve the problem; N/A
  • Screen-shots with the error (if any); N/A
  • Post Memory Dumps on crash if you encounter any; N/A
  • All log files of CPM, if you had logs enabled; see post below
  • Any other Additional Information; See above

The process is a low priority one and should consume few resources when the computer is in use.
The process does exactly what its name says meaning it is populating a central database with the monitored apps but it shouldn’t take that much time. In order to identify the issue please try to populate the apps manually. Please follow these steps:

  • Restart the computer so that the CPMPopulateDBTool process will not be active in memory.
  • Copy the attached bat file in the CPM installation directory.
  • Run the bat file and populate the DB by pressing ‘Populate DB’ button; upon every application sent to the DB press ‘Continue’ button to proceed with the next one;if the upload is stuck at a certain app for more then twenty minutes you can cancel the operation.
  • CPMLogs directory should be created on the Desktop after this; Please zip it and post it for analyzes.

Thank you for your support.

[attachment deleted by admin]

Thanks Alexandru

Will also move this to bugs.

Have done as you requested.

Overall 32 monitored apps to be added to DB at start of process

  1. most were not added. Most common cited errors were a) error retrieving app version information and b) missing critical information (usually id or directory)
  2. In 3 cases high CPU was exhibited for an extended period. In two of these no info from which the program could be identified was retrieved. The third was MS SQL Server 2005 (v9. many zeros 5) which caused Hi CPU for 2 hours, before completing successfully.
  3. Process completed without need to cancel out of anything, though there was no feedback on ‘device 32/32’, suggesting the last installation had not been processed?

Will append “Hijack this” report to give system details and zipped directory contents.

Best wishes


[attachment deleted by admin]

Just to update you.

Despite the fact that the batch tool process completed without the need to cancel out, the automatic process has now started running again and is consuming high CPU. I guess its continually trying to database the applications that it failed to database in the completed run.

It’s also running at priority 8 - ie normal priority.

Also NB that SQL server was installed by another app - MX contact version 11, an Outlook add-on. So that’s a pretty complex installation.

Best wishes


Thank you for the information. We will exclude the apps that fail with certain error codes to be uploaded to the DB in the upcoming CPM version. You can uncheck the ‘Take Part in our Application Contribute Program’ option from Settings Tab until the next release comes out.
Thank you.

It’s a pleasure. Thanks for the feedback on intended action. Will do as you suggest.

Best wishes


  • Your Operating System (and whether it’s 32bit/64bit);windows 7 pro 32
  • Security Software Installed;cis 5.4
  • How you produced the problem;i used cpm to uinstall a program and now everytime i reboot it says CPM is performing its force delete process. this was a bug from beta 4 or 5
  • How you tried to resolve the problem;
  • Screen-shots with the error (if any);
  • Post Memory Dumps on crash if you encounter any;
  • All log files of CPM, if you had logs enabled;
  • Any other Additional Information;
  • Your Operating System (and whether it’s 32bit/64bit); windows 7 32
  • Security Software Installed; comodo firewall latest
  • How you produced the problem; unistalled comodo backup pro beta and rebooted before removing leftovers with cpm. when my system was booting got a BSOD from cumon.sys
  • How you tried to resolve the problem;na
  • Screen-shots with the error (if any);na
  • Post Memory Dumps on crash if you encounter any;i can create a minidump if requested but i cant find the post on how to do so
  • All log files of CPM, if you had logs enabled; attached
  • Any other Additional Information;

[attachment deleted by admin]

[attachment deleted by admin]

You can check for the minidump in windows\minidump directory or in windows directory for the memory.dmp file. Please zip it and post it for analyzes.
Thank you for your support.

there is no minidump folder ?

Please go to ‘Advanced System Settings’, in the ‘Advanced’ Tab go to ‘Startup and Recovery’ Settings and at
‘Write Debug Information’ select ‘Small Memory Dump’. You can now try to reproduce the issue and collect the dump file.
Thank you.

ok thanks for the help. if i can reproduce the bug i will edit my original post and attach the mini dump

Hi everyone,

I would like to report a possible bug.

Your Operating System (and whether it’s 32bit/64bit):
Windows 7 Ultimate sp1 32bits

Security Software Installed:

How you produced the problem:
prob 1. I clicked on Windows Updates tab and no update are listed
prob 2. In the Program tab, I select Orbit Downloader and clicked complete uninstall but a dialog box appears that ask to uninstall another program that is dependent on Orbit Downloader but these program are independent from each other.

How you tried to resolve the problem:
Yes, I’ve tried to reinstall the CPM

Screen-shots attached


[attachment deleted by admin]


We would appreciate if could you please tell us the status of the two dependent applications (Monitored or DB Monitored).
Also, could you tell us how the two applications were installed: did you install them successively or did they come in a bundle; the CPM version you used to monitor the applications (if their status is Monitored)?
Thank you for your report.

The two applications are both monitored and it comes with their own installer not bundled. At first I installed Orbit Downloader and used it to download the Pidgin when the download was finished, I run the installer and install Pidgin. There goes the problem when I complete uninstall Orbit Downloader. My CPM version is 1.2.188360.106