Comodo problem


I used to have Comodo in my last computer and I was very happy with it as a firewall. Now, after some time without computer, I have a new one and I installed Comodo Internet Security Premium on it, but I just noticed that my inboud connections are always in zero. I find this very strange, cuz in my last computer with other Comodo version (3, I think) there were always some inbound connections numbers, but this time is zero since I installed this Comodo weeks ago. Why is it always with Zero? Shouldn’t it show some numbers sometimes? I prefered Comodo when I could see that there were inbound connections and which ones they were.


Can you show us your Global Rules? What configuration are you using? Internet Security of Proactive Security configuration?

Hi Eric

I’m using Proactive Security. Here are the Global Rules (my Comodo is in portuguese, but I think you can “understand” the options by their order cuz it’s equal to the english one, I think):

I see you have not defined a trusted local network to connect with. Every application that may be listening for incoming traffic will not get it as there is no incoming traffic allowed for example from your router.

On what type of connection are you? ADSL or cable? Is there a router in your set up?

It is ADSL. What does “is there a router in your set up” means? If I have a router (I do)?

Usually ADSL modems have the router build in.

To see that you are behind a router I need to know your IP address. Easiest way to find it is to open Active Connections and look at the source address of your browser for example. It will most likely look like 192.68.1.x.

It appears local adress (192.168.2…101…) and foreign adresses.

Are you sharing your connection with others or are you the only user?

I’m sharing my connection with other computer.

Here is what I think. I think with the old version you probably made your local network a trusted zone. Making your local network a trusted zone will allow you to access printers, files and folder on other computers. The other computers can also access yours.

The following steps will make your local network trusted.

Go to My Network Zones (Firewall → Common Tasks) and see if there is already a network which looks like this 192.168.1.x/ If so edit it and name it My Local Network.

When there is no such network we will make one.

  • Choose Add → A New Network Zone → give it the name My Local Network → Apply.
  • Now select My Local Network → Add → A New Address → choose “An IP address mask” → fill in → Apply → Ok

Next step is to use the Stealth Ports Wizard to make your local network trusted. Follow the steps in Define a New Trusted Network - Stealth my ports to EVERYONE else from the online help file.

Now your local network is trusted and incoming traffic from the network is now allowed.

But EricJH, I don’t want to share or acess stuff in the other computer. It’s two computers in the same house, but we just want to share the Internet, not the files and so on. It’s two different persons.

I don’t know how to edit the local network as you said. There isn’t any button saying edit, add or anything at all.

I suggested to define a trusted local network because you said something was different because you saw no incoming traffic after installing the latest CIS.

Seeing no incoming traffic monitored is not abnormal. Your Global Rules as well the default rules of CIS do not allow incoming traffic that was not asked for.

Or are you referring to the firewall logs that show no unsolicited incoming traffic?

I’m talking about this:

In the other Comodo it used to appear like this (I found this image in the forum):

I could see that the action was blocked, from where it came and what was the destination. Now I can’t see, it’s always zero and I don’t feel completely secure.

The basic block rule in Global Rules has changed from “Block and log all IP” to “Block all IP”. The default setting does not log anymore. You need to edit it to make it log. :slight_smile:

I did what you said Eric, but I still have 0 inbound connections and my firewall log don’t show nothing but 2 old logs Firefox and RDesc. My list shouldn’t be bigger? :-\

This is how my Global Rules look:

And my Predefined Firewall Policies:

Please edit the block rule in Global Rules ( the red rule at the bottom) to make it log.

I see in Global Rules there are two trusted networks defined:

  • - Are you connected to two local networks? May be you are using a laptop at work and at home?
  • Area De Rede Local 1. How is this local network defined?


I have a router (with cable(s), not wireless) and it bring Internet to my computer (desktop) and to other in the house (a laptop). Both computers are always here, we don’t take them to work or anywhere else. But the laptop don’t have Comodo, just mine have it.

What do you mean? Is this the answer?

Sorry if I’m taking your time Eric; informatic is not my strengh and I just wish that Comodo was easier to work with. :-[

No problem. Along the way you will learn several things about CIS. It is never wasted energy.

Good to see you got the logging added to the block rule in Global Rules. In Global Rules remove the rules pointing to the ip addresses -

In the rule for System in Application Rules (Firewall → Network Security Policy) there may also be rules pointing to the IP addresses - If they are there you can remove them there too.

You mean and, right? The first ones in the image? Cuz there isn’t (1 is the difference).

The first ones in the image indeed.

Explanation. From your other screenshots I see your local network is in the 192.168.1. range. So the rules for the 192.168.200 range are not needed.