Comodo personal Firewall Alpha : Doesn't Check Local host Tcp or Udp Trafic

I just reinstaled an new system an wanted to try the new comodo but since this is an alpha i knew ther could be some issues.
The first thing i noticed is that the new comodo doesn’t check local host loopback trafic ( and there is no way for me to enable or dissable like it was back in 2.x series . The catch is this way if you run an transparent proxy ( i’m runing ghostsurf platinum 2007) or an program that filters HTTP trafic like and add blocker or pop up blocker ( Ad Muncher) all your http outbound conetions will pass even if they were not made by legitimate programs .Actualy i started System Mecahnic pro and i got outbound protection without the firewall noticing ( not even the HIPS module ) . >:(
My questions is if the new build will have once again the option to enable the tcp , udp , checking on the loopback interface .
By the way i’m quite impresed with the new version :BNC but i just was a bit disapointed by the lack of that feature. Keep up the good job :BNC

The Defense+ section has a rule for Loopback connections that you can allow/block for each process.

You can also monitor globally but just a bit differently…

In Defense +, go to Advanced, Defense + Settings, Monitor Settings. There’s a box, “Loopback Networking;” make sure it’s checked…


Even with all thoss options enabled comodo doesn’t monitor the trafic between more than 2 local host loopback conections.
This what i a mean : programs runing : Admuncher ( binds it’self to loopback interface on ports between 1100 and 1120 ) GhostSurf Pro Platinum 2007 ( binds to localhost port 7212) and any browser (Opera) and Bitdefender profesional ( the firewall module not instaled) .
Ok if i wanna acces any websites in opera the trafic goes this path : Opera has the folowing setup :proxy server = ( ghostsurf pro patinum,s port) but because admuncher hooks it self to any http requests the real trafic is opera makes request to Admuncher :1100-1120 ports then admuncher fowards the trafic to ghostsurf then the internet. The problem is that if both admuncher and ghostsurf pro platium are toghether any requests made from opera pass without any promt ( i left the options to ask ) so the localhost trafic leaks very easy :frowning: . This never happend in the 2.x series because then the trafic was picked up very easy opera - admuncher - ghostsurf -internet was very acurate.
I will submit a screenshot when i get back home because now i’m on some busines travell.

As you can see all the options are enabled and the only programs that have internet acces are admuncher and bitdefender updater. But when i just open an web page opera has direct internet acces ( no pop ups) and observ that the firewall allows this trafic since it beleives it’s coming from admuncher … The real problem is that the only programs that acces the internet here are opera and ghostsurf ( proxy.exe privacycontrolcenter.exe) and admuncher is mearly an intermidiar from them at loopback interface conetions :frowning: .
If you need more prof i will submit more screens .
Hope it will get fixed. I must say that in 2.x series the firewall picked up this kind of loopback trafic and i used to have certain rules to allow it now the trafic is very easy to fool.

[attachment deleted by admin]

Tnx for all the screenshots, KilJaden. I’m wondering if perhaps you haven’t responded to a popup somewhere and not realized it, thus creating an Exception entry for (most likely) Opera. I would look, not just at the Access Rights, but the Protection Settings, too, and check out what Exceptions may have created.

Not saying that there are any, just that it might be a possibility. Doesn’t hurt to look.

If not, please post about the issue in this thread
as that will be the primary place the developers check for issues/bugs. You don’t have go into a lot of detail, but do make sure to provide a link to this topic for reference.


No there wasn’t any pop up regarding the internet acces . Opera loaded the page without the firewall noticing it . I must say that the only time the firewall noticed opera’s internet activity was when i acces the internet without admuncher and ghostsurf this is why it’s allowed DNS trafic in those rules . Then i just deleted opera’s internet acces and the other rules rebooted and tried to see if it leaked and the pics is what i got :frowning:

I have been playing with some aspects of this firewall, and am finding some things that I consider less than optimal as far as how it allows some traffic like this, without seeming to give the user appropriate interaction. I have reported it in the same thread I gave a link in my earlier post.

I would suggest you do the same, so the development team will be sure to see it.

Wish I had a quick and easy answer for you, but I don’t. It looks to me like you may have uncovered a bug with the application… And good work for that! ;D


alpha randomly reboots the pc for no reason at all.
and also shuts down the pc completly.